summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-09-03 16:46:20 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-09-03 20:44:28 +0200
commit52feaf1d1b78d1970113068a7c3a4efdfb5c3d76 (patch)
treeafd3358291975f162451af80d7e4748e2e2dad55 /app-emacs/async
parentapp-emacs/async: bump to 1.9.9 (diff)
downloadgentoo-52feaf1d1b78d1970113068a7c3a4efdfb5c3d76.tar.gz
gentoo-52feaf1d1b78d1970113068a7c3a4efdfb5c3d76.tar.bz2
gentoo-52feaf1d1b78d1970113068a7c3a4efdfb5c3d76.zip
app-emacs/async: add live 9999 version
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/async')
-rw-r--r--app-emacs/async/async-9999.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-emacs/async/async-9999.ebuild b/app-emacs/async/async-9999.ebuild
new file mode 100644
index 000000000000..090af108d29c
--- /dev/null
+++ b/app-emacs/async/async-9999.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+REAL_PN="emacs-async"
+REAL_P="${REAL_PN}-${PV}"
+
+inherit elisp
+
+DESCRIPTION="Simple library for asynchronous processing in Emacs"
+HOMEPAGE="https://github.com/jwiegley/emacs-async/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/jwiegley/${REAL_PN}.git"
+else
+ SRC_URI="https://github.com/jwiegley/${REAL_PN}/archive/v${PV}.tar.gz
+ -> ${REAL_P}.tar.gz"
+ S="${WORKDIR}/${REAL_PN}-${PV}"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+elisp-enable-tests buttercup
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}