summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2021-04-22 17:01:45 +0200
committerUlrich Müller <ulm@gentoo.org>2021-04-22 17:14:05 +0200
commitd4bc07ec157acc2eeb684ac885e94be5b8151c16 (patch)
tree899b0a5ad05f82ef8d2f8447d38505bc1acede22 /app-emacs/dash/dash-2.18.1.ebuild
parentsys-devel/clang: Add M68k to 13.0.0.9999 (diff)
downloadgentoo-d4bc07ec157acc2eeb684ac885e94be5b8151c16.tar.gz
gentoo-d4bc07ec157acc2eeb684ac885e94be5b8151c16.tar.bz2
gentoo-d4bc07ec157acc2eeb684ac885e94be5b8151c16.zip
app-emacs/dash: Version bump to 2.18.1
Closes: https://bugs.gentoo.org/785058 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-emacs/dash/dash-2.18.1.ebuild')
-rw-r--r--app-emacs/dash/dash-2.18.1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-emacs/dash/dash-2.18.1.ebuild b/app-emacs/dash/dash-2.18.1.ebuild
new file mode 100644
index 000000000000..62c3a1a1c7f3
--- /dev/null
+++ b/app-emacs/dash/dash-2.18.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit elisp
+
+DESCRIPTION="A modern list library for Emacs"
+HOMEPAGE="https://github.com/magnars/dash.el"
+SRC_URI="https://github.com/magnars/dash.el/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="sys-apps/texinfo"
+
+S="${WORKDIR}/${PN}.el-${PV}"
+SITEFILE="50${PN}-gentoo.el"
+ELISP_TEXINFO="dash.texi"
+DOCS="README.md"
+
+src_test() {
+ ./run-tests.sh || die
+}