summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArsen Arsenović <arsen@gentoo.org>2024-02-04 17:22:53 +0100
committerArsen Arsenović <arsen@gentoo.org>2024-02-04 17:31:14 +0100
commit9c9f4f9a30c4e9e50458094a314c4558ac09f89f (patch)
tree8958c79c16799e4c6a75470c4080d811f72dabba /app-emacs/jinx
parentsys-kernel/git-sources: add 6.8_rc3 (diff)
downloadgentoo-9c9f4f9a30c4e9e50458094a314c4558ac09f89f.tar.gz
gentoo-9c9f4f9a30c4e9e50458094a314c4558ac09f89f.tar.bz2
gentoo-9c9f4f9a30c4e9e50458094a314c4558ac09f89f.zip
app-emacs/jinx: add 1.2
Signed-off-by: Arsen Arsenović <arsen@gentoo.org>
Diffstat (limited to 'app-emacs/jinx')
-rw-r--r--app-emacs/jinx/Manifest1
-rw-r--r--app-emacs/jinx/jinx-1.2.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/app-emacs/jinx/Manifest b/app-emacs/jinx/Manifest
index b395004e8c99..19876cf55ea6 100644
--- a/app-emacs/jinx/Manifest
+++ b/app-emacs/jinx/Manifest
@@ -1,3 +1,4 @@
DIST jinx-0.9.tar.xz 20852 BLAKE2B 09a6a765cf51c2efe3a90317cdaeff03c2bc35bd6202b71070a19d51189c2ee6fc7406881130986dcdcfd9a9f6cec4aee25e0e71924a38aca7708aa3b99eb550 SHA512 a61e377fdee84fc91c3714f12f1bfffd95d6618a78c48dbcda6ff134f2ce3b604f283ddc5e7040c125e406ec573e3f6e7bfcde681fe574b84d7736e114ea7c0b
DIST jinx-1.0.tar.gz 33255 BLAKE2B 19edfc30e85b5da047962f61256036c2e07fdb304632e8a07edd313616343214e74a981ca971eacf5ec23e595144edb4f511313c94140639d85b704d0517d9a3 SHA512 7990d7bb090ad8aec6afdaa68d7125ad2dfe0259327afd596f9f6c44b4b80f29a92aa6f0057f85f76f42b28004240edc85eb8e48ef21e02c95643e138751bbba
DIST jinx-1.1.tar.gz 33820 BLAKE2B 457214768c7220376a8f1e5c05eedf855fdd560b265ca0431840aee05428d1cf3576e3ef0214cf64b164984adb0951e7932271dd80b6b0d06ed740172335c5fe SHA512 3bb1981557e35d3834834cbdc0fc1360b5a931f0e16cc68c2eb0739956db9e8e97d615236e575758cbb282087a7baad3c956fc9e628679a791ca744e8365355b
+DIST jinx-1.2.tar.gz 33991 BLAKE2B 37661f5d02bb3f1a1813bd5d4e78b6c6c115ef40fa1f346685956a02486870fbccb570490e05029550e281e0be02bde12f6cdd5b3bf6dc67041cab294759585d SHA512 bc5caa73a348c3a5aae6322290823c60f48127b915e173ae08385ee979e94d4d05c733ad0003c5ac4702828de5dffd2dfb88c7da720bafa4a85665657579e0d0
diff --git a/app-emacs/jinx/jinx-1.2.ebuild b/app-emacs/jinx/jinx-1.2.ebuild
new file mode 100644
index 000000000000..fd1936d0c50c
--- /dev/null
+++ b/app-emacs/jinx/jinx-1.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+inherit edo elisp toolchain-funcs
+
+DESCRIPTION="Enchanted Spell Checker for GNU Emacs"
+HOMEPAGE="https://github.com/minad/jinx"
+
+SRC_URI="
+ https://github.com/minad/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz
+"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ app-text/enchant:2
+ >=app-emacs/compat-29.1.4.0
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+SITEFILE="50${PN}-gentoo.el"
+
+ELISP_TEXINFO="${PN}.texi"
+
+src_compile() {
+ edo $(tc-getCC) -fPIC -Wall -Wextra -shared \
+ $($(tc-getPKG_CONFIG) --cflags --libs enchant-2) \
+ ${CPPFLAGS} ${CFLAGS} ${LDFLAGS} -o jinx-mod.so jinx-mod.c
+ elisp-org-export-to texinfo README.org
+ elisp_src_compile
+}
+
+src_install() {
+ elisp-make-autoload-file
+ elisp_src_install
+
+ elisp-modules-install "${PN}" jinx-mod.so
+ doinfo jinx.info
+}