summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-12-27 18:00:28 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-12-27 19:51:54 +0100
commit30fbca1305eeeca4c0bb920f8c043f635f6a7f05 (patch)
treee137d9d88a3293bff91890e499a9c839050e2fbe /app-emacs
parentwww-servers/kore: bump to 4.3.0_rc4 (diff)
downloadgentoo-30fbca1305eeeca4c0bb920f8c043f635f6a7f05.tar.gz
gentoo-30fbca1305eeeca4c0bb920f8c043f635f6a7f05.tar.bz2
gentoo-30fbca1305eeeca4c0bb920f8c043f635f6a7f05.zip
app-emacs/consult: bump to 1.9
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/consult/Manifest1
-rw-r--r--app-emacs/consult/consult-1.9.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/app-emacs/consult/Manifest b/app-emacs/consult/Manifest
index 320de8d6dc33..8d67e19109f0 100644
--- a/app-emacs/consult/Manifest
+++ b/app-emacs/consult/Manifest
@@ -1 +1,2 @@
DIST consult-1.8.tar.gz 104909 BLAKE2B b946274cc83e0b3372895c30e2d3b303bc9c5f7c4da7a8f4fc9521ac96f60e3c07e17df6bee7f9ec3594ff3d3fcdbdc21ea1cd6ccb74c8cc0d13bfd42b0ddd9d SHA512 3497be58ab11338453864a77b35e23f60f4c9ba901f4a335428671d629bc8d92f3dddb47ded9876a7964603935714851ebbc4bedcded254fb6cb0ef80b415601
+DIST consult-1.9.tar.gz 106013 BLAKE2B 17b55f08821a77a3267547111f335b422adc62698faa1901f9197e6dece441d0d087215cc91188e90cc5bdd0ce9b41903d73338cc48c0d082d290cfd588e3e63 SHA512 bc85c2a5cab4b1b94bf53aee822d3efa2f38d9efc39f10596023b755d94de092ab0715cab17b625ffeb2c3bfdcbe57925d1f2dd4857363d62f8ea03f85d6e959
diff --git a/app-emacs/consult/consult-1.9.ebuild b/app-emacs/consult/consult-1.9.ebuild
new file mode 100644
index 000000000000..7f3ed9bf0123
--- /dev/null
+++ b/app-emacs/consult/consult-1.9.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27
+
+inherit elisp
+
+DESCRIPTION="Consulting complete-read for GNU Emacs"
+HOMEPAGE="https://github.com/minad/consult/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/minad/${PN}.git"
+else
+ SRC_URI="https://github.com/minad/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ >=app-emacs/compat-28.1
+"
+BDEPEND="
+ ${RDEPEND}
+"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}