summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-12-27 18:21:27 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-12-27 19:51:58 +0100
commit3b511bff0e480c143c317e0c25224f9c4f39301e (patch)
tree1466e07df7c9b6a17eb4ffba0d2c4a8018bbc88c /app-emacs
parentapp-emacs/tempel: drop old 1.1 (diff)
downloadgentoo-3b511bff0e480c143c317e0c25224f9c4f39301e.tar.gz
gentoo-3b511bff0e480c143c317e0c25224f9c4f39301e.tar.bz2
gentoo-3b511bff0e480c143c317e0c25224f9c4f39301e.zip
app-emacs/tempel: bump to 1.3
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/tempel/Manifest1
-rw-r--r--app-emacs/tempel/tempel-1.3.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/app-emacs/tempel/Manifest b/app-emacs/tempel/Manifest
index 3c8f9430813d..ef365c36c4eb 100644
--- a/app-emacs/tempel/Manifest
+++ b/app-emacs/tempel/Manifest
@@ -1 +1,2 @@
DIST tempel-1.2.tar.gz 27574 BLAKE2B 6a0fc8fde62b80e67e1367c0b33cf5e37a5e9d557ebfb7533a2c70b4279bdbaf5d477f6f76ae47866dda0a4933563eae19d0e29385430784804a8c60d45d4c42 SHA512 60b0400dd4dc35ec29727a7ab34331a1a5c4f9f9cc7035994f49ea4d4313ce2d0f5a70d3b0da4c0a27649a9171c7398dcd37871cb77340f271657f045e83e3d3
+DIST tempel-1.3.tar.gz 27980 BLAKE2B fc094edcb137420ddb484417a86006bafca999d455dd1a7e532e85e30936e9db807e0618673688088739b9af245fb162d8d026f260c9e2f9bc5651d3118a12a3 SHA512 bad06d73882caf2e1624d8610182c5a264450121d2fc5425ad4a0d7075a33ccdf27f0252d54592730a5a58758a5b038201d7303d11f4101802f71cba0d9f66ca
diff --git a/app-emacs/tempel/tempel-1.3.ebuild b/app-emacs/tempel/tempel-1.3.ebuild
new file mode 100644
index 000000000000..a892a8e9058a
--- /dev/null
+++ b/app-emacs/tempel/tempel-1.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS="27.1"
+
+inherit elisp
+
+DESCRIPTION="Templates with in-buffer field editing for GNU Emacs"
+HOMEPAGE="https://github.com/minad/tempel/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/minad/${PN}.git"
+else
+ SRC_URI="https://github.com/minad/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ >=app-emacs/compat-29.1.3.4
+"
+BDEPEND="
+ ${RDEPEND}
+"
+
+DOCS=( README.org )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}