summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Turner <jturner.usa@gmail.com>2022-04-06 21:37:43 -0400
committerMatthew Smith <matthew@gentoo.org>2022-04-10 12:18:40 +0100
commitb399a43333eb898b570e427adf0e64fc12b9f8c0 (patch)
tree8ebccefe354281905f4db684d6f85d6e57a723b4 /app-emacs
parentgames-action/supertuxkart: Depend on libsdl2[opengl,video] USE flags (diff)
downloadgentoo-b399a43333eb898b570e427adf0e64fc12b9f8c0.tar.gz
gentoo-b399a43333eb898b570e427adf0e64fc12b9f8c0.tar.bz2
gentoo-b399a43333eb898b570e427adf0e64fc12b9f8c0.zip
app-emacs/flycheck: add 32_p20220328
Signed-off-by: John Turner <jturner.usa@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/24911 Signed-off-by: Matthew Smith <matthew@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/flycheck/Manifest1
-rw-r--r--app-emacs/flycheck/files/50flycheck-gentoo-r1.el2
-rw-r--r--app-emacs/flycheck/flycheck-32_p20220328.ebuild31
3 files changed, 34 insertions, 0 deletions
diff --git a/app-emacs/flycheck/Manifest b/app-emacs/flycheck/Manifest
index 5195b9be5be0..8abe02aeda55 100644
--- a/app-emacs/flycheck/Manifest
+++ b/app-emacs/flycheck/Manifest
@@ -1 +1,2 @@
DIST flycheck-32_p20210825.tar.gz 1042020 BLAKE2B 1663340de24980b3a1e58929e327841b743495dbd5d5c8306f007d0dfa989707015ceadaf6e5cac673eddb45adf9ec05dc35d8cb35af322c9cde6644194dd75d SHA512 472e25956d804e7f7ba8ebda2e3a7527eaaf3aee47fa5bd43a46ae651f94d857657cf4594f5a1ed0c169ec0ac610139956d182818ffeedf2c4132a5583ca870d
+DIST flycheck-32_p20220328.tar.gz 1037565 BLAKE2B 385d73e9ccae06db09d23819600317b807b7ff8cf0679be510cac27d539e57374fffd67575687067e8d6beeae66472b2831a5ece4adbe7b85da9b484dc8b6346 SHA512 f2c5dad66a1bae826f1b48242d3b1202cf41615fa2eadba55c4aabbbd9616ca873ba93c8c9f53cbefc22587b70ed1a2cd4fcbdcb2d6caf13d0c21c4d36e4ffc7
diff --git a/app-emacs/flycheck/files/50flycheck-gentoo-r1.el b/app-emacs/flycheck/files/50flycheck-gentoo-r1.el
new file mode 100644
index 000000000000..46ab676a9a2a
--- /dev/null
+++ b/app-emacs/flycheck/files/50flycheck-gentoo-r1.el
@@ -0,0 +1,2 @@
+(add-to-list 'load-path "@SITELISP@")
+(load "@SITELISP@/flycheck-autoloads")
diff --git a/app-emacs/flycheck/flycheck-32_p20220328.ebuild b/app-emacs/flycheck/flycheck-32_p20220328.ebuild
new file mode 100644
index 000000000000..0d92a6a59ff8
--- /dev/null
+++ b/app-emacs/flycheck/flycheck-32_p20220328.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS="24.3"
+
+inherit elisp
+
+DESCRIPTION="Modern on-the-fly syntax checking extension for GNU Emacs"
+HOMEPAGE="https://www.flycheck.org/"
+COMMIT="3b5b4248074f016922c2674789d4a242528cf4c7"
+SRC_URI="https://github.com/flycheck/flycheck/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="test" # test requires cask and ert-runner which are not packaged yet
+
+RDEPEND=">=app-emacs/dash-2.12.1
+ >=app-emacs/pkg-info-0.4"
+
+SITEFILE="50${PN}-gentoo-r1.el"
+DOCS=( README.md )
+ELISP_REMOVE="flycheck-buttercup.el flycheck-ert.el"
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}