summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-05-20 00:49:32 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-05-20 01:14:04 +0200
commitc82a314dd061d62bad7fb7e4145ca91c6596d4d3 (patch)
treedbd0dfc28eff711b7ee684bed20d32600d3b7cab /app-emacs
parentx11-apps/mesa-progs: Keyword 9.0.0 loong, #930206 (diff)
downloadgentoo-c82a314dd061d62bad7fb7e4145ca91c6596d4d3.tar.gz
gentoo-c82a314dd061d62bad7fb7e4145ca91c6596d4d3.tar.bz2
gentoo-c82a314dd061d62bad7fb7e4145ca91c6596d4d3.zip
app-emacs/embark: bump to 1.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/embark/Manifest1
-rw-r--r--app-emacs/embark/embark-1.1.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/app-emacs/embark/Manifest b/app-emacs/embark/Manifest
index 7d4fde8bd536..6f0531f43525 100644
--- a/app-emacs/embark/Manifest
+++ b/app-emacs/embark/Manifest
@@ -1 +1,2 @@
DIST embark-1.0.tar.gz 112818 BLAKE2B 111203ec462b06f11dae9760a64d27e197faa13cefe1eb4debd2e7222380aab0ccad19587ee275f343bb0e2a716379e67209e27dcaa0aaaa7a98f97f660fb6f5 SHA512 ca42c6bd428807aefee6e7bb817651577401be8adacbd64146e97bd07ddd8df325dfeafeaa824fd3f4cd289da1a9b4868f44feacb66585f2533b64fa4d594d22
+DIST embark-1.1.tar.gz 115762 BLAKE2B 69fc4005b901dcfd85ad124dc449048a13223277683eba7c5c873cd8050883ab53b4c3716670894e146da9c40c1789eafff3df4d00eb0ee46a8dab4c165f01ab SHA512 29c87eaf3275428cfbd442de3a09d7a126094bc90bb1b1c34f476caf11cd3da21ce9368ef7d1855732250a85b269b01effcd514da10e1e491ecb3bdc61efd750
diff --git a/app-emacs/embark/embark-1.1.ebuild b/app-emacs/embark/embark-1.1.ebuild
new file mode 100644
index 000000000000..9b53ee20a240
--- /dev/null
+++ b/app-emacs/embark/embark-1.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+
+inherit elisp optfeature
+
+DESCRIPTION="Conveniently act on minibuffer completions inside GNU Emacs"
+HOMEPAGE="https://github.com/oantolin/embark/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/oantolin/${PN}.git"
+else
+ SRC_URI="https://github.com/oantolin/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND=">=app-emacs/compat-29.1.4.0"
+BDEPEND="${RDEPEND}"
+
+ELISP_REMOVE="avy-embark-collect.el embark-consult.el"
+
+DOCS=( README.org )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+
+ elisp-make-autoload-file
+}
+
+src_install() {
+ elisp_src_install
+
+ doinfo ${PN}.texi
+}
+
+pkg_postinst() {
+ elisp_pkg_postinst
+
+ optfeature "Avy integration for Embark" app-emacs/avy-embark-collect
+ optfeature "Consult integration for Embark" app-emacs/embark-consult
+}