summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArsen Arsenović <arsen@gentoo.org>2024-12-15 22:55:16 +0100
committerArsen Arsenović <arsen@gentoo.org>2024-12-16 20:32:21 +0100
commitd550838df7def8a217a0b5ff17fc7bf6abe5a2f7 (patch)
tree43049833aca445de83004695ae2a39c538036fda /app-emacs
parentapp-emacs/jsonrpc: new package, add 1.0.25 (diff)
downloadgentoo-d550838df7def8a217a0b5ff17fc7bf6abe5a2f7.tar.gz
gentoo-d550838df7def8a217a0b5ff17fc7bf6abe5a2f7.tar.bz2
gentoo-d550838df7def8a217a0b5ff17fc7bf6abe5a2f7.zip
app-emacs/dape: new package, add 0.17.0
Signed-off-by: Arsen Arsenović <arsen@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/dape/Manifest1
-rw-r--r--app-emacs/dape/dape-0.17.0.ebuild67
-rw-r--r--app-emacs/dape/files/50dape-gentoo.el3
-rw-r--r--app-emacs/dape/metadata.xml19
4 files changed, 90 insertions, 0 deletions
diff --git a/app-emacs/dape/Manifest b/app-emacs/dape/Manifest
new file mode 100644
index 000000000000..16590727787e
--- /dev/null
+++ b/app-emacs/dape/Manifest
@@ -0,0 +1 @@
+DIST dape-0.17.0.tar.gz 77229 BLAKE2B f0942019fe6215b416cecce89b01a81bb450a615ff2898d3c67788b6c3575bbe72c1420d27b6796a619c3403a6a94e717db805e553212c0bc8a07d5ae9e6670a SHA512 a0f26ecee4ec2cd8e57035ee58f15562e3d11b61203ded80e5560951e2f37a7a1c00c44538d75699c902b39cf9d2a59edcb1a528f6ce12351717fdd6136ae6e8
diff --git a/app-emacs/dape/dape-0.17.0.ebuild b/app-emacs/dape/dape-0.17.0.ebuild
new file mode 100644
index 000000000000..0b0fa9977676
--- /dev/null
+++ b/app-emacs/dape/dape-0.17.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=29.1
+
+inherit elisp
+
+DESCRIPTION="Debug Adapter Protocol for Emacs"
+HOMEPAGE="https://github.com/svaante/dape"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/svaante/${PN}.git"
+else
+ SRC_URI="https://github.com/svaante/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ || (
+ app-emacs/jsonrpc
+ >=app-editors/emacs-30:*
+ )
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+# Requires debugpy, but we do not package debugpy right now, as well as
+# js-debug. Most tests use only the former.
+RESTRICT="test"
+
+DOCS=( README.org CHANGELOG.org LICENSE )
+SITEFILE="50${PN}-gentoo.el"
+
+# elisp-enable-tests ert . -l dape-tests.el
+
+pkg_setup() {
+ elisp_pkg_setup
+ local has_jsonrpc="$(${EMACS} ${EMACSFLAGS} \
+ --eval "(princ (>= emacs-major-version 30))")"
+ if has_version app-emacs/jsonrpc || [[ ${has_jsonrpc} = t ]]; then
+ :
+ else
+ die "Emacs does not have jsonrpc.el 1.0.25 or later, nor was app-emacs/jsonrpc installed"
+ fi
+}
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}
+
+# src_test() {
+# elisp-test
+# }
+
+elisp_src_install() {
+ # Need to ignore dape-tests.el.
+ einstalldocs
+ elisp-install "${PN}" dape.el dape.elc dape-autoloads.el
+}
diff --git a/app-emacs/dape/files/50dape-gentoo.el b/app-emacs/dape/files/50dape-gentoo.el
new file mode 100644
index 000000000000..a9e318c2f6f9
--- /dev/null
+++ b/app-emacs/dape/files/50dape-gentoo.el
@@ -0,0 +1,3 @@
+;;; app-emacs/dape site configuration -*- lexical-binding: t; -*-
+(add-to-list 'load-path "@SITELISP@")
+(load "@SITELISP@/dape-autoloads.el" nil t)
diff --git a/app-emacs/dape/metadata.xml b/app-emacs/dape/metadata.xml
new file mode 100644
index 000000000000..1d0732121c49
--- /dev/null
+++ b/app-emacs/dape/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>arsen@gentoo.org</email>
+ <description>Arsen Arsenović</description>
+ </maintainer>
+ <maintainer type="person">
+ <email>sam@gentoo.org</email>
+ <description>Sam James</description>
+ </maintainer>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">svaante/dape</remote-id>
+ </upstream>
+</pkgmetadata>