summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2016-10-01 17:33:36 -0500
committerAlex Brandt <alunduil@gentoo.org>2016-10-01 17:33:36 -0500
commit34d6893a3b21eb48d776f7c5344cfd111c3382d3 (patch)
tree12afca7a761417b5470a91d611768566d1ef75e5 /app-emulation/docker-compose/docker-compose-1.8.1.ebuild
parentdev-python/stormpath: remove version 2.4.1 (diff)
downloadgentoo-34d6893a3b21eb48d776f7c5344cfd111c3382d3.tar.gz
gentoo-34d6893a3b21eb48d776f7c5344cfd111c3382d3.tar.bz2
gentoo-34d6893a3b21eb48d776f7c5344cfd111c3382d3.zip
app-emulation/docker-compose: add version 1.8.1
Package-Manager: portage-2.3.1
Diffstat (limited to 'app-emulation/docker-compose/docker-compose-1.8.1.ebuild')
-rw-r--r--app-emulation/docker-compose/docker-compose-1.8.1.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/app-emulation/docker-compose/docker-compose-1.8.1.ebuild b/app-emulation/docker-compose/docker-compose-1.8.1.ebuild
new file mode 100644
index 000000000000..f3bd7dfe82da
--- /dev/null
+++ b/app-emulation/docker-compose/docker-compose-1.8.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_4 )
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Multi-container orchestration for Docker"
+HOMEPAGE="https://www.docker.com/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+CDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/cached-property-1.2.0[${PYTHON_USEDEP}]
+ <dev-python/cached-property-2[${PYTHON_USEDEP}]
+ >=dev-python/dockerpty-0.4.1[${PYTHON_USEDEP}]
+ <dev-python/dockerpty-0.5[${PYTHON_USEDEP}]
+ >=dev-python/docker-py-1.10.3[${PYTHON_USEDEP}]
+ <dev-python/docker-py-2.0[${PYTHON_USEDEP}]
+ >=dev-python/docopt-0.6.1[${PYTHON_USEDEP}]
+ <dev-python/docopt-0.7[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-2.5.1[${PYTHON_USEDEP}]
+ <dev-python/jsonschema-3[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}]
+ <dev-python/pyyaml-4[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.6.1[${PYTHON_USEDEP}]
+ <dev-python/requests-2.8[${PYTHON_USEDEP}]
+ >=dev-python/six-1.3.0[${PYTHON_USEDEP}]
+ <dev-python/six-2[${PYTHON_USEDEP}]
+ >=dev-python/texttable-0.8.1[${PYTHON_USEDEP}]
+ <dev-python/texttable-0.9[${PYTHON_USEDEP}]
+ >=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]
+ <dev-python/websocket-client-1.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/enum34-1.0.4[${PYTHON_USEDEP}]' 'python2_7' )
+ $(python_gen_cond_dep '<dev-python/enum34-2[${PYTHON_USEDEP}]' 'python2_7' )
+"
+DEPEND="
+ test? (
+ ${CDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/mock-1.0.1[${PYTHON_USEDEP}]' 'python2_7' )
+ )
+"
+RDEPEND="${CDEPEND}"
+
+python_test() {
+ ${PYTHON} -m pytest tests/unit || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ newbashcomp contrib/completion/bash/docker-compose ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ doins contrib/completion/zsh/*
+
+ distutils-r1_python_install_all
+}