summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2024-02-10 12:21:30 +0200
committerViorel Munteanu <ceamac@gentoo.org>2024-02-10 18:30:47 +0200
commita3da55ebfaa341d2e4f248221a00c4357d4f7db4 (patch)
tree0ddb258d8c57528844dcb548f058a5daf0a749d5 /app-emulation/virtualbox/files
parentapp-emulation/virtualbox: move patches to patchset (diff)
downloadgentoo-a3da55ebfaa341d2e4f248221a00c4357d4f7db4.tar.gz
gentoo-a3da55ebfaa341d2e4f248221a00c4357d4f7db4.tar.bz2
gentoo-a3da55ebfaa341d2e4f248221a00c4357d4f7db4.zip
app-emulation/virtualbox: move more patches to patchset
Move the patches for live version to the patchset too. Don't move the patches for 6.1 branch, because it is EOL. Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'app-emulation/virtualbox/files')
-rw-r--r--app-emulation/virtualbox/files/virtualbox-7.0.0-fix-compilation-clang.patch44
-rw-r--r--app-emulation/virtualbox/files/virtualbox-7.0.10-fix-binutils-hardened.patch35
-rw-r--r--app-emulation/virtualbox/files/virtualbox-7.0.11-configure-include-qt6-path.patch13
-rw-r--r--app-emulation/virtualbox/files/virtualbox-7.0.6-gcc-13.patch28
-rw-r--r--app-emulation/virtualbox/files/virtualbox-7.0.8-mtune-keep-size.patch13
-rw-r--r--app-emulation/virtualbox/files/virtualbox-7.0.9-python.patch22
6 files changed, 0 insertions, 155 deletions
diff --git a/app-emulation/virtualbox/files/virtualbox-7.0.0-fix-compilation-clang.patch b/app-emulation/virtualbox/files/virtualbox-7.0.0-fix-compilation-clang.patch
deleted file mode 100644
index c3e34f875acd..000000000000
--- a/app-emulation/virtualbox/files/virtualbox-7.0.0-fix-compilation-clang.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-clang does not have syslimits.h, it is gcc specific
-and it is useless anyway since <limits.h> is already included
-so just remove it
-
-Cannot use PFNRT here on clang because of the exception specification
-
---- a/src/VBox/ExtPacks/VBoxDTrace/include/VBoxDTraceLibCWrappers.h
-+++ b/src/VBox/ExtPacks/VBoxDTrace/include/VBoxDTraceLibCWrappers.h
-@@ -34,8 +34,6 @@
- # include <limits.h> /* Workaround for syslimit.h bug in gcc 4.8.3 on gentoo. */
- # ifdef RT_OS_DARWIN
- # include <sys/syslimits.h> /* PATH_MAX */
--# elif !defined(RT_OS_SOLARIS) && !defined(RT_OS_FREEBSD)
--# include <syslimits.h> /* PATH_MAX */
- # endif
- # include <libgen.h> /* basename */
- # include <unistd.h>
---- a/src/VBox/Devices/Graphics/DevVGA-SVGA3d-glLdr.h
-+++ b/src/VBox/Devices/Graphics/DevVGA-SVGA3d-glLdr.h
-@@ -97,7 +97,11 @@
- /** Load OpenGL library and initialize function pointers. */
- int glLdrInit(PPDMDEVINS pDevIns);
- /** Resolve an OpenGL function name. */
-+#ifdef __clang__
-+void* glLdrGetProcAddress(const char *pszSymbol);
-+#else // !__clang__
- PFNRT glLdrGetProcAddress(const char *pszSymbol);
-+#endif // !__clang__
- /** Get pointers to extension function. They are available on Windows only when OpenGL context is set. */
- int glLdrGetExtFunctions(PPDMDEVINS pDevIns);
-
---- a/src/VBox/Devices/Graphics/DevVGA-SVGA3d-glLdr.cpp
-+++ b/src/VBox/Devices/Graphics/DevVGA-SVGA3d-glLdr.cpp
-@@ -35,6 +35,10 @@
- #include <iprt/ldr.h>
- #include <iprt/log.h>
-
-+#ifdef __clang__
-+# define PFNRT void*
-+#endif
-+
- #ifdef RT_OS_WINDOWS
- # define OGLGETPROCADDRESS MyWinGetProcAddress
- DECLINLINE(PFNRT) MyWinGetProcAddress(const char *pszSymbol)
diff --git a/app-emulation/virtualbox/files/virtualbox-7.0.10-fix-binutils-hardened.patch b/app-emulation/virtualbox/files/virtualbox-7.0.10-fix-binutils-hardened.patch
deleted file mode 100644
index 1a5f85f89ff8..000000000000
--- a/app-emulation/virtualbox/files/virtualbox-7.0.10-fix-binutils-hardened.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-Fix building with sys-devel/binutils-2.41-r1[hardened]: read-only segment has dynamic relocations.
-https://bugs.gentoo.org/913109
-
---- a/src/VBox/Runtime/Makefile.kmk
-+++ b/src/VBox/Runtime/Makefile.kmk
-@@ -3238,6 +3238,7 @@
- endif
- endif
- RuntimeR0_INCS = include
-+RuntimeR0_LDFLAGS.linux = -z notext
- RuntimeR0_SOURCES := \
- $(if $(VBOX_ONLY_VALIDATIONKIT),,../VMM/VBoxVMM.d) \
- common/checksum/crc32c.cpp \
---- a/src/VBox/VMM/Makefile.kmk
-+++ b/src/VBox/VMM/Makefile.kmk
-@@ -603,6 +603,8 @@
- VMMR0_DEFS.darwin.amd64 += VBOX_WITH_NATIVE_NEM VBOX_WITH_NEM_R0
- endif
-
-+ VMMR0_LDFLAGS.linux += -z notext
-+
- $(call VBOX_SET_VER_INFO_R0,VMMR0,VirtualBox VMM - ring-0 context parts) # Version info / description.
-
- if "$(USERNAME)" == "bird" && "$(KBUILD_TARGET)" == "win"
---- a/src/VBox/ExtPacks/VBoxDTrace/Makefile.kmk
-+++ b/src/VBox/ExtPacks/VBoxDTrace/Makefile.kmk
-@@ -258,7 +258,7 @@
- VBoxDTraceR0_TEMPLATE = VBoxR0ExtPackDTrace
- VBoxDTraceR0_DEFS = IN_VBOXDTRACE_R0 IN_RT_R0
- ifeq ($(VBOX_LDR_FMT),elf)
-- VBoxDTraceR0_LDFLAGS = -e ModuleInit
-+ VBoxDTraceR0_LDFLAGS = -e ModuleInit -z notext
- endif
- VBoxDTraceR0_INCS = \
- include \
diff --git a/app-emulation/virtualbox/files/virtualbox-7.0.11-configure-include-qt6-path.patch b/app-emulation/virtualbox/files/virtualbox-7.0.11-configure-include-qt6-path.patch
deleted file mode 100644
index a9345ae78141..000000000000
--- a/app-emulation/virtualbox/files/virtualbox-7.0.11-configure-include-qt6-path.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/configure b/configure
-index 5d653d97..f6953d88 100755
---- a/configure
-+++ b/configure
-@@ -1695,6 +1695,8 @@ EOF
- else
- # Strip .../QtCore as we add components ourself:
- INCQT6=`echo "$INCQT6"|$KBUILD_SED 's|\([^ ]*\)/QtCore|\1|g; s| $||g'`
-+ # Strip .../QtGui as we add components ourself:
-+ INCQT6=`echo "$INCQT6"|$KBUILD_SED 's|\([^ ]*\)/QtGui|\1|g; s| $||g'`
- # store only the first path, remove all other paths
- # most likely pkg-config gave us -I/usr/include/qt6 -I/usr/include/qt6/QtCore
- INCQT6=`echo "$INCQT6"|$KBUILD_SED 's|\([^ ]*\) .*|\1|'`
diff --git a/app-emulation/virtualbox/files/virtualbox-7.0.6-gcc-13.patch b/app-emulation/virtualbox/files/virtualbox-7.0.6-gcc-13.patch
deleted file mode 100644
index ed3a2d02fbc0..000000000000
--- a/app-emulation/virtualbox/files/virtualbox-7.0.6-gcc-13.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-Add a few missing includes.
-
-Bug: https://bugs.gentoo.org/892852
-
---- a/src/libs/dxvk-native-1.9.2a/src/util/util_matrix.cpp
-+++ b/src/libs/dxvk-native-1.9.2a/src/util/util_matrix.cpp
-@@ -1,3 +1,4 @@
-+#include <cstdint>
- #include "util_matrix.h"
-
- namespace dxvk {
-@@ -229,4 +230,4 @@
- return os;
- }
-
--}
-\ No newline at end of file
-+}
---- a/src/libs/dxvk-native-1.9.2a/src/util/util_vector.h
-+++ b/src/libs/dxvk-native-1.9.2a/src/util/util_vector.h
-@@ -1,6 +1,7 @@
- #pragma once
-
- #include <iostream>
-+#include <cstdint>
-
- #include "util_bit.h"
- #include "util_math.h"
diff --git a/app-emulation/virtualbox/files/virtualbox-7.0.8-mtune-keep-size.patch b/app-emulation/virtualbox/files/virtualbox-7.0.8-mtune-keep-size.patch
deleted file mode 100644
index e37d9d6dcb94..000000000000
--- a/app-emulation/virtualbox/files/virtualbox-7.0.8-mtune-keep-size.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Force -mtune=i386. Random -mtune can lead to iPxeBiosBin.rom getting too
-large (larger than 56k). This can happen because we support custom CFLAGS.
-
---- a/src/VBox/Devices/PC/ipxe/Makefile.kmk
-+++ b/src/VBox/Devices/PC/ipxe/Makefile.kmk
-@@ -125,6 +125,7 @@
- -ffreestanding \
- -ffunction-sections \
- -march=i386 \
-+ -mtune=i386 \
- -fomit-frame-pointer \
- -fstrength-reduce \
- -falign-jumps=1 \
diff --git a/app-emulation/virtualbox/files/virtualbox-7.0.9-python.patch b/app-emulation/virtualbox/files/virtualbox-7.0.9-python.patch
deleted file mode 100644
index 73d529628cbb..000000000000
--- a/app-emulation/virtualbox/files/virtualbox-7.0.9-python.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-Virtualbox 7.x will only build a lib named VBoxPython3.so, regardless of the
-actual python version used when compiling. Remove VBoxPython3m.so, we don't
-use it.
-
-Upstream added support for pyton up to 3.12.
-
---- a/src/libs/xpcom18a4/python/Makefile.kmk
-+++ b/src/libs/xpcom18a4/python/Makefile.kmk
-@@ -704,13 +704,6 @@
- VBoxPython3_DEFS = $(filter-out VBOX_PYXPCOM_VERSIONED,$(VBoxPythonBase_DEFS)) Py_LIMITED_API=0x03030000
- VBoxPython3_INCS = $(VBoxPythonBase_INCS) $(VBOX_PYTHON$(VBOX_PYTHON_LIMITED_API_VER)_INC)
- VBoxPython3_LDFLAGS.darwin = -undefined dynamic_lookup
--
-- ifneq ($(KBUILD_TARGET),darwin)
-- DLLS += VBoxPython3m
-- VBoxPython3m_EXTENDS = VBoxPythonBase_m
-- VBoxPython3m_DEFS = $(filter-out VBOX_PYXPCOM_VERSIONED,$(VBoxPythonBase_m_DEFS)) Py_LIMITED_API=0x03030000
-- VBoxPython3m_INCS = $(VBoxPythonBase_m_INCS) $(VBOX_PYTHON$(VBOX_PYTHON_LIMITED_API_VER)_INC)
-- endif
- endif
- endif # VBOX_WITH_PYTHON_LIMITED_API
-