summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNP-Hardass <NP-Hardass@gentoo.org>2015-11-15 17:47:37 -0500
committerNP-Hardass <NP-Hardass@gentoo.org>2015-11-16 02:57:55 -0500
commit0271219fa8a3a8395d2bff30d244e764aff07632 (patch)
tree6855e920bf6da9c00b99e27c5be1207be84fffce /app-emulation/wine/wine-9999.ebuild
parentadd slot to sys-libs/ncurses dep (diff)
downloadgentoo-0271219fa8a3a8395d2bff30d244e764aff07632.tar.gz
gentoo-0271219fa8a3a8395d2bff30d244e764aff07632.tar.bz2
gentoo-0271219fa8a3a8395d2bff30d244e764aff07632.zip
app-emulation/wine: Version bump to 1.7.55. Pulseaudio now mainstream.
Pulseaudio support has been merged upstream. While this means that patches from Wine Staging are no longer necessary, some users may still want to keep the staging flag enabled for additional patches for pulseaudio. Package-Manager: portage-2.2.23
Diffstat (limited to 'app-emulation/wine/wine-9999.ebuild')
-rw-r--r--app-emulation/wine/wine-9999.ebuild18
1 files changed, 6 insertions, 12 deletions
diff --git a/app-emulation/wine/wine-9999.ebuild b/app-emulation/wine/wine-9999.ebuild
index 37b9d26352b3..e6a53ea16ee6 100644
--- a/app-emulation/wine/wine-9999.ebuild
+++ b/app-emulation/wine/wine-9999.ebuild
@@ -8,7 +8,7 @@ AUTOTOOLS_AUTORECONF=1
PLOCALES="ar bg ca cs da de el en en_US eo es fa fi fr he hi hr hu it ja ko lt ml nb_NO nl or pa pl pt_BR pt_PT rm ro ru sk sl sr_RS@cyrillic sr_RS@latin sv te th tr uk wa zh_CN zh_TW"
PLOCALE_BACKUP="en"
-inherit autotools-utils eutils fdo-mime flag-o-matic gnome2-utils l10n multilib multilib-minimal pax-utils toolchain-funcs virtualx
+inherit autotools-utils eutils fdo-mime flag-o-matic gnome2-utils l10n multilib multilib-minimal pax-utils toolchain-funcs virtualx versionator
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="git://source.winehq.org/git/wine.git http://source.winehq.org/git/wine.git"
@@ -17,10 +17,9 @@ if [[ ${PV} == "9999" ]] ; then
SRC_URI=""
#KEYWORDS=""
else
- MY_P="${PN}-${PV/_/-}"
- SRC_URI="mirror://sourceforge/${PN}/Source/${MY_P}.tar.bz2"
+ MAJOR_V=$(get_version_component_range 1-2)
+ SRC_URI="https://dl.winehq.org/wine/source/${MAJOR_V}/${P}.tar.bz2"
KEYWORDS="-* ~amd64 ~x86 ~x86-fbsd"
- S=${WORKDIR}/${MY_P}
fi
GV="2.40"
@@ -44,8 +43,7 @@ if [[ ${PV} == "9999" ]] ; then
STAGING_EGIT_REPO_URI="git://github.com/wine-compholio/wine-staging.git"
else
SRC_URI="${SRC_URI}
- staging? ( https://github.com/wine-compholio/wine-staging/archive/v${PV}.tar.gz -> ${STAGING_P}.tar.gz )
- pulseaudio? ( https://github.com/wine-compholio/wine-staging/archive/v${PV}.tar.gz -> ${STAGING_P}.tar.gz )"
+ staging? ( https://github.com/wine-compholio/wine-staging/archive/v${PV}.tar.gz -> ${STAGING_P}.tar.gz )"
fi
LICENSE="LGPL-2.1"
@@ -211,7 +209,7 @@ src_unpack() {
EGIT_CHECKOUT_DIR=${STAGING_DIR} git-r3_src_unpack
fi
else
- unpack ${MY_P}.tar.bz2
+ unpack ${P}.tar.bz2
use staging || use pulseaudio && unpack "${STAGING_P}.tar.gz"
fi
@@ -265,8 +263,6 @@ src_prepare() {
source "${STAGING_DIR}/patches/patchinstall.sh"
)
eend $?
- elif use pulseaudio; then
- PATCHES+=( "${STAGING_DIR}/patches/winepulse-PulseAudio_Support"/*.patch )
fi
autotools-utils_src_prepare
@@ -322,6 +318,7 @@ multilib_src_configure() {
$(use_with oss)
$(use_with pcap)
$(use_with png)
+ $(use_with pulseaudio)
$(use_with threads pthread)
$(use_with scanner sane)
$(use_enable test tests)
@@ -334,9 +331,6 @@ multilib_src_configure() {
$(use_with xml xslt)
)
- if use pulseaudio || use staging; then
- myconf+=( $(use_with pulseaudio pulse) )
- fi
use staging && myconf+=(
--with-xattr
$(use_with vaapi va)