summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2022-04-17 15:44:23 +0200
committerFlorian Schmaus <flow@gentoo.org>2022-04-17 16:03:57 +0200
commit7652b72590674d347b051e1530cf06541539cd31 (patch)
treefaa7070543b2467ee8dc51e09d968d5db91b3955 /app-emulation/xen
parentapp-emulation/xen-tools: convert myconf to array, drop effectles sed (diff)
downloadgentoo-7652b72590674d347b051e1530cf06541539cd31.tar.gz
gentoo-7652b72590674d347b051e1530cf06541539cd31.tar.bz2
gentoo-7652b72590674d347b051e1530cf06541539cd31.zip
app-emulation/xen: improve naming and type of phase shared variable
Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'app-emulation/xen')
-rw-r--r--app-emulation/xen/xen-4.16.0-r5.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/app-emulation/xen/xen-4.16.0-r5.ebuild b/app-emulation/xen/xen-4.16.0-r5.ebuild
index 6342aaf23287..eb0fa574bc2e 100644
--- a/app-emulation/xen/xen-4.16.0-r5.ebuild
+++ b/app-emulation/xen/xen-4.16.0-r5.ebuild
@@ -117,9 +117,11 @@ src_prepare() {
default
}
+XEN_OPTS=()
+
src_configure() {
- use arm && myopt="${myopt} CONFIG_EARLY_PRINTK=sun7i"
- use debug && myopt="${myopt} debug=y"
+ use arm && XEN_OPTS+=( CONFIG_EARLY_PRINTK=sun7i )
+ use debug && XEN_OPTS+=( debug=y )
# remove flags
unset CFLAGS
@@ -131,7 +133,7 @@ src_configure() {
src_compile() {
# Send raw LDFLAGS so that --as-needed works
- emake V=1 CC="$(tc-getCC)" LDFLAGS="$(raw-ldflags)" LD="$(tc-getLD)" -C xen ${myopt}
+ emake V=1 CC="$(tc-getCC)" LDFLAGS="$(raw-ldflags)" LD="$(tc-getLD)" -C xen ${XEN_OPTS[@]}
}
src_install() {