summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichal Privoznik <michal.privoznik@gmail.com>2024-12-02 12:16:11 +0100
committerSam James <sam@gentoo.org>2024-12-02 14:47:53 +0000
commit041d616da19f824cb11898ed3a65c4c8bb603f9b (patch)
tree02450ba34fbfd78a4b85684d1e05af84a5e8c8b9 /app-emulation
parentapp-emulation/qemu: Update live ebuild (diff)
downloadgentoo-041d616da19f824cb11898ed3a65c4c8bb603f9b.tar.gz
gentoo-041d616da19f824cb11898ed3a65c4c8bb603f9b.tar.bz2
gentoo-041d616da19f824cb11898ed3a65c4c8bb603f9b.zip
app-emulation/qemu: Pass --python=${PYTHON} to configure
QEMU expects python during compilation (plenty of build scripts are written in python). And up until upstream commit [1] it wasn't much of a problem. But starting from that commit, the configure script creates a venv unconditionally and installs various packages there. At the same time, the configure script is free to chose whatever python version it deems usable (in practice it finds python3 first). Well, it may chose python without ensurepip USE flag. Tell the configure script which python to use explicitly by passing --python=${PYTHON}. 1: https://gitlab.com/qemu-project/qemu/-/commit/81e2b198a8cb4ee5fdf108bd438f44b193ee3a36 Closes: https://bugs.gentoo.org/942518 Signed-off-by: Michal Privoznik <michal.privoznik@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/39562 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/qemu/qemu-8.2.3.ebuild1
-rw-r--r--app-emulation/qemu/qemu-8.2.7.ebuild1
-rw-r--r--app-emulation/qemu/qemu-8.2.8.ebuild1
-rw-r--r--app-emulation/qemu/qemu-9.0.4.ebuild1
-rw-r--r--app-emulation/qemu/qemu-9.1.2.ebuild1
-rw-r--r--app-emulation/qemu/qemu-9999.ebuild1
6 files changed, 6 insertions, 0 deletions
diff --git a/app-emulation/qemu/qemu-8.2.3.ebuild b/app-emulation/qemu/qemu-8.2.3.ebuild
index 6fbc52d1a747..01ec0ca376eb 100644
--- a/app-emulation/qemu/qemu-8.2.3.ebuild
+++ b/app-emulation/qemu/qemu-8.2.3.ebuild
@@ -515,6 +515,7 @@ qemu_src_configure() {
--disable-guest-agent
--disable-strip
--disable-download
+ --python="${PYTHON}"
# bug #746752: TCG interpreter has a few limitations:
# - it does not support FPU
diff --git a/app-emulation/qemu/qemu-8.2.7.ebuild b/app-emulation/qemu/qemu-8.2.7.ebuild
index 6d3d77d66526..4f1e891938a1 100644
--- a/app-emulation/qemu/qemu-8.2.7.ebuild
+++ b/app-emulation/qemu/qemu-8.2.7.ebuild
@@ -515,6 +515,7 @@ qemu_src_configure() {
--disable-guest-agent
--disable-strip
--disable-download
+ --python="${PYTHON}"
# bug #746752: TCG interpreter has a few limitations:
# - it does not support FPU
diff --git a/app-emulation/qemu/qemu-8.2.8.ebuild b/app-emulation/qemu/qemu-8.2.8.ebuild
index 55910aad6115..7c5adb09c144 100644
--- a/app-emulation/qemu/qemu-8.2.8.ebuild
+++ b/app-emulation/qemu/qemu-8.2.8.ebuild
@@ -515,6 +515,7 @@ qemu_src_configure() {
--disable-guest-agent
--disable-strip
--disable-download
+ --python="${PYTHON}"
# bug #746752: TCG interpreter has a few limitations:
# - it does not support FPU
diff --git a/app-emulation/qemu/qemu-9.0.4.ebuild b/app-emulation/qemu/qemu-9.0.4.ebuild
index e713c9e7834e..13ae2d10fa0b 100644
--- a/app-emulation/qemu/qemu-9.0.4.ebuild
+++ b/app-emulation/qemu/qemu-9.0.4.ebuild
@@ -521,6 +521,7 @@ qemu_src_configure() {
--disable-guest-agent
--disable-strip
--disable-download
+ --python="${PYTHON}"
# bug #746752: TCG interpreter has a few limitations:
# - it does not support FPU
diff --git a/app-emulation/qemu/qemu-9.1.2.ebuild b/app-emulation/qemu/qemu-9.1.2.ebuild
index 61886a5726eb..80d4d3ac6ea3 100644
--- a/app-emulation/qemu/qemu-9.1.2.ebuild
+++ b/app-emulation/qemu/qemu-9.1.2.ebuild
@@ -520,6 +520,7 @@ qemu_src_configure() {
--disable-guest-agent
--disable-strip
--disable-download
+ --python="${PYTHON}"
# bug #746752: TCG interpreter has a few limitations:
# - it does not support FPU
diff --git a/app-emulation/qemu/qemu-9999.ebuild b/app-emulation/qemu/qemu-9999.ebuild
index e4f3ea185d13..e82bd167c807 100644
--- a/app-emulation/qemu/qemu-9999.ebuild
+++ b/app-emulation/qemu/qemu-9999.ebuild
@@ -518,6 +518,7 @@ qemu_src_configure() {
--disable-guest-agent
--disable-strip
--disable-download
+ --python="${PYTHON}"
# bug #746752: TCG interpreter has a few limitations:
# - it does not support FPU