summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-14 06:14:03 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-14 06:15:48 +0200
commit8fa855c455f5e3d3b81f060fcee0c9f7a07da8b9 (patch)
tree88310a5bf28487782a97764503f331045e0a0bec /app-eselect/eselect-sh
parentapp-eselect/eselect-sh: Add 0.5.0 (diff)
downloadgentoo-8fa855c455f5e3d3b81f060fcee0c9f7a07da8b9.tar.gz
gentoo-8fa855c455f5e3d3b81f060fcee0c9f7a07da8b9.tar.bz2
gentoo-8fa855c455f5e3d3b81f060fcee0c9f7a07da8b9.zip
app-eselect/eselect-sh: Inline the module into the ebuild
The module itself is smaller than the ebuild file, so instead of wasting two data blocks on them, let's inline the module into the ebuild. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-eselect/eselect-sh')
-rw-r--r--app-eselect/eselect-sh/eselect-sh-0.5.0.ebuild17
-rw-r--r--app-eselect/eselect-sh/files/sh.eselect-0.5.013
2 files changed, 15 insertions, 15 deletions
diff --git a/app-eselect/eselect-sh/eselect-sh-0.5.0.ebuild b/app-eselect/eselect-sh/eselect-sh-0.5.0.ebuild
index 0516ae327ad5..6a89133477cf 100644
--- a/app-eselect/eselect-sh/eselect-sh-0.5.0.ebuild
+++ b/app-eselect/eselect-sh/eselect-sh-0.5.0.ebuild
@@ -11,11 +11,24 @@ S=${WORKDIR}
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
RDEPEND="app-eselect/eselect-lib-bin-symlink"
src_install() {
insinto /usr/share/eselect/modules
- newins "${FILESDIR}"/sh.eselect-${PV} sh.eselect
+ newins - sh.eselect <<-EOF
+ # Copyright 1999-2022 Gentoo Authors
+ # Distributed under the terms of the GNU General Public License v2
+
+ DESCRIPTION="Manage /bin/sh (POSIX shell) implementations"
+ MAINTAINER="mgorny@gentoo.org"
+ VERSION="${PV}"
+
+ SYMLINK_PATH=/bin/sh
+ SYMLINK_TARGETS=( bash dash lksh mksh )
+ SYMLINK_DESCRIPTION='POSIX shell'
+ SYMLINK_CRUCIAL=1
+
+ inherit bin-symlink
+ EOF
}
diff --git a/app-eselect/eselect-sh/files/sh.eselect-0.5.0 b/app-eselect/eselect-sh/files/sh.eselect-0.5.0
deleted file mode 100644
index aa0f3c08494f..000000000000
--- a/app-eselect/eselect-sh/files/sh.eselect-0.5.0
+++ /dev/null
@@ -1,13 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-DESCRIPTION="Manage /bin/sh (POSIX shell) implementations"
-MAINTAINER="mgorny@gentoo.org"
-VERSION="0.5.0"
-
-SYMLINK_PATH=/bin/sh
-SYMLINK_TARGETS=( bash dash lksh mksh )
-SYMLINK_DESCRIPTION='POSIX shell'
-SYMLINK_CRUCIAL=1
-
-inherit bin-symlink