summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Siebeck <gentoo.2019@r123.de>2020-04-19 15:04:41 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-04-29 11:09:56 +0300
commitb6a37697d5692fe885f4eebe46cc9c47b529d228 (patch)
tree69a17e8d49d506e52e324120d2ea9dedb99611b2 /app-i18n/transifex-client/transifex-client-0.13.9.ebuild
parentapp-i18n/transifex-client: take maintainership (diff)
downloadgentoo-b6a37697d5692fe885f4eebe46cc9c47b529d228.tar.gz
gentoo-b6a37697d5692fe885f4eebe46cc9c47b529d228.tar.bz2
gentoo-b6a37697d5692fe885f4eebe46cc9c47b529d228.zip
app-i18n/transifex-client: add version 0.13.9
Closes: https://bugs.gentoo.org/718222 Closes: https://bugs.gentoo.org/665246 Signed-off-by: Robert Siebeck <gentoo.2019@r123.de> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-i18n/transifex-client/transifex-client-0.13.9.ebuild')
-rw-r--r--app-i18n/transifex-client/transifex-client-0.13.9.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-i18n/transifex-client/transifex-client-0.13.9.ebuild b/app-i18n/transifex-client/transifex-client-0.13.9.ebuild
new file mode 100644
index 000000000000..ebf993e907dc
--- /dev/null
+++ b/app-i18n/transifex-client/transifex-client-0.13.9.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="A command line interface for Transifex"
+HOMEPAGE="https://pypi.org/project/transifex-client/ https://www.transifex.net/"
+SRC_URI="mirror://pypi/t/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( dev-python/mock[${PYTHON_USEDEP}] )"
+RDEPEND="<dev-python/python-slugify-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.19.1[${PYTHON_USEDEP}]
+ <dev-python/six-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.24.2[${PYTHON_USEDEP}]"
+
+distutils_enable_tests setup.py