summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGraham Ramsey <graham.ramsey@gmail.com>2022-10-07 11:42:47 +0100
committerYixun Lan <dlan@gentoo.org>2022-10-08 09:36:42 +0800
commitd81f84c2ac29bc4a3e8f171c7adde0d8fcef2a59 (patch)
tree48604e71dd8eeb8c8c6d3816b01d03a8b700d7bd /app-i18n
parentdev-util/min-cscope: fix build with upcoming clang16 (diff)
downloadgentoo-d81f84c2ac29bc4a3e8f171c7adde0d8fcef2a59.tar.gz
gentoo-d81f84c2ac29bc4a3e8f171c7adde0d8fcef2a59.tar.bz2
gentoo-d81f84c2ac29bc4a3e8f171c7adde0d8fcef2a59.zip
app-i18n/ibus-libpinyin: Version 1.13.1 added
1.13.1 adds a bugfix Closes: https://bugs.gentoo.org/875845 Closes: https://github.com/gentoo/gentoo/pull/27671 Signed-off-by: Graham Ramsey <graham.ramsey@gmail.com> Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/ibus-libpinyin/Manifest1
-rw-r--r--app-i18n/ibus-libpinyin/ibus-libpinyin-1.13.1.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/app-i18n/ibus-libpinyin/Manifest b/app-i18n/ibus-libpinyin/Manifest
index 3d6a11941404..31d4ac917bb4 100644
--- a/app-i18n/ibus-libpinyin/Manifest
+++ b/app-i18n/ibus-libpinyin/Manifest
@@ -1,2 +1,3 @@
DIST ibus-libpinyin-1.12.1.tar.gz 1766803 BLAKE2B 1de8a51b52688dede32c572b39bd379296480ab2b0f909357465370e346bdf50f4cade5ab3f105f62a74e59cf2dc5e8d5235aedde7571b70d3c5dcee86d2e36b SHA512 ad6e7507bdb468d506071135449383e5bd4fc878bcffda4be6e4e7915b79dbaf919d2fa941b92b177dc7790bd895eaa9a6d04a2610f85e1e80e8eb50f188211d
DIST ibus-libpinyin-1.13.0.tar.gz 1726869 BLAKE2B f18ae81edb4ebf18f569fc13f3088f32e57c6a4512f7cafb33a18fdb08d5fdcdb17ff1861c3419db3063808f655510f6f4de63c274d798c48731ac4632203ba6 SHA512 8eca89c3c71ada37ec93307556fc476ad8719e58ca828f684dff6e74e1cb91df3e8c8ce03c87dbb72d5b7213e7c7ca367da8cf6b1dddb47d63afdf23d53bc54c
+DIST ibus-libpinyin-1.13.1.tar.gz 1726900 BLAKE2B 2540b5ca6657fe421f6f2986f32fba1b8840cafcc37b3ec5402705cb0edc0aac6b12d972b5da0326339a04c875dbd8f8cce902f613558f3f9d21b4a0cace31a3 SHA512 ee3a8c95e091992acb0558ff297743eb49bd8c73fbb9cd1f2b56db75137573dda2c677b1b25eb213fbd8779be004b06f95cded04273d7a469cf49f45cc27813a
diff --git a/app-i18n/ibus-libpinyin/ibus-libpinyin-1.13.1.ebuild b/app-i18n/ibus-libpinyin/ibus-libpinyin-1.13.1.ebuild
new file mode 100644
index 000000000000..7f8fdf0ab762
--- /dev/null
+++ b/app-i18n/ibus-libpinyin/ibus-libpinyin-1.13.1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 2015-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+LUA_COMPAT=( lua5-{1..3} )
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit autotools gnome2-utils lua-single python-single-r1
+
+DESCRIPTION="Intelligent Pinyin and Bopomofo input methods based on LibPinyin for IBus"
+HOMEPAGE="https://github.com/libpinyin/ibus-libpinyin https://sourceforge.net/projects/libpinyin/"
+SRC_URI="https://github.com/libpinyin/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="boost lua opencc"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}
+ lua? ( ${LUA_REQUIRED_USE} )"
+
+BDEPEND="dev-db/sqlite:3
+ virtual/pkgconfig"
+
+DEPEND="${PYTHON_DEPS}
+ >=app-i18n/libpinyin-2.2.1:=
+ dev-db/sqlite:3
+ dev-libs/glib:2
+ virtual/libintl
+ $(python_gen_cond_dep '
+ app-i18n/ibus[python(+),${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+ boost? ( dev-libs/boost:= )
+ lua? ( ${LUA_DEPS} )
+ opencc? ( app-i18n/opencc:= )"
+
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+
+ if use lua; then
+ lua-single_pkg_setup
+ fi
+}
+
+src_prepare() {
+ sed -i \
+ -e "/^appdatadir/s:/appdata:/metainfo:" \
+ data/Makefile.am || die
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-english-input-mode \
+ $(use_enable boost) \
+ $(use_enable lua lua-extension) \
+ $(use_enable opencc)
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+}