summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Mozes <hydrapolic@gmail.com>2018-09-28 13:24:31 +0200
committerThomas Deutschmann <whissi@gentoo.org>2018-10-02 11:37:35 +0200
commit150ca4f443b124c64aa9e3c446d7d4dda98569b1 (patch)
treee0ebca11147ec463b6f9a38bd0f5027fecb93558 /app-misc/elasticsearch
parentapp-misc/elasticsearch: bump to 5.6.12 (diff)
downloadgentoo-150ca4f443b124c64aa9e3c446d7d4dda98569b1.tar.gz
gentoo-150ca4f443b124c64aa9e3c446d7d4dda98569b1.tar.bz2
gentoo-150ca4f443b124c64aa9e3c446d7d4dda98569b1.zip
app-misc/elasticsearch: bump to 6.4.1
Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Package-Manager: Portage-2.3.50, Repoman-2.3.11 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'app-misc/elasticsearch')
-rw-r--r--app-misc/elasticsearch/Manifest2
-rw-r--r--app-misc/elasticsearch/elasticsearch-6.4.1.ebuild91
2 files changed, 93 insertions, 0 deletions
diff --git a/app-misc/elasticsearch/Manifest b/app-misc/elasticsearch/Manifest
index 344520433f1e..23f941474c4d 100644
--- a/app-misc/elasticsearch/Manifest
+++ b/app-misc/elasticsearch/Manifest
@@ -2,5 +2,7 @@ DIST elasticsearch-5.6.11.tar.gz 33864199 BLAKE2B 08884e6367007835ec1d248912d412
DIST elasticsearch-5.6.12.tar.gz 33861038 BLAKE2B 548513d568ffad6373f15671934cce84217d59b8a036847685ad055681f816d3a75fb6ba2c60c7965402e791d6f5b1a11fe8918bca9f4a60fb8e9d43809da0a2 SHA512 bc2436ff34bca652f6a6462920921dce3b085300787e02191c0673d7b3789c0cf81681108573f0ec4dc945e91a2e6ae19898d1b606ca35694bfde6d9cd5762cd
DIST elasticsearch-6.3.2.tar.gz 91452574 BLAKE2B c422990fabad70e6e77e8f59f6fb9e9bf5a84eb7e6b8b67dfd91f53e474b1b501b3a1d5ea8f54f0793631504f194a116e816eb3558782b67c8dadecbc2711ee5 SHA512 954cd1e16a5f2e0b0efaeb7e6b19c708d1588d30814a31defb09037c3b90f78c5e9dbd1ca9af9c700d517145a4279bacc1d8ce7cc6894fbe7bf71eec9ed3110d
DIST elasticsearch-6.4.0.tar.gz 97901357 BLAKE2B 60263c3b68a91fba2341d45162cac328e5561cfe046bcc0dfff3eb09d2e487374c5e8481b460a54861df7b2c5774ac2cc6c884fc6b5455fb40f0c89848c0ad0b SHA512 6f465378a51c487f1f6a84a0843ac1038db60170ee8a5d96874a759f6dbbf2de9f7bcbbf55616f49f28f1098c82f2e585c917267d02b8b1f43627a1984b3da66
+DIST elasticsearch-6.4.1.tar.gz 97924081 BLAKE2B 179433ebe9fca80517057a0379d67545bfd42af741ca64fc2e5b307f9071634d20f297c46d43cfbcfa8dcc45f269c5db32b70656bd4c3035a47aacae861875a2 SHA512 a023a6db5554dee6f10718dfa297aa06a735c7857542c2db80fa5c2b86ff4bf405bb8167578c5b60741ad05ed96a64b54bc71d128a0ff955468b0449588b053c
DIST elasticsearch-oss-6.3.2.tar.gz 29418577 BLAKE2B 152640dc01a10f44ba43f87f68361cc0dd5e1cf54d0ff92377f3acd1a12a247f002ffe2d003cc53760e891278249c10b1d6d4eb978b0bb1c1ebf8879a2cfcb9a SHA512 3c51a860414f7e55900b1d9a350bdbc3e673c8445e316454c2480315b4b9fc08df58090c6281cecc3ae63d12d78d6bd58e228b3371aa325db799ce18758a21f4
DIST elasticsearch-oss-6.4.0.tar.gz 33727061 BLAKE2B dd0ff95bb124103ca340b480c5192c9919ef226d4c3ef1b61accd0df2ee9b60a8215693b3db0fa327a4d6791de66746654144a9172210687e8a2efa9f6f4dde3 SHA512 0197dcf24bdb81cbcfa492d899363528816143962abd1925a5092e8177c25e8ca490afe5868b41057b3cded296f59f38ed11ba0156a820b6c877c69a5888846c
+DIST elasticsearch-oss-6.4.1.tar.gz 33725674 BLAKE2B e24809eab213aa34499dcfb1e9a9a2b37d85346d4647282de51c95b17f0ae693f9b48e1649658d700ed8e3d547fd22b5f2276c3b4a2b78aa6c129b8bd1eb096b SHA512 5036adbb091dff95416f4f4b24f615475d7c8c058fcda733ec49a9867b7dafcb90c430f486c667cdc30958280814e609c3f0bc49c20bdb06c0a22d01504a3873
diff --git a/app-misc/elasticsearch/elasticsearch-6.4.1.ebuild b/app-misc/elasticsearch/elasticsearch-6.4.1.ebuild
new file mode 100644
index 000000000000..52da0c6d6359
--- /dev/null
+++ b/app-misc/elasticsearch/elasticsearch-6.4.1.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit systemd user
+
+DESCRIPTION="Open Source, Distributed, RESTful, Search Engine"
+HOMEPAGE="https://www.elastic.co/products/elasticsearch"
+SRC_URI="x-pack? ( https://artifacts.elastic.co/downloads/${PN}/${P}.tar.gz )
+ !x-pack? ( https://artifacts.elastic.co/downloads/${PN}/${PN}-oss-${PV}.tar.gz )"
+LICENSE="Apache-2.0 BSD-2 LGPL-3 MIT public-domain x-pack? ( Elastic )"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="x-pack"
+
+RDEPEND="virtual/jre:1.8"
+
+QA_PRESTRIPPED="usr/share/elasticsearch/modules/x-pack-ml/platform/linux-x86_64/\(bin\|lib\)/.*"
+
+pkg_setup() {
+ enewgroup ${PN}
+ enewuser ${PN} -1 /bin/bash /usr/share/${PN} ${PN}
+}
+
+src_prepare() {
+ default
+
+ rm bin/*.{bat,exe} LICENSE.txt NOTICE.txt || die
+ rmdir logs || die
+
+ if use x-pack; then
+ rm bin/x-pack/*.bat || die
+ rm -r modules/x-pack-ml/platform/{darwin,windows}-x86_64 || die
+ fi
+}
+
+src_install() {
+ keepdir /etc/${PN}
+ keepdir /etc/${PN}/scripts
+
+ insinto /etc/${PN}
+ doins -r config/.
+ rm -r config || die
+
+ fowners root:${PN} /etc/${PN}
+ fperms 2750 /etc/${PN}
+
+ insinto /usr/share/${PN}
+ doins -r .
+
+ exeinto /usr/share/${PN}/bin
+ doexe "${FILESDIR}/elasticsearch-systemd-pre-exec"
+
+ chmod +x "${ED}"/usr/share/${PN}/bin/* || die
+
+ if use x-pack; then
+ chmod +x "${ED}"/usr/share/${PN}/modules/x-pack-ml/platform/linux-x86_64/bin/* || die
+ fi
+
+ keepdir /var/{lib,log}/${PN}
+ fowners ${PN}:${PN} /var/{lib,log}/${PN}
+ fperms 0750 /var/{lib,log}/${PN}
+ dodir /usr/share/${PN}/plugins
+
+ insinto /etc/sysctl.d
+ newins "${FILESDIR}/${PN}.sysctl.d" ${PN}.conf
+
+ newconfd "${FILESDIR}/${PN}.conf.3" ${PN}
+ newinitd "${FILESDIR}/${PN}.init.5" ${PN}
+
+ systemd_install_serviced "${FILESDIR}/${PN}.service.conf"
+ systemd_newtmpfilesd "${FILESDIR}/${PN}.tmpfiles.d" ${PN}.conf
+ systemd_newunit "${FILESDIR}"/${PN}.service.3 ${PN}.service
+}
+
+pkg_postinst() {
+ elog
+ elog "You may create multiple instances of ${PN} by"
+ elog "symlinking the init script:"
+ elog "ln -sf /etc/init.d/${PN} /etc/init.d/${PN}.instance"
+ elog
+ elog "Please make sure you put elasticsearch.yml, log4j2.properties and scripts"
+ elog "from /etc/${PN} into the configuration directory of the instance:"
+ elog "/etc/${PN}/instance"
+ elog
+ ewarn "Please make sure you have proper permissions on /etc/${PN}"
+ ewarn "prior to keystore generation or you may experience startup fails."
+ ewarn "chown root:${PN} /etc/${PN} && chmod 2750 /etc/${PN}"
+ ewarn "chown root:${PN} /etc/${PN}/${PN}.keystore && chmod 0660 /etc/${PN}/${PN}.keystore"
+}