summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2017-06-10 13:54:16 -0400
committerMike Gilbert <floppym@gentoo.org>2017-06-10 13:54:36 -0400
commitd9ff9212ffd616031b62964ad74864ff4a31d457 (patch)
tree6c58bc69b5810b927e4c087f29db7e72b7e64d02 /app-misc/grc/grc-1.11-r1.ebuild
parentsys-kernel/rt-sources: version bump to {3.18.55_p61,4.1.40_p48,4.4.70_p83,4.9... (diff)
downloadgentoo-d9ff9212ffd616031b62964ad74864ff4a31d457.tar.gz
gentoo-d9ff9212ffd616031b62964ad74864ff4a31d457.tar.bz2
gentoo-d9ff9212ffd616031b62964ad74864ff4a31d457.zip
app-misc/grc: revbump to prevent duplicate bug reports
Bug: https://bugs.gentoo.org/621424 Package-Manager: Portage-2.3.6_p7, Repoman-2.3.2_p75
Diffstat (limited to 'app-misc/grc/grc-1.11-r1.ebuild')
-rw-r--r--app-misc/grc/grc-1.11-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/app-misc/grc/grc-1.11-r1.ebuild b/app-misc/grc/grc-1.11-r1.ebuild
new file mode 100644
index 000000000000..dd4b617a6298
--- /dev/null
+++ b/app-misc/grc/grc-1.11-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} pypy )
+
+inherit eutils python-r1
+
+DESCRIPTION="Generic Colouriser beautifies your logfiles or output of commands"
+HOMEPAGE="http://kassiopeia.juls.savba.sk/~garabik/software/grc.html"
+SRC_URI="https://github.com/garabik/grc/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed \
+ -e 's:#! :#!:g' \
+ -e 's:3$::g' \
+ -i grc grcat || die
+ default
+}
+
+src_install() {
+ python_foreach_impl python_doscript grc grcat
+
+ insinto /usr/share/grc
+ doins \
+ contrib/mrsmith/conf.* \
+ colourfiles/conf.*
+ insinto /etc/profile.d
+ newins grc.bashrc grc.sh
+
+ insinto /etc
+ doins grc.conf
+
+ dodoc README.markdown INSTALL TODO debian/changelog CREDITS Regexp.txt
+ doman *.1
+}