summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2024-06-29 12:08:43 +0300
committerViorel Munteanu <ceamac@gentoo.org>2024-06-29 12:12:24 +0300
commitadd89e7268345fb3be6d651bf493abeca5fd271a (patch)
treeff45392d9bae887e4f493d9503721f7a8deb9a53 /app-misc/mc
parentapp-misc/fastfetch: Stabilize 2.14.0 arm64, #935127 (diff)
downloadgentoo-add89e7268345fb3be6d651bf493abeca5fd271a.tar.gz
gentoo-add89e7268345fb3be6d651bf493abeca5fd271a.tar.bz2
gentoo-add89e7268345fb3be6d651bf493abeca5fd271a.zip
app-misc/mc: disable localization tests on musl
Disable localization tests on musl. Reorder variables according to skel.ebuild. Update metadata.xml. No changes to ebuild logic or what gets installed. Closes: https://bugs.gentoo.org/922483 Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'app-misc/mc')
-rw-r--r--app-misc/mc/files/mc-4.8.31-musl-tests.patch55
-rw-r--r--app-misc/mc/mc-4.8.31.ebuild27
-rw-r--r--app-misc/mc/metadata.xml27
3 files changed, 85 insertions, 24 deletions
diff --git a/app-misc/mc/files/mc-4.8.31-musl-tests.patch b/app-misc/mc/files/mc-4.8.31-musl-tests.patch
new file mode 100644
index 000000000000..5c7c6b0f2397
--- /dev/null
+++ b/app-misc/mc/files/mc-4.8.31-musl-tests.patch
@@ -0,0 +1,55 @@
+https://bugs.gentoo.org/922483
+
+--- a/tests/lib/vfs/vfs_path_string_convert.c
++++ b/tests/lib/vfs/vfs_path_string_convert.c
+@@ -116,50 +116,6 @@
+ 4,
+ &vfs_test_ops3
+ },
+-#ifdef HAVE_CHARSET
+- { /* 3. */
+- "/#test1/bla-bla1/some/path/#test2/bla-bla2/#enc:KOI8-R/some/path#test3/111/22/33",
+- "/test1://bla-bla1/some/path/test2://#enc:KOI8-R/bla-bla2/some/path/test3://111/22/33",
+- "111/22/33",
+- 4,
+- &vfs_test_ops3
+- },
+- { /* 4. */
+- "/#test1/bla-bla1/#enc:IBM866/some/path/#test2/bla-bla2/#enc:KOI8-R/some/path#test3/111/22/33",
+- "/test1://#enc:IBM866/bla-bla1/some/path/test2://#enc:KOI8-R/bla-bla2/some/path/test3://111/22/33",
+- "111/22/33",
+- 4,
+- &vfs_test_ops3
+- },
+- { /* 5. */
+- "/#test1/bla-bla1/some/path/#test2/bla-bla2/#enc:IBM866/#enc:KOI8-R/some/path#test3/111/22/33",
+- "/test1://bla-bla1/some/path/test2://#enc:KOI8-R/bla-bla2/some/path/test3://111/22/33",
+- "111/22/33",
+- 4,
+- &vfs_test_ops3
+- },
+- { /* 6. */
+- "/#test1/bla-bla1/some/path/#test2/bla-bla2/#enc:IBM866/some/#enc:KOI8-R/path#test3/111/22/33",
+- "/test1://bla-bla1/some/path/test2://#enc:KOI8-R/bla-bla2/some/path/test3://111/22/33",
+- "111/22/33",
+- 4,
+- &vfs_test_ops3
+- },
+- { /* 7. */
+- "/#test1/bla-bla1/some/path/#test2/#enc:IBM866/bla-bla2/#enc:KOI8-R/some/path#test3/111/22/33",
+- "/test1://bla-bla1/some/path/test2://#enc:KOI8-R/bla-bla2/some/path/test3://111/22/33",
+- "111/22/33",
+- 4,
+- &vfs_test_ops3
+- },
+- { /* 8. */
+- "/#test1/bla-bla1/some/path/#enc:IBM866/#test2/bla-bla2/#enc:KOI8-R/some/path#test3/111/22/33",
+- "/test1://#enc:IBM866/bla-bla1/some/path/test2://#enc:KOI8-R/bla-bla2/some/path/test3://111/22/33",
+- "111/22/33",
+- 4,
+- &vfs_test_ops3
+- },
+-#endif /* HAVE_CHARSET */
+ };
+ /* *INDENT-ON* */
+
diff --git a/app-misc/mc/mc-4.8.31.ebuild b/app-misc/mc/mc-4.8.31.ebuild
index 5981d616172c..8b8437c5c57f 100644
--- a/app-misc/mc/mc-4.8.31.ebuild
+++ b/app-misc/mc/mc-4.8.31.ebuild
@@ -6,17 +6,18 @@ EAPI=8
inherit autotools flag-o-matic
MY_P="${P/_/-}"
-SRC_URI="http://ftp.midnight-commander.org/${MY_P}.tar.xz"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos"
-
DESCRIPTION="GNU Midnight Commander is a text based file manager"
HOMEPAGE="https://midnight-commander.org"
+SRC_URI="http://ftp.midnight-commander.org/${MY_P}.tar.xz"
+S="${WORKDIR}/${MY_P}"
LICENSE="GPL-3"
SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos"
IUSE="+edit gpm nls sftp +slang spell test unicode X"
REQUIRED_USE="spell? ( edit )"
+RESTRICT="!test? ( test )"
DEPEND="
>=dev-libs/glib-2.30.0:2
@@ -34,8 +35,12 @@ DEPEND="
x11-libs/libSM
)
"
-RDEPEND="${DEPEND}
- spell? ( app-dicts/aspell-en )"
+
+RDEPEND="
+ ${DEPEND}
+ spell? ( app-dicts/aspell-en )
+"
+
BDEPEND="
app-arch/xz-utils
virtual/pkgconfig
@@ -43,10 +48,6 @@ BDEPEND="
test? ( dev-libs/check )
"
-RESTRICT="!test? ( test )"
-
-S="${WORKDIR}/${MY_P}"
-
PATCHES=(
"${FILESDIR}"/${PN}-4.8.26-ncurses-mouse.patch
"${FILESDIR}"/${PN}-4.8.29-gentoo-tools.patch
@@ -61,8 +62,11 @@ QA_CONFIG_IMPL_DECL_SKIP=(
src_prepare() {
default
- # Bug #906194
- use elibc_musl && eapply "${FILESDIR}"/${PN}-4.8.30-musl-tests.patch
+ # Bug #906194, #922483
+ if use elibc_musl; then
+ eapply "${FILESDIR}"/${PN}-4.8.30-musl-tests.patch
+ eapply "${FILESDIR}"/${PN}-4.8.31-musl-tests.patch
+ fi
eautoreconf
}
@@ -105,6 +109,7 @@ src_test() {
# information.
CK_FORK=no emake check VERBOSE=1
}
+
src_install() {
emake DESTDIR="${D}" install
dodoc AUTHORS NEWS README
diff --git a/app-misc/mc/metadata.xml b/app-misc/mc/metadata.xml
index 3e6d204bb8fc..96a33cf76636 100644
--- a/app-misc/mc/metadata.xml
+++ b/app-misc/mc/metadata.xml
@@ -1,16 +1,17 @@
-<?xml version="1.0" encoding="UTF-8"?>
+<?xml version='1.0' encoding='UTF-8'?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person">
- <email>ceamac@gentoo.org</email>
- <name>Viorel Munteanu</name>
- </maintainer>
- <use>
- <flag name="edit">Compile and install the mcedit application</flag>
- <flag name="sftp">Add support for sftp (uses <pkg>net-libs/libssh2</pkg> for it).</flag>
- <flag name="slang">Use <pkg>sys-libs/slang</pkg> instead of <pkg>sys-libs/ncurses</pkg>.</flag>
- </use>
- <upstream>
- <remote-id type="github">MidnightCommander/mc</remote-id>
- </upstream>
+ <maintainer type="person">
+ <email>ceamac@gentoo.org</email>
+ <name>Viorel Munteanu</name>
+ </maintainer>
+ <use>
+ <flag name="edit">Compile and install the mcedit application</flag>
+ <flag name="sftp">Add support for sftp (uses <pkg>net-libs/libssh2</pkg> for it).</flag>
+ <flag name="slang">Use <pkg>sys-libs/slang</pkg> instead of <pkg>sys-libs/ncurses</pkg>.</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">MidnightCommander/mc</remote-id>
+ <bugs-to>https://midnight-commander.org/wiki/NewTicket</bugs-to>
+ </upstream>
</pkgmetadata>