summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-07-31 22:03:37 +0200
committerDavid Seifert <soap@gentoo.org>2022-07-31 22:03:37 +0200
commita2cf9a7cef43fef557f78fe86c16034e2d165802 (patch)
tree804db6021f663528f9162379190e07ab617ab8cc /app-misc/tpipe/tpipe-1.6-r2.ebuild
parentapp-misc/timestamp: update EAPI 6 -> 8 (diff)
downloadgentoo-a2cf9a7cef43fef557f78fe86c16034e2d165802.tar.gz
gentoo-a2cf9a7cef43fef557f78fe86c16034e2d165802.tar.bz2
gentoo-a2cf9a7cef43fef557f78fe86c16034e2d165802.zip
app-misc/tpipe: update EAPI 6 -> 8
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-misc/tpipe/tpipe-1.6-r2.ebuild')
-rw-r--r--app-misc/tpipe/tpipe-1.6-r2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-misc/tpipe/tpipe-1.6-r2.ebuild b/app-misc/tpipe/tpipe-1.6-r2.ebuild
new file mode 100644
index 000000000000..8b37b96a2605
--- /dev/null
+++ b/app-misc/tpipe/tpipe-1.6-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Command to duplicate standard input to more than one program"
+HOMEPAGE="http://www.eurogaran.com/downloads/tpipe"
+SRC_URI="http://www.eurogaran.com/downloads/tpipe/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-makefile.patch
+ "${FILESDIR}"/${P}-Wimplicit-function-declaration.patch
+)
+
+src_configure() {
+ tc-export CC
+}
+
+src_install() {
+ dobin tpipe
+ einstalldocs
+ doman tpipe.1
+}