summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2024-10-28 14:51:31 +0000
committerJoonas Niilola <juippis@gentoo.org>2024-12-04 20:10:36 +0200
commit66ce9c9dc69c790f6028da5299de20c0c9177b04 (patch)
tree43d65c8390fddece6ca9189b210d26d84414d415 /app-misc
parentwww-apache/modsecurity-crs: add 3.3.7 (diff)
downloadgentoo-66ce9c9dc69c790f6028da5299de20c0c9177b04.tar.gz
gentoo-66ce9c9dc69c790f6028da5299de20c0c9177b04.tar.bz2
gentoo-66ce9c9dc69c790f6028da5299de20c0c9177b04.zip
app-misc/elasticsearch: add 7.17.24
Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/elasticsearch/Manifest1
-rw-r--r--app-misc/elasticsearch/elasticsearch-7.17.24.ebuild82
2 files changed, 83 insertions, 0 deletions
diff --git a/app-misc/elasticsearch/Manifest b/app-misc/elasticsearch/Manifest
index 9effb377f4bd..9902bcfee4e9 100644
--- a/app-misc/elasticsearch/Manifest
+++ b/app-misc/elasticsearch/Manifest
@@ -1,2 +1,3 @@
DIST elasticsearch-7.17.16-no-jdk-linux-x86_64.tar.gz 168795535 BLAKE2B 642ae6f07db953e7fa783dcd63c6dcebab61e85ea600bede09e9596bf9dee2d71c43e5c28b80bd4c091d792ed3a95d10cc75ffb1074ad4b3cfceb081ed25027f SHA512 3755373f5068a08e4619b4e922bc2d3d97d41791dbf5aa84564574fc84abee9c567b16095cf0e11d48910627e3c183ff1193bf2d5ade59891bea2b3f994aa7df
+DIST elasticsearch-7.17.24-no-jdk-linux-x86_64.tar.gz 172921988 BLAKE2B f12577dde799546004971119714054a318bcab4290c65373b48b1e3f9f0fe23cd951975fe3b1371d379d4c83f0f690a5886eaafc3465d67ee1804eb9dade169c SHA512 18a4d726b33f301f0a69b2ec04a94b3411cbcf70b471ad0febed527bf51d0546b7ab1293bb4c121a4a10d8849773c0b6b88aa0863cac49183b08eafa70179266
DIST elasticsearch-8.15.1-linux-x86_64.tar.gz 605974468 BLAKE2B 8fc2476cd2629cf8bcd9c2183763aba1880f76357809f661da9c3df6538bdf7bc21e897356cb4e35084ef1333120539e494893177fffe0aaa1e7ea4cc3f52fcd SHA512 3eced0f59446f60170b7ab3372f58bbda713e2166bb936ef0f74a027e579565b469d3f8888715638e6dfc3e98f88e1b73f7de8a6fc37be236ade4a099f9cc808
diff --git a/app-misc/elasticsearch/elasticsearch-7.17.24.ebuild b/app-misc/elasticsearch/elasticsearch-7.17.24.ebuild
new file mode 100644
index 000000000000..d8370e7f9001
--- /dev/null
+++ b/app-misc/elasticsearch/elasticsearch-7.17.24.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit systemd tmpfiles
+
+DESCRIPTION="Free and Open, Distributed, RESTful Search Engine"
+HOMEPAGE="https://www.elastic.co/elasticsearch/"
+SRC_URI="https://artifacts.elastic.co/downloads/${PN}/${P}-no-jdk-linux-x86_64.tar.gz"
+LICENSE="Apache-2.0 BSD-2 Elastic-2.0 LGPL-3 MIT public-domain"
+SLOT="0/7"
+KEYWORDS="~amd64"
+
+RDEPEND="acct-group/elasticsearch
+ acct-user/elasticsearch
+ sys-libs/zlib
+ virtual/jre"
+
+QA_PREBUILT="usr/share/elasticsearch/modules/x-pack-ml/platform/linux-x86_64/\(bin\|lib\)/.*"
+QA_PRESTRIPPED="usr/share/elasticsearch/modules/x-pack-ml/platform/linux-x86_64/\(bin\|lib\)/.*"
+
+src_prepare() {
+ default
+
+ rm LICENSE.txt NOTICE.txt || die
+ rmdir logs || die
+}
+
+src_install() {
+ keepdir /etc/${PN}
+ keepdir /etc/${PN}/scripts
+
+ insinto /etc/${PN}
+ doins -r config/.
+ rm -r config || die
+
+ fowners root:${PN} /etc/${PN}
+ fperms 2750 /etc/${PN}
+
+ insinto /usr/share/${PN}
+ doins -r .
+
+ exeinto /usr/share/${PN}/bin
+ doexe "${FILESDIR}/elasticsearch-systemd-pre-exec"
+
+ fperms -R +x /usr/share/${PN}/bin
+ fperms -R +x /usr/share/${PN}/modules/x-pack-ml/platform/linux-x86_64/bin
+
+ keepdir /var/{lib,log}/${PN}
+ fowners ${PN}:${PN} /var/{lib,log}/${PN}
+ fperms 0750 /var/{lib,log}/${PN}
+
+ insinto /etc/sysctl.d
+ newins "${FILESDIR}/${PN}.sysctl.d" ${PN}.conf
+
+ newconfd "${FILESDIR}/${PN}.conf.4" ${PN}
+ newinitd "${FILESDIR}/${PN}.init.9" ${PN}
+
+ systemd_install_serviced "${FILESDIR}/${PN}.service.conf"
+ systemd_newunit "${FILESDIR}"/${PN}.service.3 ${PN}.service
+
+ newtmpfiles "${FILESDIR}"/${PN}.tmpfiles.d ${PN}.conf
+}
+
+pkg_postinst() {
+ tmpfiles_process /usr/lib/tmpfiles.d/${PN}.conf
+
+ elog
+ elog "You may create multiple instances of ${PN} by"
+ elog "symlinking the init script:"
+ elog "ln -sf /etc/init.d/${PN} /etc/init.d/${PN}.instance"
+ elog
+ elog "Please make sure you put elasticsearch.yml, log4j2.properties and scripts"
+ elog "from /etc/${PN} into the configuration directory of the instance:"
+ elog "/etc/${PN}/instance"
+ elog
+ ewarn "Please make sure you have proper permissions on /etc/${PN}"
+ ewarn "prior to keystore generation or you may experience startup fails."
+ ewarn "chown root:${PN} /etc/${PN} && chmod 2750 /etc/${PN}"
+ ewarn "chown root:${PN} /etc/${PN}/${PN}.keystore && chmod 0660 /etc/${PN}/${PN}.keystore"
+}