summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Anderson <telans@posteo.de>2021-03-07 12:56:08 +0100
committerDavid Seifert <soap@gentoo.org>2021-03-07 12:56:08 +0100
commit9396b836ff6e515b4d4cc9b49ab06403b4d47062 (patch)
tree78814ac9094dd3f60a38ea5d3af48fd4cad93993 /app-misc
parentapp-emulation/libvirt: migrate to tmpfiles.eclass (diff)
downloadgentoo-9396b836ff6e515b4d4cc9b49ab06403b4d47062.tar.gz
gentoo-9396b836ff6e515b4d4cc9b49ab06403b4d47062.tar.bz2
gentoo-9396b836ff6e515b4d4cc9b49ab06403b4d47062.zip
app-misc/elasticsearch: migrate to tmpfiles.eclass
Package-Manager: Portage-3.0.16, Repoman-3.0.2 Signed-off-by: Theo Anderson <telans@posteo.de> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/elasticsearch/elasticsearch-6.8.13.ebuild6
-rw-r--r--app-misc/elasticsearch/elasticsearch-7.8.1.ebuild6
2 files changed, 6 insertions, 6 deletions
diff --git a/app-misc/elasticsearch/elasticsearch-6.8.13.ebuild b/app-misc/elasticsearch/elasticsearch-6.8.13.ebuild
index 6191d3d9e2e0..6b347e7957c4 100644
--- a/app-misc/elasticsearch/elasticsearch-6.8.13.ebuild
+++ b/app-misc/elasticsearch/elasticsearch-6.8.13.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit systemd
+inherit systemd tmpfiles
DESCRIPTION="Open Source, Distributed, RESTful, Search Engine"
HOMEPAGE="https://www.elastic.co/products/elasticsearch"
@@ -67,7 +67,7 @@ src_install() {
newinitd "${FILESDIR}/${PN}.init.6" ${PN}
systemd_install_serviced "${FILESDIR}/${PN}.service.conf"
- systemd_newtmpfilesd "${FILESDIR}/${PN}.tmpfiles.d" ${PN}.conf
+ newtmpfiles "${FILESDIR}/${PN}.tmpfiles.d" ${PN}.conf
systemd_newunit "${FILESDIR}"/${PN}.service.3 ${PN}.service
}
diff --git a/app-misc/elasticsearch/elasticsearch-7.8.1.ebuild b/app-misc/elasticsearch/elasticsearch-7.8.1.ebuild
index 2155270debec..8afc59b63222 100644
--- a/app-misc/elasticsearch/elasticsearch-7.8.1.ebuild
+++ b/app-misc/elasticsearch/elasticsearch-7.8.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit systemd
+inherit systemd tmpfiles
DESCRIPTION="Open Source, Distributed, RESTful, Search Engine"
HOMEPAGE="https://www.elastic.co/products/elasticsearch"
@@ -62,7 +62,7 @@ src_install() {
newinitd "${FILESDIR}/${PN}.init.7" ${PN}
systemd_install_serviced "${FILESDIR}/${PN}.service.conf"
- systemd_newtmpfilesd "${FILESDIR}/${PN}.tmpfiles.d" ${PN}.conf
+ newtmpfiles "${FILESDIR}/${PN}.tmpfiles.d" ${PN}.conf
systemd_newunit "${FILESDIR}"/${PN}.service.3 ${PN}.service
}