summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2024-06-22 21:34:23 +0200
committerConrad Kostecki <conikost@gentoo.org>2024-06-22 22:00:08 +0200
commit969521b7e51c5f37b571830e8fd0c0653f04896e (patch)
treeb1a0df668267c38366f8a8a1cb5c57f0de256592 /app-misc
parentapp-misc/ebusd: x86 stable (diff)
downloadgentoo-969521b7e51c5f37b571830e8fd0c0653f04896e.tar.gz
gentoo-969521b7e51c5f37b571830e8fd0c0653f04896e.tar.bz2
gentoo-969521b7e51c5f37b571830e8fd0c0653f04896e.zip
app-misc/fhem: add 6.3
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/fhem/Manifest1
-rw-r--r--app-misc/fhem/fhem-6.3.ebuild107
2 files changed, 108 insertions, 0 deletions
diff --git a/app-misc/fhem/Manifest b/app-misc/fhem/Manifest
index 05fe0c680ff2..f5149fb50c03 100644
--- a/app-misc/fhem/Manifest
+++ b/app-misc/fhem/Manifest
@@ -1 +1,2 @@
DIST fhem-6.2.tar.gz 32526944 BLAKE2B 00ec9cb1518ab002e0565150a30ec7191c1f0a8ae0fccb7a3a745837f7794e4f61a8e7fa4707416e841f86803d69c27f7158c36f765733e76f461dcbb15e306e SHA512 8bb4cf277ab3f008b353c3fa7f67a50f502299e79f2b96d13e88150766e39498888a05a44b6509a51f90d82dcd0aefa6642deea585c72d65e3849b6aa0322143
+DIST fhem-6.3.tar.gz 33197360 BLAKE2B ed995e70e9740c3f0b0564c7ca784529c91a6a5007432a6f913e71b1ef4997d46a89a1b1eb2d20f4ae95f50f7b6e833a8ab02027cff202701a85e19dff78ba5d SHA512 c52f7e3f7697a4b4ec0a75e21596f4b3f6439d2bd49ffdcc33a592532cc1582b6d516b4d214916e6fd4070a29fbf35fc3c6847e7240fb39e0ad18b4fc34fa7d3
diff --git a/app-misc/fhem/fhem-6.3.ebuild b/app-misc/fhem/fhem-6.3.ebuild
new file mode 100644
index 000000000000..b7cf99d0cf69
--- /dev/null
+++ b/app-misc/fhem/fhem-6.3.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit systemd tmpfiles
+
+DESCRIPTION="A GPL'd perl server for house automation"
+HOMEPAGE="https://www.fhem.de/"
+SRC_URI="https://www.fhem.de/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="
+ acct-group/fhem
+ acct-user/fhem
+ dev-perl/Crypt-CBC
+ dev-perl/Device-SerialPort
+ dev-perl/Digest-CRC
+ dev-perl/JSON
+"
+
+DEPEND="media-gfx/pngcrush"
+
+src_prepare() {
+ default
+
+ # Allow install path to be set by DESTDIR in Makefile
+ sed -i -e 's,^\(BINDIR=\),\1'\$\(DESTDIR\)',' Makefile || die
+
+ # Remove docs in Makefile, as they will be installed manually
+ sed -i -e 's/docs//g' Makefile || die
+ sed -i -e '/README_DEMO.txt/d' Makefile || die
+
+ # Remove manpage in Makefile, as it will be installed manually
+ sed -i -e '/fhem.pl.1/d' Makefile || die
+
+ # Remove lcd4linux binaries, as they are provied by app-misc/lcd4linux
+ rm -r contrib/lcd4linux || die
+
+ # Remove log dir, as it will be replaced with a symlink
+ rm -r log || die
+
+ # Fix fhemicon_darksmall.png, as it reports "broken IDAT window length"
+ # Reported to Upstream: https://forum.fhem.de/index.php/topic,86238.0.html
+ pngcrush -fix -force -ow www/images/default/fhemicon_darksmall.png || die
+
+ cp "${FILESDIR}"/fhem.cfg fhem.cfg || die
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ local DOCS=(
+ "CHANGED"
+ "HISTORY"
+ "MAINTAINER.txt"
+ "README.SVN"
+ "README_DEMO.txt"
+ "docs"/*.txt
+ "docs"/*.patch
+ "docs"/*.pdf
+ "docs/changelog"
+ "docs/copyright"
+ "docs/dotconfig"
+ "docs/fhem.odg.readme"
+ "docs/LIESMICH.update-thirdparty"
+ "docs"/README*
+ "docs/X10"
+ )
+
+ if use doc; then
+ local DOCS+=( "docs/X10" )
+ local HTML_DOCS=( "docs/"*.eps "docs/"*.html "docs"/*.jpg "docs"/*.js "docs"/*.odg "docs/"*.png "docs/km271" )
+ fi
+
+ diropts -o fhem -g fhem
+ keepdir "/var/lib/fhem"
+ keepdir "/var/log/fhem"
+ diropts
+
+ dosym ../../var/lib/fhem /opt/fhem/data
+ dosym ../../var/log/fhem /opt/fhem/log
+
+ default
+
+ newinitd "${FILESDIR}"/fhem.initd fhem
+
+ systemd_newunit "${FILESDIR}"/fhem.service-r1 fhem.service
+ newtmpfiles "${FILESDIR}"/fhem.tmpfiles fhem.conf
+
+ newman docs/fhem.man fhem.pl.1
+
+ echo 'CONFIG_PROTECT="/opt/fhem /var/lib/fhem"' > "${T}"/99fhem || die
+ doenvd "${T}"/99fhem
+
+ fowners fhem:fhem /opt/fhem/fhem.cfg
+}
+
+pkg_postinst() {
+ tmpfiles_process fhem.conf
+}