summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-22 06:08:10 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-22 07:01:54 +0200
commit02452a18f95e91923de3fbc01ca8e4ae2a2ad268 (patch)
tree12df3f85818f513f5ebe32551f249df5dc35903b /app-office
parentapp-admin/awscli: Bump to 1.34.3 (diff)
downloadgentoo-02452a18f95e91923de3fbc01ca8e4ae2a2ad268.tar.gz
gentoo-02452a18f95e91923de3fbc01ca8e4ae2a2ad268.tar.bz2
gentoo-02452a18f95e91923de3fbc01ca8e4ae2a2ad268.zip
app-office/abiword: Patch a build failure with gcc-14
Closes: https://bugs.gentoo.org/922633 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-office')
-rw-r--r--app-office/abiword/abiword-3.0.5-r1.ebuild2
-rw-r--r--app-office/abiword/files/abiword-3.0.5-gcc14.patch12
2 files changed, 14 insertions, 0 deletions
diff --git a/app-office/abiword/abiword-3.0.5-r1.ebuild b/app-office/abiword/abiword-3.0.5-r1.ebuild
index 4e942cdb2686..f753d91ff68a 100644
--- a/app-office/abiword/abiword-3.0.5-r1.ebuild
+++ b/app-office/abiword/abiword-3.0.5-r1.ebuild
@@ -86,6 +86,8 @@ PATCHES=(
"${WORKDIR}"/patches/${PN}-3.0.4-c++17-dynamic-exception-specifications.patch
"${FILESDIR}"/${PN}-3.0.5-musl-lose-precision-fix.patch
"${FILESDIR}"/${PN}-3.0.5-libxml2-2.12.patch
+ # https://bugs.gentoo.org/922633
+ "${FILESDIR}"/${PN}-3.0.5-gcc14.patch
)
src_prepare() {
diff --git a/app-office/abiword/files/abiword-3.0.5-gcc14.patch b/app-office/abiword/files/abiword-3.0.5-gcc14.patch
new file mode 100644
index 000000000000..aa0519c0d43a
--- /dev/null
+++ b/app-office/abiword/files/abiword-3.0.5-gcc14.patch
@@ -0,0 +1,12 @@
+diff --git a/plugins/mathview/itex2mml/itex2MML.y b/plugins/mathview/itex2mml/itex2MML.y
+index c4e1cc5..60bc842 100644
+--- a/plugins/mathview/itex2mml/itex2MML.y
++++ b/plugins/mathview/itex2mml/itex2MML.y
+@@ -1804,6 +1804,7 @@ static void itex2MML_keep_error (const char * msg)
+ itex2MML_last_error = itex2MML_copy_escaped (msg);
+ }
+
++int itex2MML_do_html_filter (const char *, unsigned long, const int);
+ int itex2MML_html_filter (const char * buffer, unsigned long length)
+ {
+ return itex2MML_do_html_filter (buffer, length, 0);