summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-09-11 11:11:04 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-09-11 11:14:38 -0400
commitad447ade62913d4a72e6b1cd1ea8cbeae6d95f32 (patch)
tree75e04cbf09d23723068351ed0c08ee69776789a1 /app-portage
parentxfce-base/thunar: Bump to 4.17.5 (diff)
downloadgentoo-ad447ade62913d4a72e6b1cd1ea8cbeae6d95f32.tar.gz
gentoo-ad447ade62913d4a72e6b1cd1ea8cbeae6d95f32.tar.bz2
gentoo-ad447ade62913d4a72e6b1cd1ea8cbeae6d95f32.zip
app-portage/iwdevtools: add 0.7.0
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/iwdevtools/Manifest1
-rw-r--r--app-portage/iwdevtools/iwdevtools-0.7.0.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/app-portage/iwdevtools/Manifest b/app-portage/iwdevtools/Manifest
index 919ff4687f90..4564e3e2118b 100644
--- a/app-portage/iwdevtools/Manifest
+++ b/app-portage/iwdevtools/Manifest
@@ -1,3 +1,4 @@
DIST iwdevtools-0.4.0.tar.gz 31939 BLAKE2B bdab037a2b27bf0c67bb453427ad7f8d7485db3f45f3c465e3b2790e8e259b1328b75eff7d86012df06a44f4101e8bc0e83c9e7a8886adc25d589ecca1a25892 SHA512 a8be15568f24d2f54178f9a92cbc4107f7fdb06da8b2a769ad19ca5b55e90896c4b2253569d7d39158765081d9f9267ff568a066edef8401ec52c29451655ee1
DIST iwdevtools-0.5.3.tar.gz 42845 BLAKE2B 9e6b634e8409cffc57fde36157be0186943d4df07c47f0b07eeb0dd5071bc3e4c7b84e543a46cd2ff4e49d9b9b34b9121b3583bd227479f1485ec5957dee4780 SHA512 8458abba687135caaefd1cb0adb8af079a2cf94ca484a4bb95ef2b32e00eea46a2c8df7d305d4b0bf7121f46a92ac3a25cd9067e22ad9a314f289f77379a1684
DIST iwdevtools-0.6.0.tar.gz 51788 BLAKE2B 1b37e3097cd77201398959272c09d6391746036530c6341b7b2ccfccc4361067dc46c6e3b2c729717855e346a7ebf7279f8d0fc0a760203527a1431e2366dad0 SHA512 0c192c9a6b52eca99574eda8da8d41b051a502cbbf891188e323f376f43472aaa72c2f8ac78f4790c4f41d610aa0927180a3fbe290ac2964ccb9f257b7f508fc
+DIST iwdevtools-0.7.0.tar.gz 56208 BLAKE2B 205bb9bc1e894b9cc6a9c3abb4f902c9c3f8337fff8618df162f4dc5d78416fe8e2852cb513d4153d8acf2a0d918e43352714502e1f40faffc777e19ad81ab55 SHA512 ec528901229066d333fcd8f53060601628b682a93c3e07a89826ff0fd2e406a4dffe76397883d4c50b459588cc6364873c43e5129bd172049c30aea039ae36d5
diff --git a/app-portage/iwdevtools/iwdevtools-0.7.0.ebuild b/app-portage/iwdevtools/iwdevtools-0.7.0.ebuild
new file mode 100644
index 000000000000..25cb8346209b
--- /dev/null
+++ b/app-portage/iwdevtools/iwdevtools-0.7.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson optfeature
+
+DESCRIPTION="Small tools to aid with Gentoo development, primarily intended for QA"
+HOMEPAGE="https://github.com/ionenwks/iwdevtools"
+SRC_URI="https://github.com/ionenwks/iwdevtools/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ app-misc/pax-utils
+ app-portage/portage-utils
+ sys-apps/diffutils
+ sys-apps/file
+ sys-apps/portage
+ sys-apps/util-linux"
+BDEPEND="
+ sys-apps/help2man
+ test? ( ${RDEPEND} )"
+
+src_configure() {
+ local emesonargs=(
+ -Ddocdir=${PF}
+ -Deprefix="${EPREFIX}"
+ $(meson_use test)
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ optfeature "detecting potential ABI issues using abidiff" dev-util/libabigail
+
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog "To (optionally) integrate with portage, inspect the .bashrc files installed"
+ elog "at ${EROOT}/usr/share/${PN}. If not already using a bashrc, you can use"
+ elog "the example bashrc directly by creating a symlink:"
+ elog
+ elog " ln -s ../../usr/share/${PN}/bashrc ${EROOT}/etc/portage/bashrc"
+ elog
+ elog "See ${EROOT}/usr/share/doc/${PF}/README.rst* for info on tools."
+ fi
+}