summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2022-07-21 12:21:20 -0400
committerAnthony G. Basile <blueness@gentoo.org>2022-07-21 12:21:20 -0400
commitcc8d5b81fe2f0a1a38b2ccd757a9e8460398881c (patch)
treecfad6e06c6aa3eb6f21902080c6555d0c8a4c7f2 /app-portage
parentapp-editors/vim-core: Drop outdated blockers (diff)
downloadgentoo-cc8d5b81fe2f0a1a38b2ccd757a9e8460398881c.tar.gz
gentoo-cc8d5b81fe2f0a1a38b2ccd757a9e8460398881c.tar.bz2
gentoo-cc8d5b81fe2f0a1a38b2ccd757a9e8460398881c.zip
app-portage/grs: version bump to 0.8
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/grs/Manifest1
-rw-r--r--app-portage/grs/grs-0.8.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/app-portage/grs/Manifest b/app-portage/grs/Manifest
index 6fc83dd26ee7..59a144c1406a 100644
--- a/app-portage/grs/Manifest
+++ b/app-portage/grs/Manifest
@@ -1,2 +1,3 @@
DIST ISO-1.tar.gz 2887967 BLAKE2B 0ae9d9c4078974316d6865a8601705f7c69c8305d8401835bfa544d14a90b3688ea6b881a1c07bcb969fe2b15f210d05f114ebaf3af5ba6f1ae3705d395f1603 SHA512 50bd9bcaa3d1900763936beb4801fd9e5cb963e39d51c39c9cc9a8d160469db1b0c6fffae01bbb5d5d5c6d4e42d84a6c499c465bbdd964835c2d190785eed52d
DIST grs-0.7.tar.gz 36330 BLAKE2B 9e835262656f8a51969810f92a1ae801bc058c4529c01fe1998227fa8b81939c1d7db9f335f5a18f18d9cbd53ec809d289efd80ba7543b3b61a8dee1296bd780 SHA512 b530d66e3402e34f1c4efdff0af0e1d0f0ccf311c440c8d5ee050f8a8ab178d663433f766d507c5b1280ef9056fd97d05915e65e07a1a59bb8a3c80fd4bab4c6
+DIST grs-0.8.tar.gz 36501 BLAKE2B 2ed3391d2b12f41d2e50b54518728c642ede0deecca71aa6c6977bc4b01d53cd0274623b09e5be898a00254148d1cdcb8751d3cac50cf08ab1358cd1b7ad7007 SHA512 ae17c0af785cd4a75cb94bebb9b61c69b8e0a772643fdc7d978dfba274419bec76f4c9bafa984a83d86b13eb919ded51ac06cc7965fea2f0aab71cbaebeb2a84
diff --git a/app-portage/grs/grs-0.8.ebuild b/app-portage/grs/grs-0.8.ebuild
new file mode 100644
index 000000000000..4d092253267a
--- /dev/null
+++ b/app-portage/grs/grs-0.8.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+PYTHON_COMPAT=( python3_{8,9,10} )
+DISTUTILS_USE_SETUPTOOLS=no
+
+inherit distutils-r1 linux-info
+
+ISO="ISO-1.tar.gz"
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/grss.git"
+ SRC_URI="https://dev.gentoo.org/~blueness/${PN}/${ISO}"
+ inherit git-r3
+else
+ SRC_URI="https://dev.gentoo.org/~blueness/${PN}/${P}.tar.gz
+ https://dev.gentoo.org/~blueness/${PN}/${ISO}"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+DESCRIPTION="Suite to build Gentoo Reference Systems"
+HOMEPAGE="https://dev.gentoo.org/~blueness/grs"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="server"
+
+DEPEND=""
+RDEPEND="
+ sys-apps/portage[${PYTHON_USEDEP}]
+ server? (
+ app-arch/tar[xattr]
+ app-cdr/cdrtools
+ app-crypt/md5deep
+ dev-libs/libcgroup
+ dev-vcs/git
+ net-misc/rsync
+ sys-fs/squashfs-tools
+ sys-kernel/genkernel
+ )"
+
+pkg_setup() {
+ if use server; then
+ local CONFIG_CHECK="~CGROUPS"
+ local ERROR_CGROUPS="WARNING: grsrun requires CONFIG_CGROUPS enabled in the kernel."
+ linux-info_pkg_setup
+ fi
+}
+
+src_install() {
+ distutils-r1_src_install
+ echo "CONFIG_PROTECT=\"/etc/grs/systems.conf\"" > "${T}"/20grs
+ doenvd "${T}"/20grs
+ if use server; then
+ mkdir "${D}"/usr/share/${PN}
+ cp "${DISTDIR}"/${ISO} "${D}"/usr/share/${PN}
+ fi
+}