summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-18 15:59:15 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-18 17:21:30 +0100
commite7b8c1da9778c1b5732582f62c0503a400bccfd8 (patch)
treeef23bf348b0ba7620be947b0189e235f6c41acb2 /app-portage
parentvirtual/dist-kernel: Bump to 6.1.7 (diff)
downloadgentoo-e7b8c1da9778c1b5732582f62c0503a400bccfd8.tar.gz
gentoo-e7b8c1da9778c1b5732582f62c0503a400bccfd8.tar.bz2
gentoo-e7b8c1da9778c1b5732582f62c0503a400bccfd8.zip
app-portage/gentoopm: Bump to 0.5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/gentoopm/Manifest1
-rw-r--r--app-portage/gentoopm/gentoopm-0.5.0.ebuild35
-rw-r--r--app-portage/gentoopm/gentoopm-9999.ebuild13
3 files changed, 46 insertions, 3 deletions
diff --git a/app-portage/gentoopm/Manifest b/app-portage/gentoopm/Manifest
index 974d1511a2fe..7f0b5ceebd3c 100644
--- a/app-portage/gentoopm/Manifest
+++ b/app-portage/gentoopm/Manifest
@@ -1 +1,2 @@
DIST gentoopm-0.4.tar.gz 39123 BLAKE2B c8ea81e2d1aa09d3aa838ccb2a1d221e29ba6cf20c5539435a36da058733ee6814864f11a5a96742b371c6d0f2e1ffa269edf197cd30cf4bc7d517f9fa6623cc SHA512 7af0d4d8b3562b009d8897b70b8621d2004e22a16006ec84144544174724757b39e09cbde98ee876adc166947a58e4afa85f752c66d4dbb03ff1d3a52074720f
+DIST gentoopm-0.5.0.gh.tar.gz 36710 BLAKE2B 12819b645154fd9ea68cd2b4f605c8ea3fcbec5005754acfd0e96081527c66a04d37ab73c8c967f5989abf97f155263c98ccb3ce6e0bc1fe9d9e5dbbc639c902 SHA512 b5ff3f79c54028b8d1442414353e4872fb0249c75ce9dedff9c907bd1307841996c254b502d18f32469d938a62add2acdd77080c693069a4b01afecca382a67e
diff --git a/app-portage/gentoopm/gentoopm-0.5.0.ebuild b/app-portage/gentoopm/gentoopm-0.5.0.ebuild
new file mode 100644
index 000000000000..a18a6122239d
--- /dev/null
+++ b/app-portage/gentoopm/gentoopm-0.5.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A common interface to Gentoo package managers"
+HOMEPAGE="
+ https://github.com/projg2/gentoopm/
+ https://pypi.org/project/gentoopm/
+"
+SRC_URI="
+ https://github.com/projg2/gentoopm/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~mips ~ppc64 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ || (
+ >=sys-apps/pkgcore-0.9.4[${PYTHON_USEDEP}]
+ >=sys-apps/portage-2.1.10.3[${PYTHON_USEDEP}]
+ )
+"
+PDEPEND="
+ app-eselect/eselect-package-manager
+"
+
+distutils_enable_tests pytest
diff --git a/app-portage/gentoopm/gentoopm-9999.ebuild b/app-portage/gentoopm/gentoopm-9999.ebuild
index 65baaa7ea631..82fe7d65e1e8 100644
--- a/app-portage/gentoopm/gentoopm-9999.ebuild
+++ b/app-portage/gentoopm/gentoopm-9999.ebuild
@@ -9,7 +9,10 @@ PYTHON_COMPAT=( python3_{9..11} pypy3 )
inherit distutils-r1 git-r3
DESCRIPTION="A common interface to Gentoo package managers"
-HOMEPAGE="https://github.com/projg2/gentoopm/"
+HOMEPAGE="
+ https://github.com/projg2/gentoopm/
+ https://pypi.org/project/gentoopm/
+"
EGIT_REPO_URI="https://github.com/projg2/gentoopm.git"
LICENSE="BSD-2"
@@ -18,7 +21,11 @@ SLOT="0"
RDEPEND="
|| (
>=sys-apps/pkgcore-0.9.4[${PYTHON_USEDEP}]
- >=sys-apps/portage-2.1.10.3[${PYTHON_USEDEP}] )"
-PDEPEND="app-eselect/eselect-package-manager"
+ >=sys-apps/portage-2.1.10.3[${PYTHON_USEDEP}]
+ )
+"
+PDEPEND="
+ app-eselect/eselect-package-manager
+"
distutils_enable_tests pytest