summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-08-12 18:44:15 +0100
committerSam James <sam@gentoo.org>2022-08-12 19:16:24 +0100
commitc4ec3861df3bdd42b9ca48b9850b18373e873226 (patch)
tree682c4f3184d3a6f86ce54a8ec7af4dbe75d32bc4 /app-shells/fzf
parentsys-boot/gnu-efi: add 3.0.15 (diff)
downloadgentoo-c4ec3861df3bdd42b9ca48b9850b18373e873226.tar.gz
gentoo-c4ec3861df3bdd42b9ca48b9850b18373e873226.tar.bz2
gentoo-c4ec3861df3bdd42b9ca48b9850b18373e873226.zip
app-shells/fzf: add 0.32.1
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-shells/fzf')
-rw-r--r--app-shells/fzf/Manifest2
-rw-r--r--app-shells/fzf/fzf-0.32.1.ebuild72
2 files changed, 74 insertions, 0 deletions
diff --git a/app-shells/fzf/Manifest b/app-shells/fzf/Manifest
index aebcc868f831..fb429c7f33a8 100644
--- a/app-shells/fzf/Manifest
+++ b/app-shells/fzf/Manifest
@@ -2,3 +2,5 @@ DIST fzf-0.30.0-deps.tar.xz 20315772 BLAKE2B 8664b82f5e837bde97251f64e6d8637f202
DIST fzf-0.30.0.tar.gz 209750 BLAKE2B ee21726dac11cddc29839c1c2368e46497b4b5172e8896914b8fda602ecb28a7179f27cb3c63d9841f42e87e7d3589b37427b348b9e59cf531797c487e3fdc2d SHA512 cebb685a7fa00bdff07751d0021edde82f0ff3bf705eff82f94f6bf57c5e008eb6894d023ed7b14378f1d92fa2394192c12b720c6f711b1a414438fe3f8b4ec3
DIST fzf-0.31.0-deps.tar.xz 16051640 BLAKE2B 9aac02a1df4d9db7cf11c77dead32fb13b74965e0c38b4d5d650daff123a697091db93235c3a3f3325c91351cbaf4b5401cdeee8d5120a59bc83fa9a0ca763da SHA512 bd88603ce059cac3c10bcf4face50f8097d7efcc26ef8b61870f93e7405b849293c80e9d39e124a63103080b6bab0cc28225b85470bc650fc53c61aa5ae9f33d
DIST fzf-0.31.0.tar.gz 210779 BLAKE2B 013ba0689e661a2497ffd3a6046ae330930aca295ad9b9620ab70474d34d969a78fccebb59daf45b278a76f33093db1fcd6838fb785aa63008755ce693b15967 SHA512 e0d281fe771a51d4bd617227daa9533e0d219cc047233ca9f342683591bc09843aad1d3686d58ddef71c317e69b2ccaf4a3d6175959cf81aaec50914fe51dea0
+DIST fzf-0.32.1-deps.tar.xz 16042284 BLAKE2B 9ca05904cfa0790372e1879a77946e337dff32c51fb787f38aba305fa5f2873d05ee6cc99cecc100355dbdd6cb598675a19aeb82eb922900030739f47c297bc8 SHA512 7326e3d10aae637a9879a231ff179b03b6c052160609053c79a7fd2e578e8986cc00a4ae117b780b686581507f9762fec7c9068b9f83cd0473dcaab8c975133d
+DIST fzf-0.32.1.tar.gz 212217 BLAKE2B b1b80bd5ed69dafdca3d52ff1630be99e1384119818bacb31fc04e0cfe58cfd99a4ebb9bd9b8a29e885e7e3db8aa8ba5046107d41a5222c6c05c5d194c42d394 SHA512 8abf7eceec466a3bb0cca48e36a426b4fbf5a4cb07f09756b92705fba11dc432d59102cf0337c8f0bae2782747a45cb7040d2f0de5a2050bb80fd5a6e09f0439
diff --git a/app-shells/fzf/fzf-0.32.1.ebuild b/app-shells/fzf/fzf-0.32.1.ebuild
new file mode 100644
index 000000000000..12b7161dcb56
--- /dev/null
+++ b/app-shells/fzf/fzf-0.32.1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1 go-module
+
+DESCRIPTION="General-purpose command-line fuzzy finder, written in Golang"
+HOMEPAGE="https://github.com/junegunn/fzf"
+
+# For fancy versioning only. Bump on the next release!
+# MY_GIT_REV is the first 7 characters of release commit, we truncate it
+# after to make it easier to copy/paste.
+MY_GIT_REV=4993d19466d5f3ac127de5c0c461cde7ef1894d7
+MY_GIT_REV=${MY_GIT_REV:0:7}
+
+SRC_URI="https://github.com/junegunn/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-deps.tar.xz"
+
+LICENSE="MIT BSD-with-disclosure"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+src_prepare() {
+ default
+ sed -i 's/-s -w //' Makefile || die # bug 795225
+}
+
+src_compile() {
+ emake PREFIX="${EPREFIX}"/usr VERSION=${PV} REVISION=${MY_GIT_REV} bin/${PN}
+}
+
+src_install() {
+ dobin bin/${PN}
+ doman man/man1/${PN}.1
+
+ dobin bin/${PN}-tmux
+ doman man/man1/${PN}-tmux.1
+
+ insinto /usr/share/vim/vimfiles/plugin
+ doins plugin/${PN}.vim
+
+ insinto /usr/share/nvim/runtime/plugin
+ doins plugin/${PN}.vim
+
+ newbashcomp shell/completion.bash ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ newins shell/completion.zsh _${PN}
+
+ insinto /usr/share/fzf
+ doins shell/key-bindings.bash
+ doins shell/key-bindings.fish
+ doins shell/key-bindings.zsh
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "To add fzf support to your shell, make sure to use the right file"
+ elog "from ${EROOT}/usr/share/fzf."
+ elog
+ elog "For bash, add the following line to ~/.bashrc:"
+ elog
+ elog " # source ${EROOT}/usr/share/bash-completion/completions/fzf"
+ elog " # source ${EROOT}/usr/share/fzf/key-bindings.bash"
+ elog
+ elog "Plugins for Vim and Neovim are installed to respective directories"
+ elog "and will work out of the box."
+ elog
+ elog "For fzf support in tmux see fzf-tmux(1)."
+ fi
+}