summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-10-21 01:45:04 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-10-21 02:48:39 +0200
commita1c4143ed582003e766d3a40fa63be3c00ddcd38 (patch)
tree17c05181a213ee7597f941e4b11a82465ee0b4c8 /app-shells/pwsh-bin
parentdev-lang/neko: depend on boehm-gc with USE=threads (diff)
downloadgentoo-a1c4143ed582003e766d3a40fa63be3c00ddcd38.tar.gz
gentoo-a1c4143ed582003e766d3a40fa63be3c00ddcd38.tar.bz2
gentoo-a1c4143ed582003e766d3a40fa63be3c00ddcd38.zip
app-shells/pwsh-bin: bump to 7.2.7
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-shells/pwsh-bin')
-rw-r--r--app-shells/pwsh-bin/Manifest3
-rw-r--r--app-shells/pwsh-bin/pwsh-bin-7.2.7.ebuild51
2 files changed, 54 insertions, 0 deletions
diff --git a/app-shells/pwsh-bin/Manifest b/app-shells/pwsh-bin/Manifest
index aaf4b0d09316..fccddcb385a8 100644
--- a/app-shells/pwsh-bin/Manifest
+++ b/app-shells/pwsh-bin/Manifest
@@ -7,3 +7,6 @@ DIST powershell-7.2.5-linux-x64.tar.gz 69364625 BLAKE2B 71a91e9d8196cca8a903fdea
DIST powershell-7.2.6-linux-arm32.tar.gz 66272150 BLAKE2B 4a8f0f6595e23cfda9881c698be808714b4d543f963a932926f13a57c143b51ca9357befb1c151d86ea831ff17e54da6324fc1b11c0d1edf2b2c2ff4c086a8ad SHA512 a265d13a32050d9920e020fbd4cb2b183230a5a243b78773f6517fc2f82968009a8c559aae382b7b2d85ef0302d56bf46e01bebb1994c9495c2e5afc57330914
DIST powershell-7.2.6-linux-arm64.tar.gz 64784215 BLAKE2B 2b792c1a4a2495e6cad0d0f545c55f89bcde933af3627f9f8ceb8d66f319ce7c4aca069167ebae79e12a2fe4e057ce970c64b0967684adecdbe6bae0de908dcb SHA512 5600f721503046bfabe0352bb406a3b528e7830e60286b25ab97a5c9729546a9ab4f1e2a5b33c4cde7b04ad713c9416fe55eb8b653f1f3bb87663a23d741ded4
DIST powershell-7.2.6-linux-x64.tar.gz 69438809 BLAKE2B ae55f01e1fef540e0c0da317dfe00fb1dbcffd531697fdf8a95982499057d4c573aec45a8805aecc23152c09f735280ba6a546b819373e8259984e4aaf119c88 SHA512 b331f5a3d0457d8a212740e5034791d04275cce411ca88bd5ff59349f2a62147d20ecef30d6aeb7c399e870397ddfe4d68fe72f90c928ae66dbc00931072e782
+DIST powershell-7.2.7-linux-arm32.tar.gz 66273712 BLAKE2B dcb949c0781660b51826817bce5d91842a28b9fac0b8b229763df24b83af10849d6a65d92a194b7b338779f32e8b71ab93bd97299ed2a26a006e547ade5e77f4 SHA512 b837b168d143c63aca193214d3513c43d54292560bf771b976b1909ba50fead34b5face5dda4d8e183d39761dac081b449d999f28980d62057179d4806771e85
+DIST powershell-7.2.7-linux-arm64.tar.gz 64782906 BLAKE2B 35f7a31c4787ff6bca0a54d2a218383b1ac30b1fde35d20040313504d84f71f79e6d7c1f9429626e0c02e6ee62415e39ff0bf00b5348e6a546567c98c93c7c91 SHA512 5a8ec9d340ccaa31a6517b6b6b7bff4f08db39534cebcc59b23bf4ba885cab663618fe61723e50f2818d1c29f9d4692a49e2245559b19b6e1ec43c06924db294
+DIST powershell-7.2.7-linux-x64.tar.gz 69431855 BLAKE2B 0a4fe34368abb5572cf86cc27b690df138a44c590c4364f7f7f79f8a4eaa27e126c6960f1959e7601304e1bda4c32af0785c4ea0b728967d014bf718abfdc672 SHA512 fcc48d5767f735c6348fdcf47eb3826f8b5d3efc48d97770796d0806ee6e2fe2989491bbd40ac1d3f2fbaf534a723ba3197037a54424c921958786f6b652e99e
diff --git a/app-shells/pwsh-bin/pwsh-bin-7.2.7.ebuild b/app-shells/pwsh-bin/pwsh-bin-7.2.7.ebuild
new file mode 100644
index 000000000000..43166039177b
--- /dev/null
+++ b/app-shells/pwsh-bin/pwsh-bin-7.2.7.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="PowerShell - binary precompiled for glibc"
+HOMEPAGE="https://microsoft.com/powershell"
+BASE_URI="https://github.com/PowerShell/PowerShell/releases/download"
+SRC_URI="
+ amd64? ( ${BASE_URI}/v${PV}/powershell-${PV}-linux-x64.tar.gz )
+ arm? ( ${BASE_URI}/v${PV}/powershell-${PV}-linux-arm32.tar.gz )
+ arm64? ( ${BASE_URI}/v${PV}/powershell-${PV}-linux-arm64.tar.gz )
+"
+S=${WORKDIR}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64"
+IUSE="+pwsh-symlink"
+REQUIRED_USE="elibc_glibc"
+
+RDEPEND="
+ app-crypt/mit-krb5:0/0
+ dev-util/lttng-ust:0
+ sys-libs/pam:0/0
+ sys-libs/zlib:0/1
+ || (
+ dev-libs/openssl-compat:1.0.0
+ =dev-libs/openssl-1.0*:0/0
+ )
+ pwsh-symlink? ( !app-shells/pwsh )
+"
+
+QA_PREBUILT="*"
+
+src_install() {
+ local dest=opt/pwsh
+ dodir ${dest}
+
+ local broken_symlinks=( libcrypto.so.1.0.0 libssl.so.1.0.0 )
+ local symlink
+ for symlink in "${broken_symlinks[@]}" ; do
+ [[ -L ${symlink} ]] && { rm "${symlink}" || die ; }
+ done
+
+ mv "${S}/"* "${ED}"/${dest}/ || die
+ fperms 0755 /${dest}/pwsh
+
+ dosym ../../${dest}/pwsh /usr/bin/pwsh-bin
+ use pwsh-symlink && dosym ../../${dest}/pwsh /usr/bin/pwsh
+}