summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-08-24 13:38:23 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-08-24 17:30:25 +0200
commitfb06fbfd3ca27bb9ea567f6d996162ba96a94571 (patch)
treef2df8d77bd39fe0f03a8f5b043578c2e615b6d02 /app-shells/pwsh-bin
parentdev-dotnet/fsautocomplete: bump to 0.74.0 (diff)
downloadgentoo-fb06fbfd3ca27bb9ea567f6d996162ba96a94571.tar.gz
gentoo-fb06fbfd3ca27bb9ea567f6d996162ba96a94571.tar.bz2
gentoo-fb06fbfd3ca27bb9ea567f6d996162ba96a94571.zip
app-shells/pwsh-bin: bump to 7.4.5
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-shells/pwsh-bin')
-rw-r--r--app-shells/pwsh-bin/Manifest3
-rw-r--r--app-shells/pwsh-bin/pwsh-bin-7.4.5.ebuild71
2 files changed, 74 insertions, 0 deletions
diff --git a/app-shells/pwsh-bin/Manifest b/app-shells/pwsh-bin/Manifest
index b2777515718a..9c58a5e5a53d 100644
--- a/app-shells/pwsh-bin/Manifest
+++ b/app-shells/pwsh-bin/Manifest
@@ -4,3 +4,6 @@ DIST powershell-7.4.3-linux-x64.tar.gz 70893666 BLAKE2B bc898eeafdf7b0eb2c3c1420
DIST powershell-7.4.4-linux-arm32.tar.gz 69166374 BLAKE2B 8be16e528ddef95422906b1e37d12067ae274d68efd03dd75c1c5b50e947b5ec617084bc0f5168f4f577893956ebdfee3ceb896c918fd149bc844581ff778a0d SHA512 66e822067dfaba1fb24c853c992539d0ec3562cb63513d7f3d5a1ded12bf6dce2d5d31ca0cd32bf6951fafc16b91be8bc3629559897e287b9bb0815f424ea557
DIST powershell-7.4.4-linux-arm64.tar.gz 68135393 BLAKE2B 12803b407093c9e9a804909c42b4237bd6376caeb174e815d258b3e53da2809f18d953e5103ea7a3ce7edacb2fccd7c668a2709f74e756b4bea8e4083c134228 SHA512 cd451c12b2877948e9c11d203a4cdd5af1791dd7f4ca338e936254c0268a5f93ee238034f5c1784b9472eb60d841548445557246296a0e3ff6973dbb641a43c7
DIST powershell-7.4.4-linux-x64.tar.gz 70860313 BLAKE2B 8780833ce8afd594503d1e62a9e794de12f7947b41e1823e41e646e1751723b957508efd8987dd8c0e36e8b8bf26ee819240ab38f7169712f108c889c8432eab SHA512 ddafaed9fc2e016e8f354e44709917f7999e16fbf4ad1d1b52b6b4682171b121e772d53bc9da5f6936ef770aa162b9da7f1ad99e337befb878b5bef265e2560f
+DIST powershell-7.4.5-linux-arm32.tar.gz 69183797 BLAKE2B 44ca41b55f6cebde7a2717cb04550ae675df019fc13872a6e1a8dea93ad4802663b21fb6caa19ffdd6335e6d908022881b2953019c9cfae05aee4ce3bbe666ce SHA512 3bd6f846d4a1ac0d67764792314031c61cc399386ef65253e6080f234bee07333acdcc88dca68b9fce75a5bfd71ea27d648176d39925866f304ca45a6d8dddb8
+DIST powershell-7.4.5-linux-arm64.tar.gz 68157221 BLAKE2B 4665d26f22c74129888c59f06fceac17e61c38c83e3f3178e3bf2d566a6f67748451bd74b5ad717896c2f4f1ff5536c7f71a656cf11fabb7790aac152484ef5a SHA512 de7fcdfe132e1e50a71caf6aff62f0fd915b9eb361147c15d746f7cb0246d544ee66076118ea74589b26e0548ad32e1eed8f5b59fde9be7798df502f002934a8
+DIST powershell-7.4.5-linux-x64.tar.gz 70898869 BLAKE2B c315c1ed361c7f97e834fbac589a0d4edc175d808e6b66d526fe2cdaf9e74ef2431a4cd513689fe79097c173cb988818f80a5f5101842e2ca96796b685fd618a SHA512 372959a6a5fa8a7ebe1c34999fa04d1ceb1eb30c6b8c082e030d09e5d4ed7782616002d5eb648412aed94d9998367358245544c685cbedfe60f9a522f9cda4f1
diff --git a/app-shells/pwsh-bin/pwsh-bin-7.4.5.ebuild b/app-shells/pwsh-bin/pwsh-bin-7.4.5.ebuild
new file mode 100644
index 000000000000..e09b2d5daf99
--- /dev/null
+++ b/app-shells/pwsh-bin/pwsh-bin-7.4.5.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit wrapper
+
+DESCRIPTION="Cross-platform automation and configuration tool (binary package)"
+HOMEPAGE="https://microsoft.com/powershell/
+ https://github.com/PowerShell/PowerShell/"
+
+BASE_URI="https://github.com/PowerShell/PowerShell/releases/download/"
+SRC_URI="
+ amd64? ( ${BASE_URI}/v${PV}/powershell-${PV}-linux-x64.tar.gz )
+ arm64? ( ${BASE_URI}/v${PV}/powershell-${PV}-linux-arm64.tar.gz )
+ arm? ( ${BASE_URI}/v${PV}/powershell-${PV}-linux-arm32.tar.gz )
+"
+S="${WORKDIR}"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64"
+REQUIRED_USE="elibc_glibc"
+
+RDEPEND="
+ app-crypt/mit-krb5:0/0
+ dev-libs/icu
+ dev-util/lttng-ust:0/2.12
+ sys-libs/pam:0/0
+ sys-libs/zlib:0/1
+ || (
+ dev-libs/openssl-compat:1.0.0
+ =dev-libs/openssl-1.0*:0/0
+ )
+"
+IDEPEND="
+ app-eselect/eselect-pwsh
+"
+
+QA_PREBUILT="*"
+
+src_install() {
+ local -a broken_symlinks
+ broken_symlinks=( libcrypto.so.1.0.0 libssl.so.1.0.0 )
+
+ local symlink
+ for symlink in "${broken_symlinks[@]}" ; do
+ if [[ -L "${symlink}" ]] ; then
+ rm "${symlink}" || die "failed to remove ${symlink}"
+ fi
+ done
+
+ local dest="opt/${PN}-${SLOT}"
+ local dest_root="/${dest}"
+
+ insinto "${dest_root}"
+ doins -r .
+
+ fperms 0755 "${dest_root}/pwsh"
+
+ local gentoo_path='PSModulePath="${PSModulePath}:${EPREFIX}/usr/share/GentooPowerShell/Modules:"'
+ make_wrapper "${PN}-${SLOT}" "env ${gentoo_path} ${dest_root}/pwsh"
+}
+
+pkg_postinst() {
+ eselect pwsh update ifunset
+}
+
+pkg_postrm() {
+ eselect pwsh update ifunset
+}