summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2015-10-15 19:44:00 +0000
committerPatrice Clement <monsieurp@gentoo.org>2015-10-15 20:49:56 +0000
commit7fcabd4514243ebc576282d5a9725e10202eed42 (patch)
tree265a1196c3a41173a1e5010a2e401b49bb7cf880 /app-shells/rc/rc-1.7.4.ebuild
parentapp-emulation/qemu: Backport a few MIPS patches. Bug #563162 (diff)
downloadgentoo-7fcabd4514243ebc576282d5a9725e10202eed42.tar.gz
gentoo-7fcabd4514243ebc576282d5a9725e10202eed42.tar.bz2
gentoo-7fcabd4514243ebc576282d5a9725e10202eed42.zip
app-shells/rc: Version bump.
Package-Manager: portage-2.2.20.1 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'app-shells/rc/rc-1.7.4.ebuild')
-rw-r--r--app-shells/rc/rc-1.7.4.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-shells/rc/rc-1.7.4.ebuild b/app-shells/rc/rc-1.7.4.ebuild
new file mode 100644
index 000000000000..55c650d5c2d4
--- /dev/null
+++ b/app-shells/rc/rc-1.7.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="A reimplementation of the Plan 9 shell"
+HOMEPAGE="http://static.tobold.org/"
+SRC_URI="http://static.tobold.org/${PN}/${P}.tar.gz"
+
+LICENSE="rc"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libedit readline"
+
+RDEPEND="readline? ( sys-libs/readline:0 )
+ libedit? ( dev-libs/libedit )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local myconf="--with-history"
+ use readline && myconf="--with-edit=readline"
+ use libedit && myconf="--with-edit=editline"
+
+ econf \
+ --disable-dependency-tracking \
+ "${myconf}"
+}
+
+src_install() {
+ into /
+ newbin rc rcsh
+ newman rc.1 rcsh.1
+ dodoc AUTHORS ChangeLog NEWS README
+}
+
+pkg_postinst() {
+ ebegin "Updating /etc/shells"
+ ( grep -v "^/bin/rcsh$" "${ROOT}"etc/shells; echo "/bin/rcsh" ) > "${T}"/shells
+ mv -f "${T}"/shells "${ROOT}"etc/shells
+ eend $?
+}