summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2024-07-15 14:03:08 -0400
committerMatt Turner <mattst88@gentoo.org>2024-07-15 14:05:38 -0400
commit292651f244a4a1f1ffee6dd0a5ad21eda03cac8d (patch)
tree251e7f40689eff514f865e480bcbfa987a98fa1c /app-shells
parentwww-apps/lidarr-bin: drop 2.4.2.4238 (diff)
downloadgentoo-292651f244a4a1f1ffee6dd0a5ad21eda03cac8d.tar.gz
gentoo-292651f244a4a1f1ffee6dd0a5ad21eda03cac8d.tar.bz2
gentoo-292651f244a4a1f1ffee6dd0a5ad21eda03cac8d.zip
app-shells/fzf: Version bump to 0.54.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/fzf/Manifest2
-rw-r--r--app-shells/fzf/fzf-0.54.0.ebuild72
2 files changed, 74 insertions, 0 deletions
diff --git a/app-shells/fzf/Manifest b/app-shells/fzf/Manifest
index da3b35cfebad..027922d3e96e 100644
--- a/app-shells/fzf/Manifest
+++ b/app-shells/fzf/Manifest
@@ -4,3 +4,5 @@ DIST fzf-0.52.1-deps.tar.xz 18022516 BLAKE2B d6b5b5075409e7078958735ccc92b34dbed
DIST fzf-0.52.1.tar.gz 274817 BLAKE2B a42e694ab3a34025ecee5343e8eeb43221f66989fe6c7b827ad36d60a980c8fcea8414fffbed6858c7eec4d0e54ccc2165eafc5aecd8292d91e05da04bda1f6f SHA512 90b70c0fff41605ca647b02b64a6906e113e6cc377a51db8771806da58463ab87512294b430243b0263a3e800d64e652b6b2580b0b8205890f235d3b64c5e763
DIST fzf-0.53.0-deps.tar.xz 5882848 BLAKE2B b7faec7c2afd60642c27afa6f3c7a99fc1409d73c7d95f2f79737af3034769cef97aab11b5054f0209430d4ab038b5663e0af71e1768f674f815c7cd7dc08c66 SHA512 862e3bf23647735b888861898fd041e1d3e3dc6dcc7197b382fe790323d4904fc95fd20168d76656655e8c02ffd3cb0ee60da8df72689a94252a293f567ad5b6
DIST fzf-0.53.0.tar.gz 286797 BLAKE2B f6355c168f2b587cc2d0b21ef483812db7e077e4bf19517a4fc8fed43dd6b3f557ce1a28630075b4f1e6238aacf02ce10ceb1afd4d7fe5ca6e2453c132c56d80 SHA512 4122b49e8fec936ec4da79cdb7a7ed1891caadf842008ae36aac5ce0aa1c2263bed68fa0332f2cb4f2b38551469af0f14874410407b922827e62767032e92393
+DIST fzf-0.54.0-deps.tar.xz 5882708 BLAKE2B 1d9ca4f000960c811b5c45c61c59469c19d6947ad93fd627d0284d35c19a8df8eae96b76d8460d46ba924dd72775988f109e1eb9459499d5e307dff1920889df SHA512 ddb12e3ffab548399e81da2535857061cd9874a92534afc807fad2381562ba2fa0962cdbb366033769fa22871dcb12d187d394774e1fb2f225ceb388e92c9b25
+DIST fzf-0.54.0.tar.gz 291944 BLAKE2B e960285192c055e2228f682216aaebe02751ab66d8e9aa2bb347d46c5fc4aaa6895236c0059b4085cac213e3f8516a0ce2e9e0427a834b1c74cc41df28a2d167 SHA512 ed136c12142ceb7fabb39bd8f2d5e408efc44d17fb94514d9677a0a47013dc488bafeb657b7d448533d487091db4bd4194510e99493f8b05b007560d8c59ee2c
diff --git a/app-shells/fzf/fzf-0.54.0.ebuild b/app-shells/fzf/fzf-0.54.0.ebuild
new file mode 100644
index 000000000000..380854366f61
--- /dev/null
+++ b/app-shells/fzf/fzf-0.54.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1 go-module
+
+DESCRIPTION="General-purpose command-line fuzzy finder, written in Golang"
+HOMEPAGE="https://github.com/junegunn/fzf"
+
+# For fancy versioning only. Bump on the next release!
+# MY_GIT_REV is the first 7 characters of release commit, we truncate it
+# after to make it easier to copy/paste.
+MY_GIT_REV=9e92b6f11e0f59272de410f56493893334071e6e
+MY_GIT_REV=${MY_GIT_REV:0:7}
+
+SRC_URI="https://github.com/junegunn/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~mattst88/distfiles/${P}-deps.tar.xz"
+
+LICENSE="MIT BSD-with-disclosure"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+src_prepare() {
+ default
+ sed -i 's/-s -w //' Makefile || die # bug #795225
+}
+
+src_compile() {
+ emake PREFIX="${EPREFIX}"/usr VERSION=${PV} REVISION=${MY_GIT_REV} bin/${PN}
+}
+
+src_install() {
+ dobin bin/${PN}
+ doman man/man1/${PN}.1
+
+ dobin bin/${PN}-tmux
+ doman man/man1/${PN}-tmux.1
+
+ insinto /usr/share/vim/vimfiles/plugin
+ doins plugin/${PN}.vim
+
+ insinto /usr/share/nvim/runtime/plugin
+ doins plugin/${PN}.vim
+
+ newbashcomp shell/completion.bash ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ newins shell/completion.zsh _${PN}
+
+ insinto /usr/share/fzf
+ doins shell/key-bindings.bash
+ doins shell/key-bindings.fish
+ doins shell/key-bindings.zsh
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "To add fzf support to your shell, make sure to use the right file"
+ elog "from ${EROOT}/usr/share/fzf."
+ elog
+ elog "For bash, add the following line to ~/.bashrc:"
+ elog
+ elog " # source ${EROOT}/usr/share/bash-completion/completions/fzf"
+ elog " # source ${EROOT}/usr/share/fzf/key-bindings.bash"
+ elog
+ elog "Plugins for Vim and Neovim are installed to respective directories"
+ elog "and will work out of the box."
+ elog
+ elog "For fzf support in tmux see fzf-tmux(1)."
+ fi
+}