summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-02-24 02:40:31 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-02-24 03:15:19 +0100
commit89040598f902d95b153b5dd00e10d7d2850c5e75 (patch)
treeb255f5388d76c5fb3e581c3be4cb765f31beebbb /app-shells
parentwww-client/chromium: update ppc64 patchset for 109.0.5414.119 (diff)
downloadgentoo-89040598f902d95b153b5dd00e10d7d2850c5e75.tar.gz
gentoo-89040598f902d95b153b5dd00e10d7d2850c5e75.tar.bz2
gentoo-89040598f902d95b153b5dd00e10d7d2850c5e75.zip
app-shells/pwsh-bin: bump to 7.3.3
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/pwsh-bin/Manifest3
-rw-r--r--app-shells/pwsh-bin/pwsh-bin-7.3.3.ebuild51
2 files changed, 54 insertions, 0 deletions
diff --git a/app-shells/pwsh-bin/Manifest b/app-shells/pwsh-bin/Manifest
index 498c5d3c2947..d901136a237c 100644
--- a/app-shells/pwsh-bin/Manifest
+++ b/app-shells/pwsh-bin/Manifest
@@ -4,3 +4,6 @@ DIST powershell-7.3.1-linux-x64.tar.gz 71616643 BLAKE2B 16ecc1211f796f92d5cf64ac
DIST powershell-7.3.2-linux-arm32.tar.gz 69012331 BLAKE2B d905870e2ba8679057ebc057152d400607be089503b0acec76125644ddd01aa18da0da5f52444fa4cd160df93b1f61ba35e16593cc4d1695346fcf87737b219b SHA512 4ac407ebbf0b38ae7d17011390f759a7998343707fa3b412e1fbd710486fbaa04167941491f781b11c91df2abef0ae3fcc07be5300c1d35d4a62f073810ad1b4
DIST powershell-7.3.2-linux-arm64.tar.gz 67914800 BLAKE2B 594893f484f5c7831538d402ea2bdd3114f5e3625db527ba92df0eabfc5c24e6f9af1502518cb5b6a3b163302482c9c08be692f44e9a1e343218d815f588e0e2 SHA512 b7f134311747c0f66dac37cce813015cb0ce6ff3d35732effb4d8150b2357fa559e13c69cfe33445acbfc1c73a4e02268fb0307fd1d9319449895579420a6842
DIST powershell-7.3.2-linux-x64.tar.gz 71500527 BLAKE2B 10e6715f3e96de17b8d1bacc34cdd9711490738323a756ec462960731debf556cb1ed2212647c8ff312c2c7d93a4670c2be5f292117d7eb3f164f30511b11e49 SHA512 c42cd23c0a1fd416d9f1c7b639428af70ef71339cd70629ee459cb5cec940a2376317fef3e251f8dca5fa11ac872a319b96d7472b9d359e102c79d8c47a6ffc9
+DIST powershell-7.3.3-linux-arm32.tar.gz 69047872 BLAKE2B 864ff7619290cb509f46e635afd74043c488922a7fe26585a4221b6d9f9780a10c2abb221d8db1c93ca86119956f7bfa0aedcb64fa2bea37a87fa604692d30bd SHA512 99b2eb2b6d420c84be24491b04b3f2aa2602b473187d55cf55e5fd826cbd34d6da5fa04ea28a026fe6eb852d88d2106ddab8ac24e29d539893daf91cc8a96eb6
+DIST powershell-7.3.3-linux-arm64.tar.gz 67958251 BLAKE2B 86ad243deeabb7173ba61ea51e7b66b2201301c210a56dad5b72d2e389f1430b6a361c7cc895edcd8028034cefab61d8c00d2a90a2c6bf02ffd2b77ce19515de SHA512 62ef16ac9d376af91d47b51d18bedd932ea7886c19b84d16657e9080f6b07e215057cf1588ad7816760b73395545e2f436d40b8a323d3c1b608ce056bb6c6ee0
+DIST powershell-7.3.3-linux-x64.tar.gz 71548865 BLAKE2B ab09580a57371fcbe1638b14d86531a74953c8d8093f2c88f2d13f0611459660ca41d05a92f2333f6086c9ed94fa5c865a066a4e17d195f034de77c75fd7e80b SHA512 e53ebe4eb3dc2e4fcd63b997a819828a8234c37334aafff158af98bcaaef743bfe64c00247224c35ddc04a3d227c8cf859a3f1f261f3cf4f9f57257008f59b86
diff --git a/app-shells/pwsh-bin/pwsh-bin-7.3.3.ebuild b/app-shells/pwsh-bin/pwsh-bin-7.3.3.ebuild
new file mode 100644
index 000000000000..c0d59b29fa41
--- /dev/null
+++ b/app-shells/pwsh-bin/pwsh-bin-7.3.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="PowerShell - binary precompiled for glibc"
+HOMEPAGE="https://microsoft.com/powershell"
+BASE_URI="https://github.com/PowerShell/PowerShell/releases/download"
+SRC_URI="
+ amd64? ( ${BASE_URI}/v${PV}/powershell-${PV}-linux-x64.tar.gz )
+ arm? ( ${BASE_URI}/v${PV}/powershell-${PV}-linux-arm32.tar.gz )
+ arm64? ( ${BASE_URI}/v${PV}/powershell-${PV}-linux-arm64.tar.gz )
+"
+S=${WORKDIR}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64"
+IUSE="+pwsh-symlink"
+REQUIRED_USE="elibc_glibc"
+
+RDEPEND="
+ app-crypt/mit-krb5:0/0
+ dev-util/lttng-ust:0/2.12
+ sys-libs/pam:0/0
+ sys-libs/zlib:0/1
+ || (
+ dev-libs/openssl-compat:1.0.0
+ =dev-libs/openssl-1.0*:0/0
+ )
+ pwsh-symlink? ( !app-shells/pwsh )
+"
+
+QA_PREBUILT="*"
+
+src_install() {
+ local dest=opt/pwsh
+ dodir ${dest}
+
+ local broken_symlinks=( libcrypto.so.1.0.0 libssl.so.1.0.0 )
+ local symlink
+ for symlink in "${broken_symlinks[@]}" ; do
+ [[ -L ${symlink} ]] && { rm "${symlink}" || die ; }
+ done
+
+ mv "${S}/"* "${ED}"/${dest}/ || die
+ fperms 0755 /${dest}/pwsh
+
+ dosym ../../${dest}/pwsh /usr/bin/pwsh-bin
+ use pwsh-symlink && dosym ../../${dest}/pwsh /usr/bin/pwsh
+}