summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-05-25 21:54:16 +0200
committerMichał Górny <mgorny@gentoo.org>2019-05-25 21:57:39 +0200
commitebecf48c22d9c5e85fd87024c19230e4b2938c59 (patch)
tree5cc30ec3f23ebb9ba02816a7d7c0933ec4f95722 /app-shells
parentapp-shells/bash-completion: arm64 stable (bug #686692) (diff)
downloadgentoo-ebecf48c22d9c5e85fd87024c19230e4b2938c59.tar.gz
gentoo-ebecf48c22d9c5e85fd87024c19230e4b2938c59.tar.bz2
gentoo-ebecf48c22d9c5e85fd87024c19230e4b2938c59.zip
app-shells/bash-completion: Use bashcomp2 git repo in -9999
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/bash-completion/bash-completion-9999.ebuild20
1 files changed, 11 insertions, 9 deletions
diff --git a/app-shells/bash-completion/bash-completion-9999.ebuild b/app-shells/bash-completion/bash-completion-9999.ebuild
index bd5e53f21aa0..5c0bff2495fe 100644
--- a/app-shells/bash-completion/bash-completion-9999.ebuild
+++ b/app-shells/bash-completion/bash-completion-9999.ebuild
@@ -3,14 +3,12 @@
EAPI=7
-BASHCOMP_P=bashcomp-2.0.2
PYTHON_COMPAT=( python3_{5,6,7} )
inherit autotools git-r3 python-any-r1
DESCRIPTION="Programmable Completion for bash"
HOMEPAGE="https://github.com/scop/bash-completion"
EGIT_REPO_URI="https://github.com/scop/bash-completion"
-SRC_URI="https://bitbucket.org/mgorny/bashcomp2/downloads/${BASHCOMP_P}.tar.gz"
LICENSE="GPL-2+"
SLOT="0"
@@ -23,7 +21,7 @@ RDEPEND=">=app-shells/bash-4.3_p30-r1:0
sys-apps/miscfiles
!app-eselect/eselect-bashcomp
!!net-fs/mc"
-DEPEND="app-arch/xz-utils
+DEPEND="
test? (
${RDEPEND}
app-misc/dtach
@@ -79,13 +77,19 @@ pkg_setup() {
}
src_unpack() {
- git-r3_src_unpack
- default
+ git-r3_fetch https://github.com/mgorny/bashcomp2
+ git-r3_fetch
+
+ git-r3_checkout https://github.com/mgorny/bashcomp2 \
+ "${WORKDIR}"/bashcomp2
+ git-r3_checkout
}
src_prepare() {
- eapply "${WORKDIR}/${BASHCOMP_P}/${PN}"-2.1_p*.patch
eapply_user
+ # generate and apply patch
+ emake -C "${WORKDIR}"/bashcomp2 bash-completion-blacklist-support.patch
+ eapply "${WORKDIR}"/bashcomp2/bash-completion-blacklist-support.patch
eautoreconf
}
@@ -124,9 +128,7 @@ src_install() {
dodoc AUTHORS CHANGES CONTRIBUTING.md README.md
# install the eselect module
- insinto /usr/share/eselect/modules
- doins "${WORKDIR}/${BASHCOMP_P}/bashcomp.eselect"
- doman "${WORKDIR}/${BASHCOMP_P}/bashcomp.eselect.5"
+ emake -C "${WORKDIR}"/bashcomp2 DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
}
pkg_postinst() {