summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2022-06-17 16:30:24 -0700
committerSam James <sam@gentoo.org>2022-06-18 00:44:54 +0100
commitc560e10dafb0b60bc0a7a8cf2619e6c634aee2ee (patch)
tree6c367f0c3e7bcf0806d888e3b1b01e77172526fb /app-text/dictd
parentnet-fs/nfs4-acl-tools: strip patch; add new revision (diff)
downloadgentoo-c560e10dafb0b60bc0a7a8cf2619e6c634aee2ee.tar.gz
gentoo-c560e10dafb0b60bc0a7a8cf2619e6c634aee2ee.tar.bz2
gentoo-c560e10dafb0b60bc0a7a8cf2619e6c634aee2ee.zip
app-text/dictd: Fix the build with rlibtool
The configure.in lacks LT_INIT which generates libtool and allows the build to work with rlibtool which depends on this file to determine if it should build shared or static libraries. Closes: https://bugs.gentoo.org/818535 Signed-off-by: orbea <orbea@riseup.net> Closes: https://github.com/gentoo/gentoo/pull/25948 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text/dictd')
-rw-r--r--app-text/dictd/dictd-1.13.0-r4.ebuild123
-rw-r--r--app-text/dictd/files/dictd-1.13.0-libtool.patch56
2 files changed, 179 insertions, 0 deletions
diff --git a/app-text/dictd/dictd-1.13.0-r4.ebuild b/app-text/dictd/dictd-1.13.0-r4.ebuild
new file mode 100644
index 000000000000..a8aafc51843e
--- /dev/null
+++ b/app-text/dictd/dictd-1.13.0-r4.ebuild
@@ -0,0 +1,123 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools readme.gentoo-r1 systemd
+
+DESCRIPTION="Dictionary Client/Server for the DICT protocol"
+HOMEPAGE="http://www.dict.org/ https://sourceforge.net/projects/dict/"
+SRC_URI="mirror://sourceforge/dict/${P}.tar.gz"
+
+LICENSE="GPL-1+ GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris"
+IUSE="dbi judy minimal test"
+RESTRICT="!test? ( test )"
+
+# <gawk-3.1.6 makes tests fail.
+RDEPEND="
+ acct-group/dictd
+ acct-user/dictd
+ >=sys-apps/coreutils-6.10
+ dev-libs/libmaa
+ sys-libs/zlib
+ dbi? ( dev-db/libdbi )
+ judy? ( dev-libs/judy )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ >=sys-apps/gawk-3.1.6
+ sys-devel/flex
+ virtual/yacc
+ test? ( !~sys-apps/gawk-4.2.1 )
+"
+
+DOC_CONTENTS="
+ To start and use ${PN} you need to emerge at least one dictionary from
+ the app-dicts category with the package name starting with 'dictd-'.
+ To install all available dictionaries, emerge app-dicts/dictd-dicts.
+ ${PN} will NOT start without at least one dictionary.\n
+ \nIf you are running systemd, you will need to review the instructions
+ explained in /etc/dict/dictd.conf comments.
+"
+
+PATCHES=(
+ "${FILESDIR}"/dictd-1.10.11-colorit-nopp-fix.patch
+ "${FILESDIR}"/dictd-1.12.0-build.patch
+ "${FILESDIR}"/dictd-1.13.0-libtool.patch # 818535
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with dbi plugin-dbi) \
+ $(use_with judy plugin-judy) \
+ --libexecdir="${EPREFIX}"/usr/$(get_libdir)/${PN} \
+ --sysconfdir="${EPREFIX}"/etc/dict
+}
+
+src_compile() {
+ if use minimal; then
+ emake dictfmt dictzip dictzip
+ else
+ emake
+ fi
+}
+
+src_test() {
+ use minimal && return 0 # All tests are for dictd which we don't build...
+ if [[ ${EUID} -eq 0 ]]; then
+ # If dictd is run as root user (-userpriv) it drops its privileges to
+ # dictd user and group. Give dictd group write access to test directory.
+ chown :dictd "${WORKDIR}" "${S}/test" || die
+ chmod 770 "${WORKDIR}" "${S}/test" || die
+ fi
+ emake test
+}
+
+src_install() {
+ if use minimal; then
+ emake DESTDIR="${ED}" install.dictzip install.dict install.dictfmt
+ else
+ default
+
+ # Don't install rfc2229.txt because it is non-free
+ dodoc doc/{dicf.ms,rfc.ms,rfc.sh}
+ dodoc doc/{security.doc,toc.ms}
+ dodoc -r examples
+
+ # conf files. For dict.conf see below.
+ insinto /etc/dict
+ for f in dictd.conf site.info colorit.conf; do
+ doins "${FILESDIR}/1.10.11/${f}"
+ done
+
+ # startups for dictd
+ newinitd "${FILESDIR}/1.10.11/dictd.initd" dictd
+ newconfd "${FILESDIR}/1.10.11/dictd.confd" dictd
+ systemd_dounit "${FILESDIR}"/${PN}.service
+ fi
+
+ find "${ED}" -name '*.la' -o -name '*.a' -delete || die
+
+ insinto /etc/dict
+ doins "${FILESDIR}"/1.10.11/dict.conf
+
+ dodoc ANNOUNCE NEWS README TODO
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ if has_version sys-apps/systemd; then
+ ewarn "The default location for dicts has changed! If you've modified your"
+ ewarn "systemd units locally to point into /usr/lib/dict, please update it"
+ ewarn "to point at /usr/share/dict now."
+ fi
+}
diff --git a/app-text/dictd/files/dictd-1.13.0-libtool.patch b/app-text/dictd/files/dictd-1.13.0-libtool.patch
new file mode 100644
index 000000000000..808e72163c37
--- /dev/null
+++ b/app-text/dictd/files/dictd-1.13.0-libtool.patch
@@ -0,0 +1,56 @@
+https://bugs.gentoo.org/818535
+
+From ab4c1542d8103ef2a8dcfd8cc1ad624890258090 Mon Sep 17 00:00:00 2001
+From: orbea <orbea@riseup.net>
+Date: Fri, 17 Jun 2022 16:18:40 -0700
+Subject: [PATCH] configure: Add missing LT_INIT
+
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -28,6 +28,7 @@ endif
+
+ .SUFFIXES:
+
++top_builddir= @top_builddir@
+ srcdir= @srcdir@
+ VPATH= @srcdir@:.
+ prefix= @prefix@
+--- a/configure.in
++++ b/configure.in
+@@ -35,6 +35,8 @@ AC_INIT([dict],[VERSION],[dict-beta@dict.org])
+ AC_CONFIG_SRCDIR([dictd.c])
+ AC_CONFIG_HEADER(config.h)
+
++LT_INIT
++
+ echo Configuring for dict
+ echo .
+
+@@ -45,7 +47,7 @@ AC_CANONICAL_HOST
+ AC_PROG_CC
+ AC_PROG_CPP
+ AC_PROG_CXX
+-
++AC_PROG_LIBTOOL
+ AC_ISC_POSIX
+
+ REALCC="$CC"
+@@ -75,8 +77,6 @@ AC_PROG_MAKE_SET
+ AC_PROG_YACC
+ AC_PROG_LEX
+
+-AC_CHECK_PROG(LIBTOOL,libtool,libtool)
+-
+ AC_CHECK_PROGS(NROFF,gnroff nroff)
+ AC_CHECK_PROGS(TROFF,groff troff)
+ AC_CHECK_PROGS(COL,col cat)
+--- a/doc/Makefile.in
++++ b/doc/Makefile.in
+@@ -28,6 +28,7 @@ endif
+
+ .SUFFIXES:
+
++top_builddir= @top_builddir@
+ srcdir= @srcdir@
+ VPATH= @srcdir@
+ prefix= @prefix@