summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2017-12-16 13:09:04 +0700
committerAndrey Grozin <grozin@gentoo.org>2017-12-16 13:11:49 +0700
commitedf8dc3fa3ab3017761b41bf81ffc18b42581300 (patch)
tree8e0b73276aec05a95151018a3020e5cefcbc7bba /app-text/doconce/doconce-1.4.4.ebuild
parentmedia-radio/xwxapt: Version bump (diff)
downloadgentoo-edf8dc3fa3ab3017761b41bf81ffc18b42581300.tar.gz
gentoo-edf8dc3fa3ab3017761b41bf81ffc18b42581300.tar.bz2
gentoo-edf8dc3fa3ab3017761b41bf81ffc18b42581300.zip
app-text/doconce: bump to 1.4.4, USE flag doc added
Package-Manager: Portage-2.3.18, Repoman-2.3.6
Diffstat (limited to 'app-text/doconce/doconce-1.4.4.ebuild')
-rw-r--r--app-text/doconce/doconce-1.4.4.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-text/doconce/doconce-1.4.4.ebuild b/app-text/doconce/doconce-1.4.4.ebuild
new file mode 100644
index 000000000000..5028993da166
--- /dev/null
+++ b/app-text/doconce/doconce-1.4.4.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{5,6} )
+inherit distutils-r1
+
+DESCRIPTION="A markdown-like langauge to generate docs in html, LaTeX, and many other formats"
+HOMEPAGE="https://github.com/hplgit/doconce/ https://pypi.python.org/pypi/Doconce/"
+SRC_URI="https://dev.gentoo.org/~grozin/${P}.tar.bz2"
+LICENSE="BSD"
+SLOT="0"
+IUSE="doc"
+KEYWORDS="~amd64 ~x86"
+RDEPEND="dev-python/future[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+src_install() {
+ default
+ if use doc; then
+ sed -e "s|http://hplgit.github.io/doconce/doc|file:///usr/share/doc/${PF}|g" -i doc/web/index.html
+ docompress -x /usr/share/doc
+ dodoc -r doc/web doc/pub
+ fi
+}