summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/groonga
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/groonga')
-rw-r--r--app-text/groonga/Manifest2
-rw-r--r--app-text/groonga/files/groonga.confd9
-rw-r--r--app-text/groonga/files/groonga.initd21
-rw-r--r--app-text/groonga/groonga-4.0.7-r1.ebuild91
-rw-r--r--app-text/groonga/groonga-5.0.3.ebuild92
-rw-r--r--app-text/groonga/metadata.xml23
6 files changed, 238 insertions, 0 deletions
diff --git a/app-text/groonga/Manifest b/app-text/groonga/Manifest
new file mode 100644
index 000000000000..d2f9b0763790
--- /dev/null
+++ b/app-text/groonga/Manifest
@@ -0,0 +1,2 @@
+DIST groonga-4.0.7.tar.gz 10990151 SHA256 ec1d19b05c7a592a316e845ff4c5549c6236cc7ea83423c0fc7831c16161bbbf SHA512 942c28205ffb2c7d3ba767ff68b342ef5b7b9fef72131782635e86682c82a4ea3dad9d5263a42563ded22db573015c9859e49dc20c812f7a6534478b22d8b9a8 WHIRLPOOL 2473c14bcc50c87bfb925e73cc3c4cd2c02915ac498a5e40aeee312ac9873857406e38e8146fabe722250f2d258b6444813d4c47726c16ce4cfceea35f207d3a
+DIST groonga-5.0.3.tar.gz 12421501 SHA256 d4f3e9d00cb16c0028cb32422fa666cbbfb32f47597988fd308931274d94cf52 SHA512 c4595054f46e150b0b95b3d1fb6a18098c93471ee0cdeefc54d266a710db57d6b68a6aceb1a61ede5ebb4e1b5518be64b9b96809bd85634b61c84c1923cbf158 WHIRLPOOL bbcf91770eb626dfaf5d01e04b6f4b2f4ee6fff8fad73cdca36c500560ce8d0b9dc606391b1ae0a23d2fd763ba4eddbc69f2eb8b692a5c3c59c1b21745d01de0
diff --git a/app-text/groonga/files/groonga.confd b/app-text/groonga/files/groonga.confd
new file mode 100644
index 000000000000..0e1bc318144e
--- /dev/null
+++ b/app-text/groonga/files/groonga.confd
@@ -0,0 +1,9 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+#GROONGA_USER=groonga
+#GROONGA_GROUP=groonga
+#GROONGA_PID=/run/groonga/groonga.pid
+#CONFIG_FILE=/etc/groonga/groonga.conf
+DATABASE=/var/lib/groonga/db
diff --git a/app-text/groonga/files/groonga.initd b/app-text/groonga/files/groonga.initd
new file mode 100644
index 000000000000..758d89a4d3f5
--- /dev/null
+++ b/app-text/groonga/files/groonga.initd
@@ -0,0 +1,21 @@
+#!/sbin/runscript
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+command=/usr/bin/groonga
+command_args="-d --pid-path ${GROONGA_PID:-/run/groonga/groonga.pid} --config-path=${CONFIG_FILE:-/etc/groonga/groonga.conf} ${DATABASE}"
+pidfile="${GROONGA_PID:-/run/groonga/groonga.pid}"
+start_stop_daemon_args="--quiet --user ${GROONGA_USER:-groonga}:${GROONGA_GROUP:-groonga}"
+
+depend() {
+ use net
+}
+
+start_pre() {
+ checkpath -d /run/groonga -o ${GROONGA_USER:-groonga}:${GROONGA_GROUP:-groonga}
+ if [ ! -e "${DATABASE}" ] ; then
+ einfo "Creating database ${DATABASE}"
+ su -s /bin/sh -c "/usr/bin/groonga -n ${DATABASE} quit" ${GROONGA_USER:-groonga}
+ fi
+}
diff --git a/app-text/groonga/groonga-4.0.7-r1.ebuild b/app-text/groonga/groonga-4.0.7-r1.ebuild
new file mode 100644
index 000000000000..cf9cba12ad44
--- /dev/null
+++ b/app-text/groonga/groonga-4.0.7-r1.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils libtool user
+
+DESCRIPTION="An Embeddable Fulltext Search Engine"
+HOMEPAGE="http://groonga.org/"
+SRC_URI="http://packages.groonga.org/source/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="abort benchmark debug doc dynamic-malloc-change +exact-alloc-count examples fmalloc futex libedit libevent lzo mecab msgpack +nfkc ruby sphinx static-libs uyield zeromq zlib"
+
+RDEPEND="benchmark? ( >=dev-libs/glib-2.8 )
+ libedit? ( >=dev-libs/libedit-3 )
+ libevent? ( dev-libs/libevent )
+ lzo? ( dev-libs/lzo )
+ mecab? ( >=app-text/mecab-0.80 )
+ msgpack? ( dev-libs/msgpack )
+ ruby? ( dev-lang/ruby )
+ sphinx? ( >=dev-python/sphinx-1.0.1 )
+ zeromq? ( net-libs/zeromq )
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ sphinx? ( dev-python/sphinx )"
+
+REQUIRED_USE=" abort? ( dynamic-malloc-change ) fmalloc? ( dynamic-malloc-change ) sphinx? ( doc )"
+
+pkg_setup() {
+ enewgroup groonga
+ enewuser groonga -1 -1 -1 groonga
+}
+
+src_prepare() {
+ elibtoolize
+}
+
+src_configure() {
+ # httpd is a bundled copy of nginx; disabled for security reasons
+ # prce only is used with httpd
+ # kytea and libstemmer are not available in portage
+ econf \
+ --disable-groonga-httpd \
+ --without-pcre \
+ --without-kytea \
+ --without-libstemmer \
+ --with-log-path="${EROOT}var/log/${PN}.log" \
+ --docdir="${EROOT}usr/share/doc/${P}" \
+ $(use_enable abort) \
+ $(use_enable benchmark) \
+ $(use_enable debug memory-debug) \
+ $(use_enable doc document) \
+ $(use_enable dynamic-malloc-change) \
+ $(use_enable exact-alloc-count) \
+ $(use_enable fmalloc) \
+ $(use_enable futex) \
+ $(use_enable libedit) \
+ $(use_with libevent) \
+ $(use_with lzo) \
+ $(use_with mecab) \
+ $(use_with msgpack message-pack "${EROOT}usr") \
+ $(use_enable nfkc) \
+ $(use_with ruby) \
+ $(use_with sphinx sphinx-build) \
+ $(use_enable static-libs static) \
+ $(use_enable uyield) \
+ $(use_enable zeromq) \
+ $(use_with zlib)
+}
+
+src_install() {
+ default
+
+ prune_libtool_files
+
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+
+ keepdir /var/{log,lib}/${PN}
+ fowners groonga:groonga /var/{log,lib}/${PN}
+
+ dodoc README.md
+
+ use examples || rm -r "${D}usr/share/${PN}" || die
+ # Extra init script
+ rm -r "${D}usr/sbin/groonga-httpd-restart" || die
+}
diff --git a/app-text/groonga/groonga-5.0.3.ebuild b/app-text/groonga/groonga-5.0.3.ebuild
new file mode 100644
index 000000000000..494462be877a
--- /dev/null
+++ b/app-text/groonga/groonga-5.0.3.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils libtool user
+
+DESCRIPTION="An Embeddable Fulltext Search Engine"
+HOMEPAGE="http://groonga.org/"
+SRC_URI="http://packages.groonga.org/source/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="abort benchmark debug doc dynamic-malloc-change +exact-alloc-count examples fmalloc futex libedit libevent lzo mecab msgpack +nfkc sphinx static-libs uyield zeromq zlib"
+
+RDEPEND="benchmark? ( >=dev-libs/glib-2.8 )
+ libedit? ( >=dev-libs/libedit-3 )
+ libevent? ( dev-libs/libevent )
+ lzo? ( dev-libs/lzo )
+ mecab? ( >=app-text/mecab-0.80 )
+ msgpack? ( dev-libs/msgpack )
+ sphinx? ( >=dev-python/sphinx-1.0.1 )
+ zeromq? ( net-libs/zeromq )
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ sphinx? ( dev-python/sphinx )"
+
+REQUIRED_USE=" abort? ( dynamic-malloc-change ) fmalloc? ( dynamic-malloc-change ) sphinx? ( doc )"
+
+pkg_setup() {
+ enewgroup groonga
+ enewuser groonga -1 -1 -1 groonga
+}
+
+src_prepare() {
+ elibtoolize
+}
+
+src_configure() {
+ # httpd is a bundled copy of nginx; disabled for security reasons
+ # prce only is used with httpd
+ # kytea and libstemmer are not available in portage
+ # ruby is only used for an http test
+ econf \
+ --disable-groonga-httpd \
+ --without-pcre \
+ --without-kytea \
+ --without-libstemmer \
+ --with-log-path="${EROOT}var/log/${PN}.log" \
+ --docdir="${EROOT}usr/share/doc/${P}" \
+ --without-ruby \
+ $(use_enable abort) \
+ $(use_enable benchmark) \
+ $(use_enable debug memory-debug) \
+ $(use_enable doc document) \
+ $(use_enable dynamic-malloc-change) \
+ $(use_enable exact-alloc-count) \
+ $(use_enable fmalloc) \
+ $(use_enable futex) \
+ $(use_enable libedit) \
+ $(use_with libevent) \
+ $(use_with lzo) \
+ $(use_with mecab) \
+ $(use_with msgpack message-pack "${EROOT}usr") \
+ $(use_enable nfkc) \
+ $(use_with sphinx sphinx-build) \
+ $(use_enable static-libs static) \
+ $(use_enable uyield) \
+ $(use_enable zeromq) \
+ $(use_with zlib)
+}
+
+src_install() {
+ default
+
+ prune_libtool_files
+
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+
+ keepdir /var/{log,lib}/${PN}
+ fowners groonga:groonga /var/{log,lib}/${PN}
+
+ dodoc README.md
+
+ use examples || rm -r "${D}usr/share/${PN}" || die
+ # Extra init script
+ rm -r "${D}usr/sbin/groonga-httpd-restart" || die
+}
diff --git a/app-text/groonga/metadata.xml b/app-text/groonga/metadata.xml
new file mode 100644
index 000000000000..606f8d933015
--- /dev/null
+++ b/app-text/groonga/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>grknight@gentoo.org</email>
+</maintainer>
+<use>
+ <flag name="abort">Enable query abortion</flag>
+ <flag name="benchmark">Build benchmark programs</flag>
+ <flag name="dynamic-malloc-change">Allow dynamic memory allocation change for testing</flag>
+ <flag name="exact-alloc-count">Atomic counting for memory alloc count</flag>
+ <flag name="fmalloc">Make memory allocation failed in specified condition for debug</flag>
+ <flag name="futex">Use futex</flag>
+ <flag name="libevent">Enable <pkg>dev-libs/libevent</pkg> used for suggestion</flag>
+ <flag name="mecab">Use <pkg>app-text/mecab</pkg> for morphological analysis</flag>
+ <flag name="msgpack">Enable <pkg>dev-libs/msgpack</pkg> used for suggestion</flag>
+ <flag name="nfkc">Use nfkc based utf8 normalization</flag>
+ <flag name="sphinx">Enable document generation by <pkg>app-misc/sphinx</pkg></flag>
+ <flag name="uyield">Build for detecting race conditions</flag>
+ <flag name="zeromq">Enable <pkg>net-libs/zeromq</pkg> used for suggestion</flag>
+</use>
+</pkgmetadata>
+