summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2015-12-13 23:03:34 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2015-12-13 23:10:22 +0100
commit525eeb606d9028dafede361f696ea599fb6ccdc6 (patch)
tree58bd8ce8edf90ed463e44b0d856015e1111b51c3 /app-text/gspell/gspell-0.2.2.ebuild
parentnet-misc/rygel: version bump to 0.28.2 (diff)
downloadgentoo-525eeb606d9028dafede361f696ea599fb6ccdc6.tar.gz
gentoo-525eeb606d9028dafede361f696ea599fb6ccdc6.tar.bz2
gentoo-525eeb606d9028dafede361f696ea599fb6ccdc6.zip
app-text/gspell: version bump to 0.2.2, fix introspection and vala USE flags dependencies
Package-Manager: portage-2.2.26
Diffstat (limited to 'app-text/gspell/gspell-0.2.2.ebuild')
-rw-r--r--app-text/gspell/gspell-0.2.2.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-text/gspell/gspell-0.2.2.ebuild b/app-text/gspell/gspell-0.2.2.ebuild
new file mode 100644
index 000000000000..ed0e226d5314
--- /dev/null
+++ b/app-text/gspell/gspell-0.2.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2 vala
+
+DESCRIPTION="Spell check library for GTK+ applications"
+HOMEPAGE="https://wiki.gnome.org/Projects/gspell"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+introspection vala"
+REQUIRED_IUSE="vala? ( introspection )"
+
+RDEPEND="
+ >=app-text/enchant-1.6.0
+ >=app-text/iso-codes-0.35
+ >=dev-libs/glib-2.44:2
+ >=x11-libs/gtk+-3.16:3[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-1.42.0:= )
+ vala? ( $(vala_depend) )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.24
+ >=dev-util/intltool-0.35.0
+ >=sys-devel/gettext-0.19.4
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable introspection) \
+ $(use_enable vala)
+}