summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-24 07:46:53 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-24 09:06:50 +0200
commit49a78a63650867e625607e4360bc2f2d8dd10cfd (patch)
tree0c402fd8ce155cd9b806bd30c414877b94226c51 /app-text/htmlmin/htmlmin-0.1.12.ebuild
parentapp-text/htmlmin: Fix src_prepare() (diff)
downloadgentoo-49a78a63650867e625607e4360bc2f2d8dd10cfd.tar.gz
gentoo-49a78a63650867e625607e4360bc2f2d8dd10cfd.tar.bz2
gentoo-49a78a63650867e625607e4360bc2f2d8dd10cfd.zip
app-text/htmlmin: Enable tests
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-text/htmlmin/htmlmin-0.1.12.ebuild')
-rw-r--r--app-text/htmlmin/htmlmin-0.1.12.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/app-text/htmlmin/htmlmin-0.1.12.ebuild b/app-text/htmlmin/htmlmin-0.1.12.ebuild
index a2c7d0741a07..8a3fcf08008f 100644
--- a/app-text/htmlmin/htmlmin-0.1.12.ebuild
+++ b/app-text/htmlmin/htmlmin-0.1.12.ebuild
@@ -8,14 +8,20 @@ PYTHON_COMPAT=( python3_{6,7,8} )
inherit distutils-r1
+# upstream doesn't do tags much
+EGIT_COMMIT=220b1d16442eb4b6fafed338ee3b61f698a01e63
DESCRIPTION="A configurable HTML Minifier with safety features"
HOMEPAGE="https://github.com/mankyd/htmlmin"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="
+ https://github.com/mankyd/htmlmin/archive/${EGIT_COMMIT}.tar.gz
+ -> ${P}.gh.tar.gz"
+S=${WORKDIR}/${PN}-${EGIT_COMMIT}
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE=""
+
+distutils_enable_tests setup.py
src_prepare() {
sed '/prune/d' -i MANIFEST.in || die