summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-03-21 22:07:13 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-03-21 22:07:13 +0100
commit04cbe2d1566f4dc0bbab471abbedc5071dbacbf8 (patch)
tree5bd7b9b3582190d59537a86162ecaa5a66235be3 /app-text/lcdf-typetools
parentapp-text/lcdf-typetools: EAPI 7 (diff)
downloadgentoo-04cbe2d1566f4dc0bbab471abbedc5071dbacbf8.tar.gz
gentoo-04cbe2d1566f4dc0bbab471abbedc5071dbacbf8.tar.bz2
gentoo-04cbe2d1566f4dc0bbab471abbedc5071dbacbf8.zip
app-text/lcdf-typetools: Avoid unnecessary revbump
Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-text/lcdf-typetools')
-rw-r--r--app-text/lcdf-typetools/lcdf-typetools-2.108-r1.ebuild29
-rw-r--r--app-text/lcdf-typetools/lcdf-typetools-2.108.ebuild17
2 files changed, 9 insertions, 37 deletions
diff --git a/app-text/lcdf-typetools/lcdf-typetools-2.108-r1.ebuild b/app-text/lcdf-typetools/lcdf-typetools-2.108-r1.ebuild
deleted file mode 100644
index f0df24089ef2..000000000000
--- a/app-text/lcdf-typetools/lcdf-typetools-2.108-r1.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit toolchain-funcs flag-o-matic
-
-DESCRIPTION="Font utilities for eg manipulating OTF"
-HOMEPAGE="https://lcdf.org/type/#typetools"
-SRC_URI="https://lcdf.org/type/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE="+kpathsea"
-
-RDEPEND="kpathsea? ( virtual/tex-base dev-libs/kpathsea )"
-DEPEND="${RDEPEND}"
-BDEPEND="virtual/pkgconfig"
-
-src_configure() {
- use kpathsea && has_version 'dev-libs/kpathsea' && append-cppflags "$($(tc-getPKG_CONFIG) --cflags kpathsea)"
- econf $(use_with kpathsea)
-}
-
-src_install() {
- emake DESTDIR="${D}" install
- dodoc NEWS.md README.md ONEWS
-}
diff --git a/app-text/lcdf-typetools/lcdf-typetools-2.108.ebuild b/app-text/lcdf-typetools/lcdf-typetools-2.108.ebuild
index ea6d68087c1a..f0df24089ef2 100644
--- a/app-text/lcdf-typetools/lcdf-typetools-2.108.ebuild
+++ b/app-text/lcdf-typetools/lcdf-typetools-2.108.ebuild
@@ -1,24 +1,25 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
inherit toolchain-funcs flag-o-matic
DESCRIPTION="Font utilities for eg manipulating OTF"
-SRC_URI="http://www.lcdf.org/type/${P}.tar.gz"
-HOMEPAGE="http://www.lcdf.org/type/#typetools"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-SLOT="0"
+HOMEPAGE="https://lcdf.org/type/#typetools"
+SRC_URI="https://lcdf.org/type/${P}.tar.gz"
+
LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
IUSE="+kpathsea"
RDEPEND="kpathsea? ( virtual/tex-base dev-libs/kpathsea )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
src_configure() {
- use kpathsea && has_version '>=dev-libs/kpathsea-6.2.1' && append-cppflags "$($(tc-getPKG_CONFIG) --cflags kpathsea)"
+ use kpathsea && has_version 'dev-libs/kpathsea' && append-cppflags "$($(tc-getPKG_CONFIG) --cflags kpathsea)"
econf $(use_with kpathsea)
}