summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2024-10-31 19:18:52 +0100
committerFlorian Schmaus <flow@gentoo.org>2024-10-31 19:39:10 +0100
commit3d84a921110e1e59c7b6fe34c55b225b212e4482 (patch)
treebc9c92a171e4b794dae1adf02b321d38fbf56045 /app-text/xml2rfc/xml2rfc-3.24.0.ebuild
parentapp-emulation/qtrvsim: drop 0.9.7 (diff)
downloadgentoo-3d84a921110e1e59c7b6fe34c55b225b212e4482.tar.gz
gentoo-3d84a921110e1e59c7b6fe34c55b225b212e4482.tar.bz2
gentoo-3d84a921110e1e59c7b6fe34c55b225b212e4482.zip
app-text/xml2rfc: add 3.24.0
Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'app-text/xml2rfc/xml2rfc-3.24.0.ebuild')
-rw-r--r--app-text/xml2rfc/xml2rfc-3.24.0.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/app-text/xml2rfc/xml2rfc-3.24.0.ebuild b/app-text/xml2rfc/xml2rfc-3.24.0.ebuild
new file mode 100644
index 000000000000..63b878ca5350
--- /dev/null
+++ b/app-text/xml2rfc/xml2rfc-3.24.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Generates RFCs and IETF drafts from document source in XML"
+HOMEPAGE="
+ https://ietf-tools.github.io/xml2rfc/
+ https://github.com/ietf-tools/xml2rfc/
+ https://pypi.org/project/xml2rfc/
+"
+SRC_URI="
+ https://github.com/ietf-tools/xml2rfc/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/platformdirs-3.6.0[${PYTHON_USEDEP}]
+ dev-python/ConfigArgParse[${PYTHON_USEDEP}]
+ dev-python/intervaltree[${PYTHON_USEDEP}]
+ >=dev-python/google-i18n-address-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/html5lib-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/jinja-3.1.2[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ >=dev-python/markupsafe-2.1.1[${PYTHON_USEDEP}]
+ dev-python/pycountry[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.3.1[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/pypdf-3.2.1[${PYTHON_USEDEP}]
+ dev-python/decorator[${PYTHON_USEDEP}]
+ dev-python/dict2xml[${PYTHON_USEDEP}]
+ dev-python/weasyprint[${PYTHON_USEDEP}]
+ media-fonts/noto[cjk]
+ )
+"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ default
+ # Disable broken PdfWriterTests.
+ sed -i 's/ PdfWriterTests(unittest.TestCase):/ PdfWriterTests:/' test.py || die
+}