summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-12-07 02:43:27 +0000
committerSam James <sam@gentoo.org>2021-12-07 02:45:03 +0000
commit4d119351be58d01b2ccb9a3a012e7034ebb24176 (patch)
tree95c970aa2838add451f9f03d2f915bbaae2c0d92 /app-vim/bash-support/bash-support-4.3.ebuild
parentapp-vim/lustyexplorer: add 5.0 (diff)
downloadgentoo-4d119351be58d01b2ccb9a3a012e7034ebb24176.tar.gz
gentoo-4d119351be58d01b2ccb9a3a012e7034ebb24176.tar.bz2
gentoo-4d119351be58d01b2ccb9a3a012e7034ebb24176.zip
app-vim/bash-support: add 4.3
Going through some app-vim/* bump bugs given upstream seem to be deprecating and removing some old functionality, this is needed to keep things working. Closes: https://bugs.gentoo.org/808769 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-vim/bash-support/bash-support-4.3.ebuild')
-rw-r--r--app-vim/bash-support/bash-support-4.3.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-vim/bash-support/bash-support-4.3.ebuild b/app-vim/bash-support/bash-support-4.3.ebuild
new file mode 100644
index 000000000000..6de7fb8f0321
--- /dev/null
+++ b/app-vim/bash-support/bash-support-4.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: write and run bash scripts using menus and hotkeys"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=365"
+SRC_URI="https://www.vim.org/scripts/download_script.php?src_id=24452 -> ${P}.zip"
+S="${WORKDIR}"/${PN}
+
+LICENSE="public-domain"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="app-arch/unzip"
+
+VIM_PLUGIN_HELPFILES="${PN}"
+
+src_install() {
+ dodoc doc/{ChangeLog,bash-hotkeys.pdf}
+ rm -rf ${PN}/doc || die
+
+ vim-plugin_src_install
+}