summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-04-20 23:02:45 +0200
committerMichał Górny <mgorny@gentoo.org>2017-05-27 17:19:18 +0200
commit07a7ab8f70eaeb469214e9189ec0c0b0a1c51195 (patch)
tree48d027c6e1954b4f7db00063e09259ba88a18fe1 /app-vim/pyclewn/pyclewn-2.1-r1.ebuild
parentapp-vim/editorconfig-vim: Convert to python-single-r1, #615832 (diff)
downloadgentoo-07a7ab8f70eaeb469214e9189ec0c0b0a1c51195.tar.gz
gentoo-07a7ab8f70eaeb469214e9189ec0c0b0a1c51195.tar.bz2
gentoo-07a7ab8f70eaeb469214e9189ec0c0b0a1c51195.zip
app-vim/pyclewn: Drop unnecessary PYTHON_USEDEP on *vim
Diffstat (limited to 'app-vim/pyclewn/pyclewn-2.1-r1.ebuild')
-rw-r--r--app-vim/pyclewn/pyclewn-2.1-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/app-vim/pyclewn/pyclewn-2.1-r1.ebuild b/app-vim/pyclewn/pyclewn-2.1-r1.ebuild
new file mode 100644
index 000000000000..f21226086046
--- /dev/null
+++ b/app-vim/pyclewn/pyclewn-2.1-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+inherit eutils vim-plugin distutils-r1
+
+SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
+
+DESCRIPTION="Pyclewn allows using vim as a front end to a debugger (pdb or gdb)"
+HOMEPAGE="http://pyclewn.sourceforge.net/"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+
+CDEPEND="|| (
+ >=app-editors/vim-7.3
+ >=app-editors/gvim-7.3[netbeans]
+)"
+DEPEND="${CDEPEND}
+ app-arch/vimball
+"
+RDEPEND="${DEPEND}
+ $(python_gen_cond_dep \
+ 'dev-python/trollius[${PYTHON_USEDEP}]' python{2_7,3_3})
+"
+
+SLOT="0"
+
+#Completely broken (runs vim), disable for now
+#python_test() {
+# esetup.py test
+#}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ vimball -x -C "${ED}"/usr/share/vim/vimfiles lib/clewn/runtime/${P}.vmb || die "Extracting vimball failed"
+}
+
+pkg_postinst() {
+ vim-plugin_pkg_postinst
+
+ optfeature "C/C++ debugging" sys-devel/gdb
+ optfeature "Python debugging" dev-python/pdb-clone
+}