summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-03-26 22:55:01 +0000
committerSam James <sam@gentoo.org>2024-03-26 23:03:13 +0000
commit1c76376ce6ddd5fa26c30de8de00afd775b013f1 (patch)
treed14c076b4957ebfc0b984f59029660e2ffdeed9c /dev-build
parentdev-qt/qtbase: do build workaround for gcc:14 + avx512fp16 (diff)
downloadgentoo-1c76376ce6ddd5fa26c30de8de00afd775b013f1.tar.gz
gentoo-1c76376ce6ddd5fa26c30de8de00afd775b013f1.tar.bz2
gentoo-1c76376ce6ddd5fa26c30de8de00afd775b013f1.zip
dev-build/libtool: don't hardcode path to grep & friends
Closes: https://bugs.gentoo.org/927837 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-build')
-rw-r--r--dev-build/libtool/libtool-2.4.7-r4.ebuild (renamed from dev-build/libtool/libtool-2.4.7-r3.ebuild)8
-rw-r--r--dev-build/libtool/libtool-9999.ebuild8
2 files changed, 12 insertions, 4 deletions
diff --git a/dev-build/libtool/libtool-2.4.7-r3.ebuild b/dev-build/libtool/libtool-2.4.7-r4.ebuild
index 75bdf19f6d2a..d165475452d8 100644
--- a/dev-build/libtool/libtool-2.4.7-r3.ebuild
+++ b/dev-build/libtool/libtool-2.4.7-r4.ebuild
@@ -98,11 +98,15 @@ src_configure() {
# to find a bash shell. if /bin/sh is bash, it uses that. this can
# cause problems for people who switch /bin/sh on the fly to other
# shells, so just force libtool to use /bin/bash all the time.
- export CONFIG_SHELL="${EPREFIX}"/bin/bash
-
# Do not bother hardcoding the full path to sed.
# Just rely on $PATH. bug #574550
+ export CONFIG_SHELL="${EPREFIX}"/bin/bash
export ac_cv_path_SED="$(basename "$(type -P sed)")"
+ export ac_cv_path_EGREP="$(basename "$(type -P grep)") -E"
+ export ac_cv_path_EGREP_TRADITIONAL="$(basename "$(type -P grep)") -E"
+ export ac_cv_path_FGREP="$(basename "$(type -P grep)") -F"
+ export ac_cv_path_GREP="$(basename "$(type -P grep)")"
+ export ac_cv_path_lt_DD="$(basename "$(type -P dd)")"
[[ ${CHOST} == *-darwin* ]] && local myconf="--program-prefix=g"
diff --git a/dev-build/libtool/libtool-9999.ebuild b/dev-build/libtool/libtool-9999.ebuild
index 033495d8ee02..f25c4861a85e 100644
--- a/dev-build/libtool/libtool-9999.ebuild
+++ b/dev-build/libtool/libtool-9999.ebuild
@@ -96,11 +96,15 @@ src_configure() {
# to find a bash shell. if /bin/sh is bash, it uses that. this can
# cause problems for people who switch /bin/sh on the fly to other
# shells, so just force libtool to use /bin/bash all the time.
- export CONFIG_SHELL="${EPREFIX}"/bin/bash
-
# Do not bother hardcoding the full path to sed.
# Just rely on $PATH. bug #574550
+ export CONFIG_SHELL="${EPREFIX}"/bin/bash
export ac_cv_path_SED="$(basename "$(type -P sed)")"
+ export ac_cv_path_EGREP="$(basename "$(type -P grep)") -E"
+ export ac_cv_path_EGREP_TRADITIONAL="$(basename "$(type -P grep)") -E"
+ export ac_cv_path_FGREP="$(basename "$(type -P grep)") -F"
+ export ac_cv_path_GREP="$(basename "$(type -P grep)")"
+ export ac_cv_path_lt_DD="$(basename "$(type -P dd)")"
[[ ${CHOST} == *-darwin* ]] && local myconf="--program-prefix=g"