summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2021-07-08 17:36:51 +0200
committerLuca Barbato <lu_zero@gentoo.org>2021-07-08 17:38:43 +0200
commit718d5386cbccda60bd6098d703dba204da632ff8 (patch)
tree7b65017712bfa4b3537e2c4c01946b53fb72ff6d /dev-cpp/ETL/ETL-1.4.1.ebuild
parentnet-im/ejabberd: Stabilize 21.04 amd64 x86, #801088 (diff)
downloadgentoo-718d5386cbccda60bd6098d703dba204da632ff8.tar.gz
gentoo-718d5386cbccda60bd6098d703dba204da632ff8.tar.bz2
gentoo-718d5386cbccda60bd6098d703dba204da632ff8.zip
dev-cpp/ETL: Version bump
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Luca Barbato <lu_zero@gentoo.org>
Diffstat (limited to 'dev-cpp/ETL/ETL-1.4.1.ebuild')
-rw-r--r--dev-cpp/ETL/ETL-1.4.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-cpp/ETL/ETL-1.4.1.ebuild b/dev-cpp/ETL/ETL-1.4.1.ebuild
new file mode 100644
index 000000000000..c78382ba10fb
--- /dev/null
+++ b/dev-cpp/ETL/ETL-1.4.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Multi-platform class and template library"
+HOMEPAGE="https://www.synfig.org"
+SRC_URI="https://github.com/synfig/synfig/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RDEPENDS=">=glibmm-2.24.2:2"
+DEPENDS="${RDEPENDS}"
+
+src_prepare() {
+ default
+ sed -i -e 's/CXXFLAGS="`echo $CXXFLAGS | sed s:-g::` $debug_flags"//' \
+ -e 's/CFLAGS="`echo $CFLAGS | sed s:-g::` $debug_flags"//' \
+ -e 's/-Werror//' \
+ m4/subs.m4 || die
+ sed -i -e 's/hermite<angle>/etl::&/' test/angle.cpp
+
+ eautoreconf
+}