summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-04-06 23:47:49 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-04-07 00:08:38 +0200
commitf3722acc63671b8733c7a5680d89b913f91b6402 (patch)
treef72d336c40d06300298a61904e3822f5df02485b /dev-cpp/libcmis/libcmis-9999.ebuild
parentx11-libs/libpciaccess: Version bump to 0.13.5 (diff)
downloadgentoo-f3722acc63671b8733c7a5680d89b913f91b6402.tar.gz
gentoo-f3722acc63671b8733c7a5680d89b913f91b6402.tar.bz2
gentoo-f3722acc63671b8733c7a5680d89b913f91b6402.zip
dev-cpp/libcmis: Fix gdrive 2FA again, restrict tests, use vcs-snapshot
Gentoo-bug: 577926 See also: https://bugs.documentfoundation.org/show_bug.cgi?id=98416 Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-cpp/libcmis/libcmis-9999.ebuild')
-rw-r--r--dev-cpp/libcmis/libcmis-9999.ebuild27
1 files changed, 15 insertions, 12 deletions
diff --git a/dev-cpp/libcmis/libcmis-9999.ebuild b/dev-cpp/libcmis/libcmis-9999.ebuild
index 4db743bf4429..603a0334c7de 100644
--- a/dev-cpp/libcmis/libcmis-9999.ebuild
+++ b/dev-cpp/libcmis/libcmis-9999.ebuild
@@ -1,23 +1,24 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-EGIT_REPO_URI="https://github.com/tdf/libcmis.git"
-[[ ${PV} == 9999 ]] && SCM_ECLASS="git-r3"
-inherit alternatives autotools ${SCM_ECLASS}
-unset SCM_ECLASS
-
-DESCRIPTION="C++ client library for the CMIS interface"
-HOMEPAGE="https://github.com/tdf/libcmis"
-if [[ ${PV} = *_pre* ]]; then
+if [[ ${PV} = 9999 ]]; then
+ EGIT_REPO_URI="https://github.com/tdf/libcmis.git"
+ SCM_ECLASS="git-r3"
+elif [[ ${PV} = *_pre* ]]; then
+ SCM_ECLASS="vcs-snapshot"
snapshot=d2054a12e3f52fff8e96341e8c48f0dcd75e2e2a
SRC_URI="https://github.com/tdf/${PN}/archive/${snapshot}.tar.gz -> ${P}.tar.gz"
- S="${WORKDIR}/${PN}-${snapshot}"
unset snapshot
-elif [[ ${PV} != 9999 ]] ; then
+else
SRC_URI="https://github.com/tdf/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
fi
+inherit alternatives autotools ${SCM_ECLASS}
+unset SCM_ECLASS
+
+DESCRIPTION="C++ client library for the CMIS interface"
+HOMEPAGE="https://github.com/tdf/libcmis"
LICENSE="|| ( GPL-2 LGPL-2 MPL-1.1 )"
SLOT="0.5"
@@ -26,7 +27,7 @@ SLOT="0.5"
[[ ${PV} == 9999 ]] || \
KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
-IUSE="static-libs man test"
+IUSE="man static-libs test"
COMMON_DEPEND="
dev-libs/boost:=
@@ -48,6 +49,8 @@ RDEPEND="${COMMON_DEPEND}
!<dev-cpp/libcmis-0.5.0
"
+RESTRICT="test"
+
src_prepare() {
default
[[ ${PV} = *_pre* || ${PV} = 9999 ]] && eautoreconf