summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2023-02-18 21:54:57 +0000
committerJames Le Cuirot <chewi@gentoo.org>2023-02-18 21:54:57 +0000
commitbbc74550e02b3fe214e0e9293d03fbf0cfd12560 (patch)
tree043fe37d608b1c624af9882b85d6026af7736d4f /dev-cpp/sdbus-c++
parentdev-ml/camlp5: add 8.00.05 (diff)
downloadgentoo-bbc74550e02b3fe214e0e9293d03fbf0cfd12560.tar.gz
gentoo-bbc74550e02b3fe214e0e9293d03fbf0cfd12560.tar.bz2
gentoo-bbc74550e02b3fe214e0e9293d03fbf0cfd12560.zip
dev-cpp/sdbus-c++: Really fix musl with __UAPI_DEF_ETHHDR
Closes: https://bugs.gentoo.org/895284 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'dev-cpp/sdbus-c++')
-rw-r--r--dev-cpp/sdbus-c++/sdbus-c++-0.9.0-r5.ebuild5
-rw-r--r--dev-cpp/sdbus-c++/sdbus-c++-1.2.0-r1.ebuild5
2 files changed, 8 insertions, 2 deletions
diff --git a/dev-cpp/sdbus-c++/sdbus-c++-0.9.0-r5.ebuild b/dev-cpp/sdbus-c++/sdbus-c++-0.9.0-r5.ebuild
index a51620da4851..4ad16b14b087 100644
--- a/dev-cpp/sdbus-c++/sdbus-c++-0.9.0-r5.ebuild
+++ b/dev-cpp/sdbus-c++/sdbus-c++-0.9.0-r5.ebuild
@@ -4,7 +4,7 @@
EAPI=8
PYTHON_COMPAT=( python3_{9..11} )
-inherit python-any-r1 meson cmake
+inherit python-any-r1 meson cmake flag-o-matic
SDP="systemd-stable-252.6"
MUSL_PATCHSET="systemd-musl-patches-252.4"
@@ -79,6 +79,9 @@ src_prepare() {
src_configure() {
if ! use systemd; then
+ # Avoid redefinition of struct ethhdr.
+ use elibc_musl && append-cppflags -D__UAPI_DEF_ETHHDR=0
+
EMESON_SOURCE=${SDS} \
BUILD_DIR=${SDB} \
meson_src_configure \
diff --git a/dev-cpp/sdbus-c++/sdbus-c++-1.2.0-r1.ebuild b/dev-cpp/sdbus-c++/sdbus-c++-1.2.0-r1.ebuild
index 14aec38d9337..56e8e1beb44e 100644
--- a/dev-cpp/sdbus-c++/sdbus-c++-1.2.0-r1.ebuild
+++ b/dev-cpp/sdbus-c++/sdbus-c++-1.2.0-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
PYTHON_COMPAT=( python3_{9..11} )
-inherit python-any-r1 meson cmake
+inherit python-any-r1 meson cmake flag-o-matic
SDP="systemd-stable-252.6"
MUSL_PATCHSET="systemd-musl-patches-252.4"
@@ -80,6 +80,9 @@ src_prepare() {
src_configure() {
if ! use systemd; then
+ # Avoid redefinition of struct ethhdr.
+ use elibc_musl && append-cppflags -D__UAPI_DEF_ETHHDR=0
+
EMESON_SOURCE=${SDS} \
BUILD_DIR=${SDB} \
meson_src_configure \