summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-01-16 06:45:33 +0000
committerSam James <sam@gentoo.org>2022-01-16 06:45:33 +0000
commitf3cd6cd18b7f54edfedbd0015b28ce20b4bbcba6 (patch)
treeb1745abbdc7c01e3a857648c70ff0224e5647f1c /dev-cpp/tbb
parentdev-util/byacc: drop 20211224, 20220101, 20220109 (diff)
downloadgentoo-f3cd6cd18b7f54edfedbd0015b28ce20b4bbcba6.tar.gz
gentoo-f3cd6cd18b7f54edfedbd0015b28ce20b4bbcba6.tar.bz2
gentoo-f3cd6cd18b7f54edfedbd0015b28ce20b4bbcba6.zip
dev-cpp/tbb: fix build on musl
Closes: https://bugs.gentoo.org/830698 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-cpp/tbb')
-rw-r--r--dev-cpp/tbb/files/tbb-2021.5.0-musl-deepbind.patch25
-rw-r--r--dev-cpp/tbb/tbb-2021.5.0.ebuild1
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-cpp/tbb/files/tbb-2021.5.0-musl-deepbind.patch b/dev-cpp/tbb/files/tbb-2021.5.0-musl-deepbind.patch
new file mode 100644
index 000000000000..014a3863f452
--- /dev/null
+++ b/dev-cpp/tbb/files/tbb-2021.5.0-musl-deepbind.patch
@@ -0,0 +1,25 @@
+https://github.com/oneapi-src/oneTBB/commit/883c2e5245c39624b3b5d6d56d5b203cf09eac38
+https://bugs.gentoo.org/830698
+
+From: Khem Raj <raj.khem@gmail.com>
+Date: Wed, 15 Dec 2021 08:08:07 -0800
+Subject: [PATCH] Musl/linux can not use RTLD_DEEPBIND (#684)
+
+Exclude non-glibc linux systems along with android
+Fixes
+src/tbb/dynamic_link.cpp:417:29: error: use
+ of undeclared identifier 'RTLD_DEEPBIND' | flags = flags | RTLD_DEEPBIND;
+| ^
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+--- a/src/tbb/dynamic_link.cpp
++++ b/src/tbb/dynamic_link.cpp
+@@ -413,7 +413,7 @@ namespace r1 {
+ int flags = RTLD_NOW;
+ if (local_binding) {
+ flags = flags | RTLD_LOCAL;
+-#if __linux__ && !__ANDROID__ && !__TBB_USE_SANITIZERS
++#if (__linux__ && __GLIBC__) && !__TBB_USE_SANITIZERS
+ flags = flags | RTLD_DEEPBIND;
+ #endif
+ } else {
diff --git a/dev-cpp/tbb/tbb-2021.5.0.ebuild b/dev-cpp/tbb/tbb-2021.5.0.ebuild
index 0a18fece5fd1..2ab975036c65 100644
--- a/dev-cpp/tbb/tbb-2021.5.0.ebuild
+++ b/dev-cpp/tbb/tbb-2021.5.0.ebuild
@@ -25,6 +25,7 @@ BDEPEND="virtual/pkgconfig"
PATCHES=(
# should be in.. 2022?
"${FILESDIR}"/${PN}-2021.4.0-lto.patch
+ "${FILESDIR}"/${PN}-2021.5.0-musl-deepbind.patch
)
src_configure() {