summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2017-08-23 12:27:31 -0400
committerCraig Andrews <candrews@gentoo.org>2017-08-23 12:28:18 -0400
commitee14e170f16813fd85379f7d5617db3b6c5b3b8d (patch)
tree22237dc966be54c15068eb08482141c326165c2b /dev-cpp/waylandpp
parentsys-libs/glibc: Version bump. Only build-tested, no keywords. (diff)
downloadgentoo-ee14e170f16813fd85379f7d5617db3b6c5b3b8d.tar.gz
gentoo-ee14e170f16813fd85379f7d5617db3b6c5b3b8d.tar.bz2
gentoo-ee14e170f16813fd85379f7d5617db3b6c5b3b8d.zip
dev-cpp/waylandpp: ebuild cleanup
Note that none of these changes modify the installed image or the ebuild metadata so no revbump is required. Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-cpp/waylandpp')
-rw-r--r--dev-cpp/waylandpp/waylandpp-0.1.0.ebuild15
-rw-r--r--dev-cpp/waylandpp/waylandpp-9999.ebuild15
2 files changed, 14 insertions, 16 deletions
diff --git a/dev-cpp/waylandpp/waylandpp-0.1.0.ebuild b/dev-cpp/waylandpp/waylandpp-0.1.0.ebuild
index a85f301bf9fd..846643b6113c 100644
--- a/dev-cpp/waylandpp/waylandpp-0.1.0.ebuild
+++ b/dev-cpp/waylandpp/waylandpp-0.1.0.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit multilib scons-utils toolchain-funcs versionator
+inherit scons-utils toolchain-funcs versionator
DESCRIPTION="Wayland C++ bindings"
HOMEPAGE="https://github.com/NilsBrause/waylandpp"
@@ -18,34 +18,33 @@ if [[ ${PV} == *9999 ]] ; then
else
SRC_URI="https://github.com/NilsBrause/waylandpp/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
- S="${WORKDIR}/waylandpp-${PV}"
fi
-COMMON_DEPEND="
+RDEPEND="
>=dev-libs/wayland-1.11.0
media-libs/mesa[wayland]
"
-DEPEND="${COMMON_DEPEND}
+DEPEND="${RDEPEND}
doc? (
app-doc/doxygen
media-gfx/graphviz
)
"
-RDEPEND="${COMMON_DEPEND}"
src_compile() {
- CC="$(tc-getCXX)" PKG_CONFIG="$(tc-getPKG_CONFIG)" escons
+ CC="$(tc-getCXX)" PKG_CONFIG="$(tc-getPKG_CONFIG)" PREFIX="${D%/}/usr" escons
if use doc; then
doxygen || die "error making docs"
fi
}
src_install() {
- PREFIX="${D%/}/usr" scons install
+ CC="$(tc-getCXX)" PKG_CONFIG="$(tc-getPKG_CONFIG)" PREFIX="${D%/}/usr" escons install
# fix multilib-strict QA failures
mv "${ED%/}"/usr/{lib,$(get_libdir)} || die
if use doc; then
doman doc/man/man3/*.3
- HTML_DOCS="doc/html" einstalldocs
+ local HTML_DOCS=( doc/html )
+ einstalldocs
fi
}
diff --git a/dev-cpp/waylandpp/waylandpp-9999.ebuild b/dev-cpp/waylandpp/waylandpp-9999.ebuild
index a85f301bf9fd..846643b6113c 100644
--- a/dev-cpp/waylandpp/waylandpp-9999.ebuild
+++ b/dev-cpp/waylandpp/waylandpp-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit multilib scons-utils toolchain-funcs versionator
+inherit scons-utils toolchain-funcs versionator
DESCRIPTION="Wayland C++ bindings"
HOMEPAGE="https://github.com/NilsBrause/waylandpp"
@@ -18,34 +18,33 @@ if [[ ${PV} == *9999 ]] ; then
else
SRC_URI="https://github.com/NilsBrause/waylandpp/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
- S="${WORKDIR}/waylandpp-${PV}"
fi
-COMMON_DEPEND="
+RDEPEND="
>=dev-libs/wayland-1.11.0
media-libs/mesa[wayland]
"
-DEPEND="${COMMON_DEPEND}
+DEPEND="${RDEPEND}
doc? (
app-doc/doxygen
media-gfx/graphviz
)
"
-RDEPEND="${COMMON_DEPEND}"
src_compile() {
- CC="$(tc-getCXX)" PKG_CONFIG="$(tc-getPKG_CONFIG)" escons
+ CC="$(tc-getCXX)" PKG_CONFIG="$(tc-getPKG_CONFIG)" PREFIX="${D%/}/usr" escons
if use doc; then
doxygen || die "error making docs"
fi
}
src_install() {
- PREFIX="${D%/}/usr" scons install
+ CC="$(tc-getCXX)" PKG_CONFIG="$(tc-getPKG_CONFIG)" PREFIX="${D%/}/usr" escons install
# fix multilib-strict QA failures
mv "${ED%/}"/usr/{lib,$(get_libdir)} || die
if use doc; then
doman doc/man/man3/*.3
- HTML_DOCS="doc/html" einstalldocs
+ local HTML_DOCS=( doc/html )
+ einstalldocs
fi
}