summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2018-06-02 17:52:51 +0200
committerJohannes Huber <johu@gentoo.org>2018-06-02 17:52:51 +0200
commitee604746b688a9631001dff1618b97dd4ad1aa46 (patch)
tree81e97985474d2691017d10c47563447592761307 /dev-cpp
parentdev-cpp/yaml-cpp: Remove 0.5.3 (r0) (diff)
downloadgentoo-ee604746b688a9631001dff1618b97dd4ad1aa46.tar.gz
gentoo-ee604746b688a9631001dff1618b97dd4ad1aa46.tar.bz2
gentoo-ee604746b688a9631001dff1618b97dd4ad1aa46.zip
dev-cpp/yaml-cpp: Remove 0.5.3-r1
Bug: https://bugs.gentoo.org/614850 Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/yaml-cpp/Manifest1
-rw-r--r--dev-cpp/yaml-cpp/files/yaml-cpp-0.5.3-gcc6.patch44
-rw-r--r--dev-cpp/yaml-cpp/yaml-cpp-0.5.3-r1.ebuild37
3 files changed, 0 insertions, 82 deletions
diff --git a/dev-cpp/yaml-cpp/Manifest b/dev-cpp/yaml-cpp/Manifest
index bac72aa90f89..4a2a21dbeb90 100644
--- a/dev-cpp/yaml-cpp/Manifest
+++ b/dev-cpp/yaml-cpp/Manifest
@@ -1,2 +1 @@
-DIST yaml-cpp-0.5.3.tar.gz 2016737 BLAKE2B 6c10d44fe04fdd81cd61c909acdb576834f5358dd44353723b04d8a42bf8a1312cfa752e445c84f93c6ce76358b2d42dee5263f6fbd47a1f928d1cd28aedef07 SHA512 5ed15fee3c6455c08e6bd8f74256b230f274ef18f8e144491e940640e41626517c7eaaf4a1f380c4179066a2a757c8a0f61878df9dc3caa15e37c4954be47fe0
DIST yaml-cpp-0.6.2.tar.gz 1396250 BLAKE2B be342c212c980cdb03349dbafbe1db0bb581123b4dd6909393d3cdc86145b997a9d2f9b57a5e9d7c8cc60cdfd03f1c37e9db610d8784f2d29fdeada5ab322894 SHA512 fea8ce0a20a00cbc75023d1db442edfcd32d0ac57a3c41b32ec8d56f87cc1d85d7dd7a923ce662f5d3a315f91a736d6be0d649997acd190915c1d68cc93795e4
diff --git a/dev-cpp/yaml-cpp/files/yaml-cpp-0.5.3-gcc6.patch b/dev-cpp/yaml-cpp/files/yaml-cpp-0.5.3-gcc6.patch
deleted file mode 100644
index 88ee25fa0acb..000000000000
--- a/dev-cpp/yaml-cpp/files/yaml-cpp-0.5.3-gcc6.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-Bug: https://bugs.gentoo.org/609176
-Upstream PR: https://github.com/jbeder/yaml-cpp/pull/514
-
-From a83a1b3a7bd0a5a4eb458d898b057f6a8d409b7e Mon Sep 17 00:00:00 2001
-From: Peter-Levine <plevine457@gmail.com>
-Date: Mon, 24 Jul 2017 02:00:24 -0400
-Subject: [PATCH] Fix segfault in gmock when running tests
-
-Taken from https://github.com/google/googletest/issues/705#issuecomment-235067917
----
- test/gmock-1.7.0/include/gmock/gmock-spec-builders.h | 6 ++++--
- 1 file changed, 4 insertions(+), 2 deletions(-)
-
-diff --git a/test/gmock-1.7.0/include/gmock/gmock-spec-builders.h b/test/gmock-1.7.0/include/gmock/gmock-spec-builders.h
-index 312fbe87..2dd733b6 100644
---- a/test/gmock-1.7.0/include/gmock/gmock-spec-builders.h
-+++ b/test/gmock-1.7.0/include/gmock/gmock-spec-builders.h
-@@ -1370,6 +1370,8 @@ class ActionResultHolder : public UntypedActionResultHolderBase {
- template <>
- class ActionResultHolder<void> : public UntypedActionResultHolderBase {
- public:
-+ explicit ActionResultHolder() {}
-+
- void GetValueAndDelete() const { delete this; }
-
- virtual void PrintAsActionResult(::std::ostream* /* os */) const {}
-@@ -1381,7 +1383,7 @@ class ActionResultHolder<void> : public UntypedActionResultHolderBase {
- const typename Function<F>::ArgumentTuple& args,
- const string& call_description) {
- func_mocker->PerformDefaultAction(args, call_description);
-- return NULL;
-+ return new ActionResultHolder();
- }
-
- // Performs the given action and returns NULL.
-@@ -1390,7 +1392,7 @@ class ActionResultHolder<void> : public UntypedActionResultHolderBase {
- const Action<F>& action,
- const typename Function<F>::ArgumentTuple& args) {
- action.Perform(args);
-- return NULL;
-+ return new ActionResultHolder();
- }
- };
-
diff --git a/dev-cpp/yaml-cpp/yaml-cpp-0.5.3-r1.ebuild b/dev-cpp/yaml-cpp/yaml-cpp-0.5.3-r1.ebuild
deleted file mode 100644
index 6bf29f127ca7..000000000000
--- a/dev-cpp/yaml-cpp/yaml-cpp-0.5.3-r1.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit cmake-utils
-
-DESCRIPTION="YAML parser and emitter in C++"
-HOMEPAGE="https://github.com/jbeder/yaml-cpp"
-SRC_URI="https://github.com/jbeder/${PN}/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-IUSE=""
-
-DEPEND=">=dev-libs/boost-1.49.0-r2:="
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${PN}-release-${PV}"
-
-PATCHES=( "${FILESDIR}"/${P}-gcc6.patch )
-
-src_prepare() {
- sed -i \
- -e 's:INCLUDE_INSTALL_ROOT_DIR:INCLUDE_INSTALL_DIR:g' \
- yaml-cpp.pc.cmake || die
-
- cmake-utils_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- -DBUILD_SHARED_LIBS=ON
- )
- cmake-utils_src_configure
-}